Unintended Spaces

Bug #928965 reported by Shabab Mustafa on 2012-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Avro Phonetic m17n
High
Shabab Mustafa

Bug Description

I am using Ibus 1.3.99.20110818 on Ubuntu 11.10

I am getting an extra unintended space after 'ng' -> 'ং'

i.e. বাং লা, ভাং আ, দাং গা,

Md. Enzam Hossain (ienzam) wrote :

Specific to any application or on all applications?

Md. Enzam Hossain (ienzam) wrote :

Oh thank you for reporting the bug :-)

Shabab Mustafa (shabab-mustafa) wrote :

So far tried Gedit, LibreOffice and Firefox.

After some more testing I found the whole map_other character list has same behavior.

I think the main problem lies in line: 178 in the mim file. While state_init hit the map_other characters, it's exiting the loop and not parsing the rest of the word. Thant's why that is counting the rest of the part as a new word and putting an extra space.

I believe throwing the map_other characters into an another state may solve the problem. Let me try that myself first.

I am assigning myself to resolve this bug for the time being.

Changed in avro-m17n:
status: New → In Progress
assignee: nobody → Shabab Mustafa (shabab-mustafa)
Md. Enzam Hossain (ienzam) wrote :

Thanks for the reply and your time.
I think you are correct, please add a dummy space line there and see if it solves the problem.

  ("9" "৯")
  ("`" "")
  (" " " ") ;;; this is the new entry
 )

Shabab Mustafa (shabab-mustafa) wrote :

Both solution worked. :-) Since declaring an extra space working fine then there is no point to add any extra load by another loop.

Md. Enzam Hossain (ienzam) wrote :

Thanks, then committing the changes to github :-)

Changed in avro-m17n:
status: In Progress → Fix Committed
Md. Enzam Hossain (ienzam) wrote :
Changed in avro-m17n:
importance: Undecided → High
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers