bq tablets should join bq warranty system

Bug #1579121 reported by John McAleely
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Critical
John McAleely
The Avila project
Fix Released
Critical
Penk Chen

Bug Description

BQ uses an online database to manage warranty information, as part of their customer service.

All their devices join this system, and to date, Ubuntu devices are operating without this.

Adding to the phones in the market is probably a bit late now, but for the recently launched tablets, BQ request they join this system.

The device needs to make a GET request for the following endpoint:

For testing:
http://devices-staging.bq.com/api/isAlive/$serial_number/$ota_version/1

For production:
http://devices.bq.com/api/isAlive/${SERIAL}/${OTAVERSION}/1

I believe the $serial_number is available from android properties, and $ota_version is available from system-image-cli

The request should only be made over wifi networks.

No user interface or interaction is required. BQ's android devices do this daily, which seems a bit excessive. Perhaps we should do it after a reboot, since OTA's regularly trigger reboots.

Revision history for this message
John McAleely (john.mcaleely) wrote :

Here's the implementation, which will be added to the custom tarball for the ubuntu-touch/*/bq-aquaris-pd.en channels

Changed in avila:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Penk Chen (penk)
milestone: none → 11
information type: Proprietary → Public
Revision history for this message
John McAleely (john.mcaleely) wrote :
Changed in avila:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → John McAleely (john.mcaleely)
milestone: none → 11
Revision history for this message
John McAleely (john.mcaleely) wrote :

As noted in #1, the opening comment was originally documenting the test url:

http://devices-staging.bq.com/api/isAlive/$serial_number/$ota_version/1

And we need to ship the production URL (#1 already is):

http://devices.bq.com/api/isAlive/${SERIAL}/${OTAVERSION}/1

description: updated
Revision history for this message
John McAleely (john.mcaleely) wrote :

Landed in rc-proposed last night in the end:

https://lists.launchpad.net/ubuntu-phone/msg20535.html

Changed in avila:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in avila:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers