[FHD] boot splash not in native orientation

Bug #1543495 reported by John McAleely
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
The Avila project
High
kevin gunn
Unity System Compositor
Critical
Alexandros Frantzis
0.4
Critical
Alexandros Frantzis
unity-system-compositor (Ubuntu)
Critical
Alexandros Frantzis

Bug Description

When the frieza is booted, the 'ubuntu + dots' splash from unity is displayed in portrait.

The natural (out of the box) orientation for this device is landscape.

I expected the splash to display in landscape.

Related branches

Changed in avila:
milestone: none → ww06-2016
status: New → Confirmed
information type: Proprietary → Public
Changed in avila:
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → ww08-2016
assignee: nobody → Kevin Gunn (kgunn)
assignee: Kevin Gunn (kgunn) → kevin gunn (kgunn72)
Michał Sawicz (saviq)
summary: - unity splash screen is portrait
+ boot splash not in native orientation
affects: unity8 (Ubuntu) → unity-system-compositor (Ubuntu)
kevin gunn (kgunn72)
Changed in unity-system-compositor (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Alexandros Frantzis (afrantzis)
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: boot splash not in native orientation

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-system-compositor (Ubuntu):
status: New → Confirmed
Changed in unity-system-compositor (Ubuntu):
status: Confirmed → In Progress
Changed in unity-system-compositor:
milestone: none → 0.5.0
assignee: nobody → Alexandros Frantzis (afrantzis)
status: New → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-system-compositor at revision 276, scheduled for release in unity-system-compositor, milestone 0.5.0

Changed in unity-system-compositor:
status: In Progress → Fix Committed
Revision history for this message
Alexandros Frantzis (afrantzis) wrote :

Packages for unity-system-compositor 0.4.2 that include the orientation improvements are here:

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-075/

I don't have the device, so I can't try on it, so please give the new version a try and let me know how it works for you.

Changed in unity-system-compositor:
importance: Undecided → Critical
milestone: 0.5.0 → 0.4.2
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed separate fixes landed in both branches. r276 in both cases.

Changed in avila:
assignee: nobody → kevin gunn (kgunn72)
kevin gunn (kgunn72)
Changed in unity-system-compositor (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-system-compositor - 0.4.2+16.04.20160211.2-0ubuntu1

---------------
unity-system-compositor (0.4.2+16.04.20160211.2-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * No-change rebuild.

unity-system-compositor (0.4.2+16.04.20160211-0ubuntu1) xenial; urgency=medium

  * Orient the spinner according to the native orientation of the device.
    (LP: #1543495)
  * Implement a stub cookie authority (LP: #1536662)

 -- Alexandros Frantzis <email address hidden> Thu, 11 Feb 2016 12:22:48 +0000

Changed in unity-system-compositor (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Revision history for this message
Javier Ibáñez (javier-ibanez) wrote :

Hi all,

This issue is reproducible in r31 fw version.

Best regards.

Revision history for this message
John McAleely (john.mcaleely) wrote : Re: [Bug 1543495] Re: boot splash not in native orientation

I believe it is fixed in r32, when you get that.

On 19 February 2016 at 15:14, Javier Ibáñez <email address hidden> wrote:

> Hi all,
>
> This issue is reproducible in r31 fw version.
>
> Best regards.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1543495
>
> Title:
> boot splash not in native orientation
>
> Status in The Avila project:
> Confirmed
> Status in Canonical System Image:
> Fix Committed
> Status in Unity System Compositor:
> Fix Committed
> Status in Unity System Compositor 0.4 series:
> Fix Committed
> Status in Unity System Compositor 0.5 series:
> Fix Committed
> Status in unity-system-compositor package in Ubuntu:
> Fix Released
>
> Bug description:
> When the frieza is booted, the 'ubuntu + dots' splash from unity is
> displayed in portrait.
>
> The natural (out of the box) orientation for this device is landscape.
>
> I expected the splash to display in landscape.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/avila/+bug/1543495/+subscriptions
>

Revision history for this message
Javier Ibáñez (javier-ibanez) wrote : Re: boot splash not in native orientation

Hi all,

This issue is still reproducible in r3 firmware version

Best regards.

summary: - boot splash not in native orientation
+ [FHD] boot splash not in native orientation
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
no longer affects: unity-system-compositor/0.5
Changed in unity-system-compositor:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers