Some puritine packaged apps don't open on some devices

Bug #1532858 reported by Victor Tuson Palau on 2016-01-11
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
Critical
kevin gunn
Canonical System Image
Critical
Stephen M. Webb
Libertine
Critical
Christopher Townsend
The Avila project
Critical
Unassigned
libertine (Ubuntu)
Critical
Christopher Townsend

Bug Description

Launch the libre office application from puritine v0.5 in Avila, it reports "The application cannot be started. Internal Error ocurred"
-------------------
fwiw, LO in puritine v5 is launching reliably on N4 and N7 with no issues.

Tags: ue Edit Tag help

Related branches

Changed in avila:
status: New → Confirmed
importance: Undecided → Critical
kevin gunn (kgunn72) wrote :

adding Björn in case he might also have ideas how to debug.

@Chris/Björn - since neither of you have devices, but this works on n4/n7, can you outline some debug instructions for Victor's team to follow?

description: updated
Changed in puritine:
importance: Undecided → Critical
Changed in canonical-pocket-desktop:
importance: Undecided → Critical
Changed in puritine:
assignee: nobody → Christopher Townsend (townsend)
Changed in canonical-pocket-desktop:
assignee: nobody → kevin gunn (kgunn72)
Changed in libreoffice (Ubuntu):
status: New → Opinion
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Jason Yen (jasonyen) on 2016-01-12
Changed in avila:
milestone: none → ww04-2016
Jason Yen (jasonyen) on 2016-01-12
tags: added: ue
Jason Yen (jasonyen) on 2016-01-12
Changed in avila:
milestone: ww04-2016 → ww02-2016

Default debug instructions (escalation order):
1/ start Libreoffice from shell
2/ start /usr/lib/libreoffice/program/soffice.bin directly
3/ strace /usr/lib/libreoffice/program/soffice.bin
4/ apt install libreoffice-dbg && gdb /usr/lib/libreoffice/program/soffice.bin

Christopher Townsend (townsend) wrote :

Could you please provide ~/.cache/upstart/application-legacy-puritine_libreoffice-startcenter_0.0-.log?

Chunsang Jeong (chunsang) wrote :
Jason Yen (jasonyen) on 2016-01-13
Changed in avila:
assignee: nobody → Christopher Townsend (townsend)
Christopher Townsend (townsend) wrote :

I think the important parts of the log are these:

[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed!
Warning: failed to read path from javaldx

Searching for those types of errors generally leads to permission problems on folders. However, I've been looking at the folders and the permissions look correct, so I'm still stumped.

Debugging continues...

Changed in puritine:
status: New → In Progress
Changed in avila:
status: Confirmed → In Progress

As a temporary workaround, we need to disable seccomp when running proot. Still need to figure out why this is the case, but making a temporary fix in Libertine will take care of this.

Changed in libertine:
status: New → In Progress
Changed in puritine:
status: In Progress → Invalid
Changed in libreoffice (Ubuntu):
status: Opinion → Invalid
Changed in libertine:
importance: Undecided → Critical
assignee: nobody → Christopher Townsend (townsend)
status: In Progress → Fix Committed
Changed in libertine (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Christopher Townsend (townsend)
John McAleely (john.mcaleely) wrote :

awesome news. Which parts do we need to update to use this workaround?

I need to get a silo for Libertine and then get it in the overlay PPA and then it will be picked up in an image build.

John McAleely (john.mcaleely) wrote :

ok, sounds good. can you be sure to email me a silo number when it's ready.

John McAleely (john.mcaleely) wrote :

Silo 13 works for me.

Changed in avila:
milestone: ww02-2016 → ww04-2016
John McAleely (john.mcaleely) wrote :

So, with Silo 13 installed, I can open firefox and browse to www,.ubuntu.com (after seeing the mozilla welcome page). In Libreoffice I opened Impress, and created a new (blank) presentation. Edited a slide and then saved it to Documents.

I could then close libreoffice, re-open it and open the saved slide from the document picker it presented.

Given the workaround, is there anything specific to check?

summary: - [Avila] Libre office not working
+ Some puritine packaged apps don't open on some devices
Changed in canonical-pocket-desktop:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine - 0.99.8+16.04.20160114.1-0ubuntu1

---------------
libertine (0.99.8+16.04.20160114.1-0ubuntu1) xenial; urgency=medium

  [ Chris Townsend ]
  * Various fixes for making LXC containers work.
  * Refactor libertine-launch to have no explicit dependencies on
    either the LXC or chroot backends. Move specific functions to
    their respective backends.
  * Refactor the discovery of the type of container being used, so
    it's taken care inside of the class.
  * Add new libertine-launch tests.
  * Allow LXC containers access to /dev/dri devices since some X apps
    like to talk to them directly.
  * Fix Depends so that the lxc backend will be installed by default
    if the kernel supports it. Otherwise, fall back to the chroot
    backend.
  * As a temporary fix, disable seccomp when running proot. Fixes
    incompatible kernels. (LP: #1532856, #1532858)

  [ Stephen M. Webb ]
  * libertine-container-manager: added list-apps command
  * python/libertine/AppDiscovery.py: new module for app discovery

  [ CI Train Bot ]
  * No-change rebuild.

 -- Christopher Townsend <email address hidden> Thu, 14 Jan 2016 18:53:40 +0000

Changed in libertine (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → Critical
milestone: none → ww04-2016
status: New → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in avila:
status: In Progress → Fix Committed
tags: added: lt-blocker
kevin gunn (kgunn72) on 2016-02-09
Changed in canonical-pocket-desktop:
status: In Progress → Fix Released
Changed in libertine:
status: Fix Committed → Fix Released
Changed in avila:
status: Fix Committed → Fix Released
Changed in avila:
assignee: Christopher Townsend (townsend) → nobody
status: Fix Released → Fix Committed
kevin gunn (kgunn72) on 2016-02-10
no longer affects: puritine
no longer affects: libreoffice (Ubuntu)
tags: removed: lt-blocker
Stephen M. Webb (bregma) on 2016-07-30
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers