Bluetooth keyboard is configured with wrong keyboard layout

Bug #1491340 reported by Thibaut Brandscheid on 2015-09-02
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
High
Michał Sawicz
Canonical System Image
High
Michał Sawicz
The Avila project
High
Michał Sawicz
bluez (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange
unity8 (Ubuntu)
High
Lukáš Tinkl

Bug Description

Phone: Meizu MX4 (15.04 r4)
OS Language: German

What you expected to happen:
When connecting a Bluetooth keyboard I expect that the keyboard layout is the same as the keyboard hardware key layout (German) or that it is possible to change the keyboard layout in the Bluetooth setting for the connected Bluetooth device.

What happened instead:
The Bluetooth keyboard worked, but wasn't set to German key layout. In the Bluetooth device setting I couldn't find any option to change the Bluetooth keyboard key layout.

Related branches

Simon Fels (morphis) on 2015-09-02
summary: - wrong keyboard layout
+ Bluetooth keyboard is configured with wrong keyboard layout
tags: added: bluetooth
Simon Fels (morphis) wrote :

From what I hear from the Mir/UI guys this is something which isn't implemented yet on their side. BlueZ itself doesn't have any control over this as its just exposing an input device which is then configured and used by the UI.

Changed in bluez (Ubuntu):
status: New → Invalid
Gerry Boland (gerboland) on 2015-09-02
Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2016-01-20
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
status: In Progress → New
Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Michał Sawicz (saviq) wrote :

This is blocked by bug #1530946 atm.

Changed in canonical-devices-system-image:
milestone: none → ww04-2016
assignee: nobody → Michał Sawicz (saviq)
importance: Undecided → High
status: New → Triaged
Changed in canonical-pocket-desktop:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Michał Sawicz (saviq)
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Jonas G. Drange (jonas-drange)
Changed in unity8 (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
Michał Sawicz (saviq) on 2016-01-22
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Changed in canonical-pocket-desktop:
status: Triaged → In Progress
Changed in avila:
assignee: nobody → Michał Sawicz (saviq)
status: New → In Progress
Changed in avila:
importance: Undecided → High
milestone: none → ww06-2016
Changed in canonical-devices-system-image:
milestone: ww04-2016 → ww08-2016
tags: added: bq-feedback
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20160323-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20160323-0ubuntu1) xenial; urgency=medium

  [ jonas-drange ]
  * Add External Keyboard panel which allows for configuration of the
    default keymap. (LP: #1524400, #1491340)

 -- Michael Zanetti <email address hidden> Wed, 23 Mar 2016 08:46:55 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.04.20160323.2-0ubuntu1

---------------
unity8 (8.12+16.04.20160323.2-0ubuntu1) xenial; urgency=medium

  [ Michael Terry ]
  *
  * Fix setting OSK layout in OOBE wizard
  * Stop the left edge tutorial from being shown when the bottom edge
    tutorial wants to be shown after receiving a call.

  [ Albert Astals Cid ]
  * Filter implementation with Option Selector filter as the only filter
  * Get the engine from the parent context
  * Implement the API changes due to filters
  * Match design visuals for the new dash navigation/page header popup
  * New Dash Navigation UX
  * Range Input filter
  * Value slider filter
  * Workaround SDK ListItem bug

  [ Albert Astals Cid, Lukáš Tinkl ]
  * Fix various tests

  [ CI Train Bot ]
  * Resync trunk.
  * Update translation template

  [ Lukáš Tinkl, Michael Terry ]
  * New first-run wizard for the phone (part of the OOBE effort) (LP:
    #1536688, #1536617, #1543790, #1555222)

  [ Lukáš Tinkl, Michał Sawicz ]
  * Keymap switching support (LP: #1524400, #1412492, #1491340)

  [ Michael Terry, Michael Zanetti ]
  * Redesign the first-boot edge tutorial

  [ Michael Zanetti ]
  * disabling some tests that are flaky in adt but can't be made fail on
    our machines

  [ Michael Zanetti, Michał Sawicz ]
  * Change the behavior alond with the switch in indicator-display (LP:
    #1538591)

  [ Michael Zanetti, Michał Sawicz, Nick Dedekind ]
  * Add support for low shell chrome. (LP: #1535397)
  * Sidestage load/unload redesign (LP: #1544479)

 -- Michael Zanetti <email address hidden> Wed, 23 Mar 2016 09:53:17 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-pocket-desktop:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Tomas Öqvist (tomoqv) wrote :

I tried this today on my Nexus 4 (rc-proposed-pd r179) and Swedish keyboard layout works with the Ubuntu Touch apps, but not Gedit and LibreOffice. With those apps the English layout remains. I haven't tried Firefox yet.

Michał Sawicz (saviq) wrote :

Tomas, that's quite likely - can you please file a new bug against unity8 for this? Thank you.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers