Default font to embed subtitles does not exist in Ubuntu

Bug #222773 reported by Kevin on 2008-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Avidemux
New
Undecided
Unassigned
avidemux (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: avidemux

When trying to embed subtitles in a video the default font that comes in Avidemux does not exist. Although you can select a new one, this can be a possible problem for someone without experience in GNU/Linux.

I made a patch that would change the default font for someone I believe it is included by default in Ubuntu.

( FreeMono.ttf )

Related branches

Andrew Hunter (rexbron) wrote :

It is great that you submitted a patch to Ubuntu, but I think this bug is much better filed upstream.

Also, just based on reading the diff, isn't hardcoding the font path into the source a bad idea for portability. Really it should just use generic system fonts, but perhaps it is more complicated than that. :)

2008/5/1 Andrew Hunter <email address hidden>:

> It is great that you submitted a patch to Ubuntu, but I think this bug
> is much better filed upstream.

That is true, but as you say carries a risk of loss of portability. As far
as I believe that changes must be made in the deb package.

I do not think that the program authors applied the patch to upstream
because a single operating system that font does not exist.

Also, just based on reading the diff, isn't hardcoding the font path
> into the source a bad idea for portability. Really it should just use
> generic system fonts, but perhaps it is more complicated than that. :)

Frankly, I chose this font because it was the first I saw. I do not know
much about font/O.S. If you know a better font you are free to modify the
patch.

Changed in avidemux:
status: New → Confirmed
Maia Everett (linneris) on 2008-05-09
Changed in avidemux:
importance: Undecided → Low
status: Confirmed → Triaged

Sorry, but I do not understand because it does not apply this patch.

If you know a better font you are free to modify the patch.

Changed in avidemux:
status: Triaged → Fix Committed
Maia Everett (linneris) on 2008-05-10
Changed in avidemux:
status: Fix Committed → Confirmed
Maia Everett (linneris) on 2008-05-10
Changed in avidemux:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.4.1-0.2ubuntu2

---------------
avidemux (1:2.4.1-0.2ubuntu2) intrepid; urgency=low

  * Added debian/patches/03_missing-asm-naming.patch:
    - Fix build failure with GCC 4.3.
    - Patch by Sergey Dryabzhinsky, taken from Gentoo bug 213099.
  * Added debian/patches/04_alsa-device.patch:
    - Change the default ALSA device from "plughw:0,0" to "pulse" (LP: #215560).
      Upstream might consider using "default" instead.
  * Added debian/patches/05_subtitle-font.patch:
    - Change the default subtitle font to DejaVu Sans. (LP: #222773)
    - Modified patch by Festor Wailon Dacoba.
  * debian/rules:
    - Delete config.h.in in clean.

 -- Matvey Kozhev <email address hidden> Sat, 10 May 2008 12:37:45 +0700

Changed in avidemux:
status: Fix Committed → Fix Released

Thanks! :D

Alecz20 (alexguzu) wrote :

I find that this bug still occurs on Avidemux 2.4.3

I stopped using Avidemux just for the reason that the subtitle feature did not work! Now I see there is a fix somehow, but I don't understand how to use the .diff file to patch it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments