Re-enable non-visual component exporting in autopilot-qt

Bug #1273956 reported by Timo Jyrinki on 2014-01-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Autopilot
Critical
Christopher Lee
Autopilot Qt Support
Critical
Christopher Lee

Bug Description

It seems all autopilot tests so far seem to fail when run with Qt 5.2. The test app seems to be starting but eventually the failure happens as shown in the attached simple test log (Friends app).

You can upgrade the device to Qt 5.2 currently with the following instructions: http://pastebin.ubuntu.com/6826187/. Desktop is upgradeable simply by adding the PPA and update + dist-upgrade (although currently losing the Qt Creator Ubuntu plugin).

I filed bug #1273720 against unity8 already yesterday, but it seems all AP tests tend to fail, so it's not unity8 specific.

The PPA (https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+packages) has autopilot-qt successfully recompiled against Qt 5.2.

All fixes should be made so that both Qt 5.0.2 and Qt 5.2 continue to work, ie usage of #ifdef:s or similar constructions.

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

The binding loop problem seen in messaging app is on the UI Toolkit side, bug #1204453 bumped now to Critical because it affects Qt 5.2 more.

Timo Jyrinki (timo-jyrinki) wrote :

Chris Lee had two quick thoughts on IRC:

"Is it perhaps an AppArmor issue? Looks like there is a dbus exception happening"

and

"Is it possible that in this new version Qt have removed the ability to load the testability driver? I know we had to patch something in at some stage, but I'm not sure of the specifics off the top of my head"

To the latter I'm able to answer that the load_testability_from_env_var.patch is still being applied (the support for QT_LOAD_TESTABILITY environment variable), but it's possible something has changed in the testability driver otherwise.

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

Christopher at it again. It seems https://code.launchpad.net/~veebers/autopilot-qt/backout-latest-change/+merge/203880 was helpful! Friends app AP passed now. Hopefully we'll get to proper QA validation now.

Changed in autopilot:
assignee: nobody → Christopher Lee (veebers)
Thomi Richards (thomir) on 2014-02-04
Changed in autopilot:
status: New → Fix Released
Changed in autopilot-qt:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Christopher Lee (veebers)
summary: - autopilot/phablet-test-run does not seem to work with Qt 5.2
+ Re-enable non-visual component exporting in autopilot-qt
Changed in autopilot-qt:
status: Confirmed → Fix Released
Thomi Richards (thomir) wrote :

Hi,

This is not fixed, or released yet - The 5.2 issue works, but this bug is to track the status of exporting non-visual components from Qt.

Changed in autopilot-qt:
status: Fix Released → Triaged
Pat McGowan (pat-mcgowan) wrote :

Can we remove the qt5.2 tag then? Is it still critical?

Changed in autopilot:
status: Fix Released → Confirmed
Thomi Richards (thomir) wrote :

Done :)

Thanks

tags: removed: qt5.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers