Autopilot cannot access MediaPlayer component

Bug #1269578 reported by Andrew Hayzen on 2014-01-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Autopilot Qt Support
Critical
Christopher Lee
autopilot-qt (Ubuntu)
Undecided
rosa maria

Bug Description

When trying to access properties off a MediaPlayer while writing an autopilot test it became apparent that autopilot cannot find the MediaPlayer component.

I have made an example application which is the SimpleUI with the addition of a MediaPlayer component. Within the autopilot tests it attempts to access the property currentIndex but fails to find the MediaPlayer with the following error:
StateNotFoundError: State not found for class '*' and filters {'objectName': 'player'}

I have linked two branches to this bug report, one being the example application and one being the MP for the music-app in which this issue was found.

Related branches

Changed in autopilot-qt:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Thomi Richards (thomir)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:autopilot-qt at revision 77, scheduled for release in autopilot-qt, milestone Unknown

Changed in autopilot-qt:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:autopilot-qt/1.4 at revision 77, scheduled for release in autopilot-qt, milestone Unknown

We had to back out the fix, so I've reset the bug status.

Changed in autopilot-qt:
status: Fix Committed → Confirmed
assignee: Thomi Richards (thomir) → Christopher Lee (veebers)
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autopilot-qt - 1.4+14.04.20140303-0ubuntu1

---------------
autopilot-qt (1.4+14.04.20140303-0ubuntu1) trusty; urgency=low

  [ Thomi Richards ]
  * Export QObject children of Qml items. (LP: #1269578)

  [ Timo Jyrinki ]
  * Fix tab/space whitespace in debian/control.

  [ Christopher Lee ]
  * Backing out recent change that introduces issues on devices.
  * Re-implement (w/ fixes) exporting QObject children of Qml items
    (including non-visual items). (LP: #1269578)
 -- Ubuntu daily release <email address hidden> Mon, 03 Mar 2014 04:42:27 +0000

Changed in autopilot-qt (Ubuntu):
status: New → Fix Released
Changed in autopilot-qt (Ubuntu):
assignee: nobody → rosa maria (rprosamaria383)
Andrew Hayzen (ahayzen) wrote :

Did this fix ever land? As I am unable to access things such as the following in QML from autopilot.

Item {
  property var currentMeta: ({})
}

It appears to have landed more than a year ago. If the problem remains in
current versions, we may want to open a new bug.

On Sat, Jan 2, 2016 at 1:06 PM, Andrew Hayzen <email address hidden>
wrote:

> Did this fix ever land? As I am unable to access things such as the
> following in QML from autopilot.
>
> Item {
> property var currentMeta: ({})
> }
>
> --
> You received this bug notification because you are a member of Autopilot
> Hackers, which is subscribed to Autopilot Qt Support.
> https://bugs.launchpad.net/bugs/1269578
>
> Title:
> Autopilot cannot access MediaPlayer component
>
> Status in Autopilot Qt Support:
> Confirmed
> Status in autopilot-qt package in Ubuntu:
> Fix Released
>
> Bug description:
> When trying to access properties off a MediaPlayer while writing an
> autopilot test it became apparent that autopilot cannot find the
> MediaPlayer component.
>
> I have made an example application which is the SimpleUI with the
> addition of a MediaPlayer component. Within the autopilot tests it attempts
> to access the property currentIndex but fails to find the MediaPlayer with
> the following error:
> StateNotFoundError: State not found for class '*' and filters
> {'objectName': 'player'}
>
> I have linked two branches to this bug report, one being the example
> application and one being the MP for the music-app in which this issue
> was found.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/autopilot-qt/+bug/1269578/+subscriptions
>

Changed in autopilot-qt:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers