Trailing dot in fqdn of ps5 VMs regresses some tests (e.g. postfix)

Bug #2019472 reported by Paride Legovini
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Auto Package Testing
Fix Released
Undecided
Paride Legovini

Bug Description

On ps5 amd64 VMs (lcy02) we have that:

$ hostname --fqdn
adt-paride-mantic-postfix.openstack.prodstack5.lan.

Note the trailing dot. This causes regressions in some packages, see for example LP: #2019195. Ideally we should fix the regressed packages (the trailing dot is technically correct), but it makes sense to workaround the problem while the packages are getting fixed. Some possibilities are:

(1) Remove `manage_etc_hosts: true` from the cloud-init user-data used by the create-nova-image-new-release script. This should prevent the hostname to be set to the name advertised by openstack, and left to the static string 'autopkgtest'. I did some git archeology and manage_etc_hosts initially came from this snippet:

# unbreak my server option :-(
userdata=`mktemp`
trap "rm $userdata" EXIT TERM INT QUIT PIPE
/bin/echo -e "#cloud-config\nmanage_etc_hosts: True" > $userdata

and that was the *only* use of user-data back then. Looks like it was a workaround for some issue? In any case I can't be sure that disabling manage_etc_hosts won't cause other issues.

(2) Remove the trailing dot in /etc/hosts using the setup-canonical.sh script, e.g.

  sed -Ei '/^127\.0\.1\.1 /s/([a-z])\. /\1 /' /etc/hosts

I don't think this can be racey with cloud-init reconfiguring the hostname because testbed-setup removes cloud-init. Cons of this approach: very hacky. We ask cloud-init to manage /etc/hosts (via manage_etc_hosts), but then mangle it manually (not nice).

Related branches

Paride Legovini (paride)
description: updated
Revision history for this message
Paride Legovini (paride) wrote :

Postfix is not trivial to fix, see discussion on:

https://bugs.launchpad.net/ubuntu/+source/postfix/+bug/2019195

As discussed we're moving ahead with solution (2).

Revision history for this message
Paride Legovini (paride) wrote :

We now need to update the charm.

Changed in auto-package-testing:
status: New → Fix Committed
Paride Legovini (paride)
Changed in auto-package-testing:
assignee: nobody → Paride Legovini (paride)
Revision history for this message
Brian Murray (brian-murray) wrote :

This has landed in production now.

Changed in auto-package-testing:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.