audio quake crashes in 1st tutorial map

Bug #178229 reported by Juan Hernandez on 2007-12-23
2
Affects Status Importance Assigned to Milestone
AudioQuake
Critical
matatk

Bug Description

I load adio quake.
type tut at the console.
enter 1st tut map.
go through the door, and I here tts say passing through door to slip gate or something like that.
I walk forward a bit, and I start hereing a beep.
I hit spacebar I think to g to the next level, and I get a send error message, it says that zquake-vidnull.exe or something like that crashes.

matatk (matatk) wrote :

Please can you tell us exactly what the error message says (it should be possible to load a screen reader to read it)? It could be a firewall message and not a crash.

The following are notes for the developers.

If we find out that it is a crash from the user, then I suspect that this is being caused by the loading screen being displayed. It seems to make sense to change cl_screen.c to (hopefully) fix this problem. The current VIDNULL conditions around the body of SCR_DrawPause should probably be moved from there to the two (GL and non-GL) bodies of the SCR_UpdateScreen function. The first logical place to try is around the ``if scr_loading'' test, but maybe we could achieve wider success by widening the net.

To test it's actually working (i.e. really not drawing stuff) we can temporarily define VIDNULL in the GL build -- I think that should work.

Unfortunately I won't be able to test any of this until I get back to work on the 2nd of January at the earliest because I don't have a Windows box here.

Its an actual crash...

The file is zquakevidnull.exe I think.

I am realizing it crashes at the end of each map when I load different
tutorial maps.

How can I get the exact error? Its one of those send information tomicrosoft
error dialogs.

THanks

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Matthew Tylee Atkinson
Sent: Sunday, December 23, 2007 7:58 AM
To: <email address hidden>
Subject: [Bug 178229] Re: audio quake crashes in 1st tutorial map

Please can you tell us exactly what the error message says (it should be
possible to load a screen reader to read it)? It could be a firewall
message and not a crash.

The following are notes for the developers.

If we find out that it is a crash from the user, then I suspect that this is
being caused by the loading screen being displayed. It seems to make sense
to change cl_screen.c to (hopefully) fix this problem. The current VIDNULL
conditions around the body of SCR_DrawPause should probably be moved from
there to the two (GL and non-GL) bodies of the SCR_UpdateScreen function.
The first logical place to try is around the ``if scr_loading'' test, but
maybe we could achieve wider success by widening the net.

To test it's actually working (i.e. really not drawing stuff) we can
temporarily define VIDNULL in the GL build -- I think that should work.

Unfortunately I won't be able to test any of this until I get back to work
on the 2nd of January at the earliest because I don't have a Windows box
here.

--
audio quake crashes in 1st tutorial map
https://bugs.launchpad.net/bugs/178229
You received this bug notification because you are a direct subscriber of
the bug.

matatk (matatk) wrote :

Thanks for the extra information. I gathered that the crash dialogue box may explain the cause of the crash but from your description I can see it might be difficult to get that information out. Perhaps Sebby will know (he's automatically been notified of the bug).

I think it's fairly likely that the problem is the loading screen being drawn between levels, which is a bit annoying as I thought we'd already fixed that but when I looked at the code, I couldn't find the fix in there. Anyway, I think I've been able to come up with a better solution than we had before, so all should be well when I get to actually alter the engine code in very early January.

Whilst you're waiting for this problem to be fixed, you could try running the OpenGL version of the game (this is the version that actually produces 3D graphical output, as opposed to the vidnull version, which doesn't produce any graphical output), which won't crash if I'm right about the cause of the crash in the vidnull version. You can ask the game launcher to use the OpenGL version by choosing the Rendering Options main menu item, then choosing the OpenGL version of the game in the Rendering Options submenu.

You will have to make sure your screen reader/magnifier (if you use one) is disabled before running the OpenGL version of the game. Hopefully that will work for you until we can fix this bug.

Thanks for your time and input so far!

Changed in audioquake:
assignee: nobody → matatk
importance: Undecided → Critical
milestone: none → 0.3.0
matatk (matatk) wrote :

I've now fixed and tested this -- it was the loading screen and it should now work fine.

Changed in audioquake:
status: New → Fix Released
Juan Hernandez (juanh) wrote :

How do I get the aq with this fix in it? Is there a new release on the
website?

thx

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Matthew Tylee Atkinson
Sent: Wednesday, January 02, 2008 12:06 PM
To: <email address hidden>
Subject: [Bug 178229] Re: audio quake crashes in 1st tutorial map

I've now fixed and tested this -- it was the loading screen and it should
now work fine.

** Changed in: audioquake
       Status: New => Fix Released

--
audio quake crashes in 1st tutorial map
https://bugs.launchpad.net/bugs/178229
You received this bug notification because you are a direct subscriber of
the bug.

matatk (matatk) wrote :

On Thu, 2008-01-03 at 17:29 +0000, Juan Hernandez wrote:
> How do I get the aq with this fix in it? Is there a new release on the
> website?

Yes; if you go to http://www.agrip.org.uk/download/ you can get it
there.

best regards,

--
Matthew Tylee Atkinson <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers