doesn't save additional settings

Bug #1159341 reported by Mike on 2013-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Audio Recorder
Medium
moma

Bug Description

If I set Show icon on the system tray to OFF, it turns back to ON after rebooting. Xubuntu 12.10+Mate1.4

Mike (mikecom) on 2013-03-24
summary: - audio recorder doesn't save additional settings
+ doesn't save additional settings
Mike (mikecom) on 2013-03-24
description: updated
description: updated
moma (osmoma) on 2013-03-24
Changed in audio-recorder:
assignee: nobody → moma (osmoma)
importance: Undecided → Medium
moma (osmoma) wrote :

Hello,
Thanks for your reboot.
Yes, you are right. The settings pops ON after logout or reboot.
I need to investigate why this happens.

You can also see the settings in dconf-editor. Browse to apps -> audio-recorder
$ dconf-editor
Install first dconf-tools package.

One can also list the values with
$ dconf dump /apps/audio-recorder/

moma (osmoma) wrote :

Thanks for your *report*.

Changed in audio-recorder:
status: New → Confirmed
moma (osmoma) wrote :

Re-hi,
The error is obviously in src/auto-start.c module, function autostart_set(...).

// Create Exec line; "audio-recorder --show-window=0 --show-icon=1".
// It hides the main window and shows the systray icon.
gchar *cmd = g_strdup_printf("%s --show-window=0 --show-icon=1", PACKAGE);
g_key_file_set_string(key_file, G_KEY_FILE_DESKTOP_GROUP, G_KEY_FILE_DESKTOP_KEY_EXEC, cmd);
g_free(cmd);

Also src/main.c needs some changes, because it should not save the --show-icon=? value in GSettings (dconf).

I will fix this in Raring 13.04, and maybe in 12.10. I have not developed for 12.10 for ages.

Mike (mikecom) wrote :

Hi, I'm sorry if I haven't understood all the things you had suggested to correct in your post as I'm rather a noob in Linux, but the fact you mentioned Autostat gave me a hint, so I went into Startup Applications and just unmarked Audio Recorder. Since that the icon doesn't appear anymore on the panel, that's actually what I wanted to get. Thank you!

moma (osmoma) wrote :

I made some changes to the code so it respects option for the systray icon (in settings).
You may need to visit the settings and set the options ON/OFF at least once so the corresponding files are updated.

I have now pushed the updated code to the launchpad.
New packages for Ubuntu 13.04 will follow within the next couple of days.

Changed in audio-recorder:
status: Confirmed → Fix Committed
moma (osmoma) wrote :

The options for autostart and systray icon need some more work. I will review the code once more. I'll be back later.

moma (osmoma) wrote :

Hello,
This solution works better.
http://bazaar.launchpad.net/~osmoma/audio-recorder/trunk/revision/319

New packages for Ubuntu 13.04 will follow within the next couple of days.

moma (osmoma) wrote :

Hi,
Packages for Ubuntu 13.04 have been updated with audio-recorder v1.1.1.

You can update your version with:
$ sudo apt-get update
$ sudo apt-get upgrade

Please test and report your findings.

Changed in audio-recorder:
status: Fix Committed → Fix Released
Mike (mikecom) wrote :

Hi, to my mind it works fine in 13.04. Thanks a lot

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers