Dee and Unity GI overrides fail to import with pygobject 2.28.3-1

Bug #742350 reported by James Gifford on 2011-03-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
AskUbuntu Lens
High
Unassigned
libunity
Fix Released
Medium
Ken VanDine
dee (Ubuntu)
Medium
Ken VanDine
libunity (Ubuntu)
Medium
Ken VanDine

Bug Description

11.04, ran "sudo apt-get update && sudo apt-get upgrade -y" and now " unity-askubuntu-daemon" crashes constantly. screenshot: http://i.imgur.com/ZENkS.jpg

Package version: 0.1-0~19~natty1

Changed in askubuntu-lens:
status: New → Incomplete
James Gifford (jamesgifford) wrote :

What I get when I run the daemon from the command line.

$ python /usr/lib/unity-place-askubuntu/unity-askubuntu-daemon
Traceback (most recent call last):
  File "/usr/lib/unity-place-askubuntu/unity-askubuntu-daemon", line 321, in <module>
    daemon = Daemon()
  File "/usr/lib/unity-place-askubuntu/unity-askubuntu-daemon", line 93, in __init__
    sections_model.set_schema("s", "s")
AttributeError: 'SharedModel' object has no attribute 'set_schema'
$

Changed in askubuntu-lens:
importance: Undecided → High
status: Incomplete → Invalid
Ken VanDine (ken-vandine) wrote :

pygobject 2.28.3-1 dropped pysupport which has been deprecated, and now uses dh_python2. This broke imports for both Dee and Unity overrides.

Changed in dee (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
Changed in libunity (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
summary: - " unity-askubuntu-daemon" crashes with latest updates
+ Dee and Unity GI overrides fail to import with pygobject 2.28.3-1
Changed in dee (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in libunity (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in dee (Ubuntu):
importance: Undecided → Medium
Changed in libunity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 3.6.8-0ubuntu2

---------------
libunity (3.6.8-0ubuntu2) natty; urgency=low

  * debian/rules
    - Move from pysupport (which is being deprecated) to dh_python2, we need
    to match pygobject for GI override imports to work properly (LP: #742350)
 -- Ken VanDine <email address hidden> Fri, 25 Mar 2011 11:27:39 -0400

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 0.5.16-0ubuntu5

---------------
dee (0.5.16-0ubuntu5) natty; urgency=low

  * debian/rules
    - Move from pysupport (which is being deprecated) to dh_python2, we need
    to match pygobject for GI override imports to work properly (LP: #742350)
 -- Ken VanDine <email address hidden> Fri, 25 Mar 2011 11:23:42 -0400

Changed in dee (Ubuntu):
status: New → Fix Released
Changed in libunity (Ubuntu):
status: New → Fix Released
Changed in libunity:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers