test-stamp-propagation fails on ABCL

Bug #1704254 reported by Robert P. Goldman on 2017-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ASDF
Undecided
Faré
Plan
Undecided
Faré

Bug Description

Tested on both ABCL 1.4.0 and !.5.0

Relevant failure information is:

XXX :LOADING :SYSTEM
; Loading /home/rpg/common-lisp/asdf/build/fasls/abcl-1.4.0-fasl42-linux-x64/asdf/test/stamp-propagation/file2.abcl ...
XXX :LOAD-TOPLEVEL :FILE2
; Loaded /home/rpg/common-lisp/asdf/build/fasls/abcl-1.4.0-fasl42-linux-x64/asdf/test/stamp-propagation/file2.abcl (0.001\
 seconds)
EVAL-NOTES ((:COMPILING :SYSTEM) (:LOAD-TOPLEVEL :FILE1) (:COMPILE-TOPLEVEL :FILE2) (:LOADING :SYSTEM) (:LOAD-TOPLEVEL :FIL\
E2))
cleaning up
TEST ABORTED: Expression (TEST-DEFSYSTEM :ASDF) fails to raise condition ERROR, instead returning NIL

Robert P. Goldman (rpgoldman) wrote :

Note this is for the "plan" branch.

Changed in asdf:
assignee: nobody → Faré (fahree)
Faré (fahree) wrote :

I can confirm that this test works on master (commit 5eca374) and fails on plan (commit 3e827d1) using ABCL 1.3.2.

Faré (fahree) wrote :

I believe the issue is related to asdf-test not enabling the asdf-cache (now asdf-session) by default anymore, which for some reason makes the test fail on ABCL and XCL (an issue I didn't investigate too deeply, but that isn't a regression).

I pushed a fix.

Changed in asdf:
milestone: none → 3.3
status: New → Fix Committed
Changed in asdf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers