ASDF manual and loaded systems

Bug #1235091 reported by Michael Wells
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ASDF
Low
Unassigned

Bug Description

In section 4.2 of the ASDF manual:

"For the advanced users, note that require-system calls load-system with keyword arguments :force-not (loaded-systems). loaded-systems returns a list of the names of loaded systems. load-system applies operate with the operation from *load-system-operation*, which by default is load-op, the system, and any provided keyword arguments."

The argument to :force-not should be (already-loaded-systems) not (loaded-systems).

Also, it would be nice if (already-loaded-systems) was explained somewhere in the manual.

Revision history for this message
Faré (fahree) wrote :

The manual was correct when written.

At some later point, I renamed loaded-systems to already-loaded-systems, because it was otherwise messing with my SLIME completion when most of the time I intended load-system.

Yes, there are many things that would be nice to document. Good luck. At least, the source is readable, now.

Changed in asdf:
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Robert P. Goldman (rpgoldman) wrote : Re: [Bug 1235091] Re: ASDF manual and loaded systems

You should feel encouraged to fix such things yourself and provide patches. If that is too much work (mastering TeXinfo can be a slog), feel free to post a textual patch here, and I will turn it into TeXinfo and merge it.

Revision history for this message
Robert P. Goldman (rpgoldman) wrote :

OK, pushed in a quick patch that replaces LOADED-SYSTEMS with ALREADY-LOADED-SYSTEMS, and adds the latter to the findex.

I'm going to call that good, but welcome more thorough documentation submissions.

Changed in asdf:
status: Confirmed → Fix Committed
milestone: none → 3.0.3
Changed in asdf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers