cbd doesn't notice if a bug has been made a duplicate of another

Bug #913869 reported by Brian Murray on 2012-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
arsenal
High
Brian Murray

Bug Description

In the event that a bug report is made a duplicate of another cbd doesn't notice this.

468 elif last_update > string_to_date(recorded_tasks[bug_number][0]['bug']['date_last_updated']):
469 bug_task_links = [task.web_link for task in bug.tasks]
470 # remove the task if it doesn't exist in the bug tasks anymore e.g. the package changed
471 for recorded_task in recorded_tasks['%s' % bug_number]:
472 if recorded_task['web_link'] not in bug_task_links:
473 recorded_task.clear()
474 for task in bug.tasks:
475 if task.status in ["Won't Fix", 'Fix Released', 'Fix Committed', 'Invalid']:
476 # if there are no recorded tasks left stop
477 if all(len(recorded_task)==0 for recorded_task in recorded_tasks[bug_number]):
478 break
479 for recorded_task in recorded_tasks['%s' % bug_number]:
480 if len(recorded_task) == 0:
481 continue
482 if task.web_link == recorded_task['web_link']:
483 # remove the data about the recorded task because it is in a closed state
484 recorded_task.clear()
485 continue

If the bug has been updated and it has been marked as a duplicate of another it should be removed from the json file.

Related branches

Changed in arsenal:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Changed in arsenal:
status: In Progress → Fix Committed
Changed in arsenal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers