Winlibs too outdated to build

Bug #1317586 reported by Foster McLane on 2014-05-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Armagetron Advanced
Undecided
Unassigned

Bug Description

Both boost and protobuf in 0.4-winlibs-work are too old to build Armagetron. Boost is outdated from being built with an old version of mingw and protobuf is outdated because Armagetron now uses the packed modifier for messages. Attached are two bzr patches for both 0.4 and 0.4-winlibs-work that fix Windows building again on newer versions of mingw and codeblocks. To prevent http://forums3.armagetronad.net/viewtopic.php?f=4&t=23271 from happening again, I split the whole winlibs update into 12 nice bite-size chunks all included in the patch file.

Foster McLane (fkmclane) wrote :
Foster McLane (fkmclane) wrote :
Manuel Moos (z-man) wrote :

Should hopefully no longer be an issue; current 0.4 should compile with code::blocks 13.12.

Changed in armagetronad:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers