Mac OS X build system sucks

Bug #1066001 reported by dlh on 2012-10-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Armagetron Advanced
Undecided
dlh

Bug Description

Building the game on Mac OS X should not use Xcode, due to its poor backwards compatibility.

Another issue: Xcode 4 dropped support for the 10.5 SDK. Universal builds, and builds supporting older versions of Mac OS X are more difficult to create if you're using a newer OS.

dlh (dlh) on 2012-10-12
Changed in armagetronad:
status: New → In Progress
dlh (dlh) wrote :

Still left todo:

* Automate building the game for each arch and using lipo to create a universal binary.
    * Need to merge Info.plist LSMinimumSystemVersion into LSMinimumSystemVersionByArchitecture
* Automate creating a .dmg or .tgz for releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers