Prism Forwarding errors are still there

Reported by Speeder on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Critical
AlexB

Bug Description

Ok, I've said it several times on IRC but I should've written it here. Sorry.

The bugs I reported some time ago about prism beams coming out of nowhere (from outside player's view) and connecting to each other sometimes the moment you build a new Prism Tower are still there in the latest fatman.

DCoder DCoder (dcoder1337) wrote :

Combined with the crash in bug 950390, I'm gonna have to insist that we fix this before releasing anything.

Changed in ares:
assignee: nobody → DCoder DCoder (dcoder1337)
importance: Undecided → Critical
status: New → In Progress
AlexB (alexander-b) on 2012-03-16
Changed in ares:
assignee: DCoder DCoder (dcoder1337) → AlexB (alexander-b)
AlexB (alexander-b) on 2012-03-17
Changed in ares:
status: In Progress → Fix Committed
milestone: none → 0.2-rc1
YR M0ddEr (yr-m0dder) wrote :

About the above post. Do the latest fatman also have that fix?
I do not fully understand the "new" system.

AlexB (alexander-b) wrote :

Yes, the v02 branch binary has this fix, but there might still be some issues caused by logging. A crash dialog can still pop up saying the sender or SupportTarget could not be removed. I'm currently working on fixing that.

AlexB (alexander-b) wrote :

I added some functions that manage the SupportTarget and the Senders list. This should reduce dangling pointers to a minimum :p
Various-fixes and v02 are updated.

Please check whether anything still goes wrong. If triggered, the logging functions will still shut down the game forcefully and violently, but this should not happen any more. If it happens anyhow, please include the debug log.

Speeder (speederyr) wrote :

Doesn't seem to happen anymore.

Renegade (renegade) on 2012-04-21
Changed in ares:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers