EMP not disables AI factories

Bug #896278 reported by FS-21 on 2011-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
AlexB

Bug Description

I tried a Generic SW with EMP effect, for humans it works perfect (I tried against myself) but AI Factories ignores EMP. AI Factories show the the EMP animation but is 100% active producing bildings/units/infantry.

##### STEPS TO REPRODUCE #####
Fatories with ImmuneToEMP=no

; Warhead used in the test:
[EMPuls]
CellSpread=6
EMP.Duration=750
EMP.Cap=1300
Ripple.Radius=100
AnimList=PULSEFX1,PULSEFX2

; I tried with & without this line
Verses=100%,100%,100%,100%,100%,100%,100%,100%,100%,100%,100%

mevitar (mevitar) wrote :

A bit late, but in case this still needed confirmation, I can confirm it.

mevitar (mevitar) wrote :

Whoops, somebody forgot to change the status. Now look at the time it took him to notice.

Changed in ares:
status: New → Confirmed
AlexB (alexander-b) on 2016-01-12
Changed in ares:
assignee: nobody → AlexB (alexander-b)
milestone: none → 0.b
status: Confirmed → Fix Committed
mevitar (mevitar) wrote :

Tested in 16.15.1117.

The results are that whenever the AI starts producing units from a factory, it keeps producing them until it finished producing the entire team (so if an AI team had 3 tanks, it kept pumping them out until all 3 of them were out). While doing that, EMP was completely ignored. However, after it finished producing the team, it won't produce anything more while the factory is EMPed. Only after the EMP is gone, can it start producing units again, and, then again, it will ignore EMP until the entire team was kicked out of the factory.

If multiple factories of a type are present, and only the factory that currently pumps-out units is to be EMPed, units will still exit from it as if it wasn't affected at all, and it will still keep producing units as long as there are other factories of this type that aren't EMPed. It also won't stop production after one team is finished - new teams are free to leave that factory afterwards even if it's EMPed.

Furthermore, i also noticed that the AI ignores EMP on Refineries (it's not something introduced now, though, but an old issue).

BTW, the results look pretty similar to the BuiltAt= issue here https://bugs.launchpad.net/ares/+bug/1529632. Perhaps they're related?

mevitar (mevitar) wrote :

Uh, ignore the "related" part, i pressed the "post comment" button too fast :P (of course they're related, duh! :P )

Speeder (speederyr) wrote :

- It does look like AI wants to finish a TeamType after "realizing" that a unit factory type has been EMP'd but this needs more observations from other people. I also think that if you keep killing such TeamType's members before it is produced the AI will continue to produce units until the TeamType is complete, still under EMP influence.

As additional side notes:
- EMP is always ignored for ConYards by the AI
- EMP is also ignored on Refineries, AI harvesters keep dumping ore in them, same to my and enemy

mevitar (mevitar) wrote :

Still happens in 0.B, no matter how i test it.

Also, i noticed that AI-owned Factory=BuildingType structures will also finish the structure they were building. I saw a ConYard that placed a refinery some seconds after it was EMPed by a unit i had. It didn't produce more structures afterwards while i kept the EMP effect on it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.