Allow warheads to temporarily change the lighting

Bug #896217 reported by Professor_Tesla on 2011-05-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Wishlist
AlexB

Bug Description

Allow warheads to temporarily change the lighting when they impact. Currently this seems to be hardcoded to only happen with the [Nuke] warhead.

Graion Dilach (graiondilach) wrote :

No, this is currently by the SW.Light tags.

But I agree. It would be nice.

Starkku (starkku) wrote :

You can actually invoke the nuke flash effect by calling the warhead with the ID 'NUKE' from a normal weapon. The sole exception is that it does not work if called from a death weapon which explains it's absence when nuclear reactor goes boom in RA2/YR.

So no, it's not technically solely limited to superweapons, altough it would be a nice idea to expand on this.

Krozalid (krozalid) wrote :

Duplicate of bug:0000407?

DCoder DCoder (dcoder1337) wrote :

I don't think so, 407 wants the victim unit get coloured with a special tint, this one asks for a map-wide recolour like the one caused by the nuke.

AlexB (alexander-b) on 2017-09-13
Changed in ares:
assignee: nobody → AlexB (alexander-b)
status: New → In Progress
status: In Progress → Fix Committed
milestone: none → 0.e
mevitar (mevitar) on 2017-09-15
Changed in ares:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.