EMP effect doesn't apply to LStorm's warhead

Bug #896057 reported by Graion Dilach on 2011-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
Unassigned

Bug Description

If an EMP warhead is defined in SW.Warhead, the EMP effect will not activate.

##### ADDITIONAL INFORMATION #####
AlexB, I have tested LStorm though as I promised yesterday. This is the only bug I found.

Tags: emp Edit Tag help
Graion Dilach (graiondilach) wrote :

Damn, I was wrong.

All settings related to debris aren't work.

AlexB (alexander-b) wrote :

Debris are created on rock, road, walls and weeds. And after destroying things that aren't infantry. For buildings they will be generated only if there is no object on the cell be lightning struck, like spawned crew or whatever. I'll see whether I can force debris if a building was destroyed.

Graion Dilach (graiondilach) wrote :

OK, will retest it on walls, then.

Irvine, California is friendly when we need walls. ^^

EDIT: No luck. Walls are destroyed, but I didn't see a debris.

Lightning.DebrisMin=10
Lightning.DebrisMax=20
Lightning.Debris=TIRE,TIRE,TIRE

Graion Dilach (graiondilach) wrote :

[NewStormSpecial]
UIName=Name:Storm
Name=Lightning Storm
IsPowered=true
RechargeVoice=00-I156
ChargingVoice=
ImpatientVoice=
SuspendVoice=
RechargeTime=.5
Type=LightningStorm
Action=LightningStorm
SidebarImage=BOLTICON
ShowTimer=yes
DisableableFromShell=no ;UMP ; gs this determines which superweapons are turned off by the checkbox
AIDefendAgainst=yes;AI will use AISuperDefense system to decide to block this
Range=7
LineMultiplier=2
Lightning.Duration=5000
Lightning.RadarOutage=50
Lightning.RadarOutageAffects=all
Lightning.HitDelay=0
Lightning.ScatterDelay=100
Lightning.ScatterCount=5
Lightning.Separation=3
;Message.Launch=NOSTR:Launched
;Message.Activate=NOSTR:Activated
Lightning.IgnoreLightningRod=no
Lightning.DebrisMin=10
Lightning.DebrisMax=20
Lightning.CloudHeight=-1
Lightning.BoltExplosion=DEXPLOLB
Lightning.Clouds=DWCCLOUD1,DWCCLOUD2,DWCCLOUD3
Lightning.Bolts=DWCLBOLT1,DWCLBOLT2,DWCLBOLT3
SW.Damage=1000
SW.Warhead=TESTWH
Lightning.Sounds=TeslaTroopSelect,TeslaTroopSelect,TeslaTroopSelect
Lightning.PrintText=no
SW.Range=4
Lightning.Debris=TIRE,TIRE,TIRE

[TESTWH]
Verses=100%,100%,100%,3%,3%,3%,10%,10%,10%,200%,100%
CellSpread=4
InfDeath=9
Wood=yes
; SJM: No piff-piff animation -- electric bolts now spawn spark systems instead.
AnimList=TSTIMPCT
IronCurtain.Duration=30
IronCurtain.Cap=-1
Wall=yes
WallAbsoluteDestroyer=yes

YR M0ddEr (yr-m0dder) wrote :

I think you should use debirs tags on warhead:

MinDebris=10
MaxDebris=20
DebrisTypes=TIRE,TIRE,TIRE
DebrisMaximums=20

That should work better. Also, I have made basic test on all the tags, so I think you should try more "advanced" stuff.

Graion Dilach (graiondilach) wrote :

OK, and no, that wasn't the problem.

TIRE is not a Debris. It's a VoxelAnim. :P

Besides, A, you should apply to be an official tester at Nighthawk B, I'm concentrating on promo material lately and missing LStorm feedback was mentioned on the IRC yesterday.

YR M0ddEr (yr-m0dder) wrote :

I am a offical tester, I have, I have access to the beta testing forum to.
Who said about missing LStorm feedback? I tested all the tags here:
http://bugs.renegadeprojects.com/view.php?id=1367

Graion Dilach (graiondilach) wrote :

Hmmm... OK. Then it was forgotten. Alongside with that you're already a tester.

Heh, I was sure that you're one but Nighthawk said you're not. :D

YR M0ddEr (yr-m0dder) wrote :

The superweapon that hasnt been tested yet is the dominator sw. you should test that one instead.

DCoder DCoder (dcoder1337) wrote :

@Graion: he was added to the list before this "5 active testers" idea got started, like a lot of other people: http://forums.renegadeprojects.com/managegroup.php?gid=1013

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.