Requesting slight alteration to new stolen tech system

Bug #895514 reported by MRMIdAS on 2010-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
AlexB

Bug Description

As it stands at the minute, a battle lab can only have one SpyEffect.StolenTechIndex= value, I would like the tag to take more than one variable, to facilitate having one unit to be gained by spying any battle lab, without resorting to cloning, as that throws up a whole new list of problems.

WoRmINaToR (worminator) wrote :

Hmm, I now see the flaw in that system... I agree, this should be revised, however I'm not entirely sure if their coding structure will be able to easily support multiple stolen tech indexes on a single building. Worth a try though. If this can't be worked out, I have some alternate solutions in mind...

MRMIdAS (mrmidas) wrote :

why not?

all it needs is "SpyEffect.StolenTechIndex=1,4 ; this tech building gives stolentech 1 & 4"

take more than one tech number to give the house, like a warfac satisfying the prerequisites for more than one vehicle.

hardly complex coding of the century. (not that I could do it, mind)

AlexB (alexander-b) wrote :

SpyEffect.StolenTechIndex now is a list. Invalid indexes are removed from the list automatically, each positive of them emitting a parser error. Negatives are silently swallowed, thus -1 can still be used to reset the tag. Should be completely backwards compatible.

Changed in ares:
assignee: nobody → AlexB (alexander-b)
milestone: none → 0.b
status: New → Fix Committed
Chanterier (speederyr) wrote :

Had to infiltrate two buildings instead of a one, both with separate StolenTechIndex to gain access to a new unit. This works.

AlexB (alexander-b) wrote :

That's the other way around, which should have worked since Stolen Tech was introduced. This expansion is about infiltrating one building giving more than just one stolen tech index.

Chanterier (speederyr) wrote :

Oh yeah, I did have a moment when I was like 'wait, didn't it always work like this?' when "testing" what I mentioned.

Tested the other way, also works.

AlexB (alexander-b) wrote :

Thank you!

Changed in ares:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.