Permanent unit control after undeploy a deployed mind-controlled unit

Bug #895438 reported by FS-21 on 2010-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
Unassigned

Bug Description

A mind controlled deployable unit like the Nod Tick tank and Nod artillery from Tiberian Sun that is undeployed loose the mind control link and changes the owner to who mind controlled it.

##### STEPS TO REPRODUCE #####
- Move a Yuri unit and mind control a deployed unit (for example a clone of the Nod Tick Tank from tiberian Sun).
- Undeploy the unit.
- The enemy lost the mind controlled unit because now is your unit.

##### ADDITIONAL INFORMATION #####
The TS vehicle deploy logic convert a vehicle to a building and vice-versa when they are undeployed.

FS-21 (jagarni1983) wrote :
FS-21 (jagarni1983) wrote :

I forgot to say that this happen with the original Yuri's Revenge (with mods because there aren't units in RA2 like the Tiberian Sun units that I mentioned in the bug report)

DCoder DCoder (dcoder1337) wrote :

Looks simple enough to fix when I'm bored.

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1074
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - Mind Control link is carried over through (Un)deploysInto= changes. AI is too dumb to handle recovered buildings though that existed in original game as well.
SVN: http://svn.renegadeprojects.com/Ares/1074

DCoder DCoder (dcoder1337) wrote :

Marking as resolved fixed - your turn, testers.

FS-21 (jagarni1983) wrote :

I used the r1074 and:
- No deploy anim for vehicles into buildings (insta-deploy)
- AI when undeploy mindcontrolled deplyoyed units sometimes (frequently) they do the undeploy anim 5-7 or more times before it becomes vehicle.

YR M0ddEr (yr-m0dder) wrote :

Indeed original bug is fixed, but a new bug occurred as FS-21 mentioned(no deploy animation when vehicle deploy to building).

Drogan (drogan) wrote :

I tried this with a yuri clone and an enemy slave miner.

I can control the miner once it's MC either in vehicle or building form and the MC marker and link is still there after I deployed/undeployed the miner.

However, no deploy animation is played for the miner when Vehicle -> Building.

Also, if the miner is freed from MC while it's in its building state, no slaves will come out (Only tried this when all the slaves from the MC'd miner are killed prior to the miner being free from MC).

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1077
Commit contains DLL: Yes
Revision comment:
Related to issue 825 - deploy animations should be functional, structures freed from MC no longer play completely dumb (they didn't even retaliate when fired upon previously). Unfortunately, when a structure is freed from MC and it was or now is owned by a human player, the EVA_BuildingCaptured voice is played. Doesn't quite make sense, but you'll have to deal with it for now. Not sure how to reproduce the "AI undeploy mindcontrolled deployed units do undeploy anim multiple times" glitch.
SVN: http://svn.renegadeprojects.com/Ares/1077

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1078
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - slaves change ownership if their enslaving unit does.
SVN: http://svn.renegadeprojects.com/Ares/1078

YR M0ddEr (yr-m0dder) wrote :

Deploy animation play again. And slaves change sides.
I was mind controlling a deployed slave miner, then I order my Yuri Prime to mind control an other slave miner, and I got IE:
http://www.megaupload.com/?d=TQI3MHRU

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1083
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - NULL pointer sanity check.
SVN: http://svn.renegadeprojects.com/Ares/1083

YR M0ddEr (yr-m0dder) wrote :

Summary of this:
- IE is fixed
- Slave change side
- Deploy anim play again
- MC a deployed slaveminer, undeploy it to a vehicle, now mind control somethingelse with that Yuri(or whatever). The slaveminer you MCed eariler wont attack anything in its range, but it will retaliate

DCoder DCoder (dcoder1337) wrote :

So it turns out VehicleTypes with DeploysInto set are very dumb when they are released from Mind Control. Normally released MC units are sent to Hunt (or other fate, see http://modenc.renegadeprojects.com/AICaptureLowMoney , but Hunt is the most common), but Westwood hosed up as usual and such units get stuck twiddling their thumbs and only fire back when attacked. What would be the best solution for them?

FS-21 (jagarni1983) wrote :
Download full text (5.0 KiB)

"Westwood hosed up as usual and such units get stuck twiddling their thumbs and only fire back when attacked. What would be the best solution for them?"
I think that "Force hunt mission" would fit it, AI could have a chance to continue attacking the enemy with those released MC units.

DCoder this is a video with the "AI undeploy mindcontrolled deployed units do undeploy anim multiple times" glitch, tested with the r1083 (HD quality available if you don't see the units):

http://www.youtube.com/watch?v=QkQyNzgJqMU

Another strange case: At the beginning and at the end of the video you can see too an odd "Tank vehicle that undeploys into vehicle" animation..

If it helps this is the code I used for the 2 units of the video that are affected:
;TS Tick Tank
[TICKT]
UIName=name:TICKTNK
Name=Tick Tank
Category=AFV
Prerequisite=TSNAWEAP
Primary=dts90mm
Strength=280
Armor=heavy
TechLevel=4
Sight=7
Speed=6
Owner=NodCountry
Cost=750
Points=40
ROT=5
Crusher=yes
VoiceSelect=TSHVRSelect
VoiceMove=TSHVRMove
VoiceAttack=TSHVRAttack
MoveSound=GrizzlyTankMoveStart
VoiceSpecialAttack=TSHVRAttack
VoiceFeedback=
MaxDebris=4
Weight=3.5
ElitePrimary=dts120mmxE
ZFudgeColumn=8
ZFudgeTunnel=13
VeteranAbilities=STRONGER,FIREPOWER,ROF,SIGHT,FASTER
EliteAbilities=SELF_HEAL,STRONGER,FIREPOWER,ROF,SENSORS
IsTilter=yes
TooBigToFitUnderBridge=true
IsSelectableCombatant=yes
CrushSound=TankCrush
MovementZone=Destroyer
ThreatPosed=25 ; This value MUST be 0 for all building addons
Accelerates=false
ImmuneToVeins=yes
Size=3
Bunkerable=no; Units default to yes, others default to no
DeploySound=PlaceBuilding
DeploysInto=GATICK
Locomotor={4A582741-9839-11d1-B709-00A024DDAFD1}
DamageParticleSystems=SparkSys,SmallGreySSys
AllowedToStartInMultiplayer=yes
DeployFacing=2
Explosion=TWLT070,S_BANG48,S_BRNL58,S_CLSN58,S_TUMU60
DeployToFire=no
TickTank=yes
DeployTime=.010

[GATICK]
UIName=name:TSGATICK
Name=Deployed Tick Tank
TechLevel=-1
Strength=450
Points=40
Adjacent=0
Cost=750
Power=0
Armor=deployed_heavy_armor
Sight=6
Explosion=TWLT070,S_BANG48,S_BRNL58,S_CLSN58,S_TUMU60
MaxDebris=4
UndeploysInto=TICKT
BaseNormal=no
VoiceSelect=TSHVRSelect
VoiceMove=TSHVRMove
VoiceAttack=TSHVRAttack
VoiceSpecialAttack=TSHVRAttack
Primary=dts90mmd
ElitePrimary=dts120mmxEd
Turret=yes
ROT=5
Powered=false
TickTank=yes
TurretAnim=TICKTTUR
TurretAnimIsVoxel=true
TurretAnimX=4
TurretAnimY=0;10
TurretAnimZAdjust=-20
ThreatPosed=35
DamageParticleSystems=SparkSys,SmallGreySSys
DamageSmokeOffset=500, 500, 400
Trainable=yes
VeteranAbilities=STRONGER,FIREPOWER,ROF,SIGHT,FASTER
EliteAbilities=SELF_HEAL,STRONGER,FIREPOWER,ROF
HasStupidGuardMode=false
Unsellable=false
DeployFacing=2
DeployTime=.010
ImmuneToPsionics=no
ImmuneToRadiation=no
DamageSound=Dummy

;-----------------------------------------------------

; advanced mobile artillery
[ART2]
UIName=Name:ART2
Name=Advanced Artillery
Prerequisite=TSNAWEAP,RADAR
Primary=TS155mm
ElitePrimary=TS155mmE
;Category=LRFS
Strength=300
Category=Support
Prerequisite=TSNAWEAP,TSNARADR
DeploysInto=ARTYDEP
Crusher=yes
Turret=no
DeployingAnim=ARTYMK
Dep...

Read more...

DCoder DCoder (dcoder1337) wrote :

The game already sends the units into Hunt mission. The problem is that that mission doesn't work for deployable units at all.

Linglin (linglin) wrote :

if this logic can be fixed.MCed MCV can't deploy or MCed CYard can't undeploy setting can be removed.

FS-21 (jagarni1983) wrote :

Patch uploaded against last revision 1083 of this branch: Adding one new line to overwrite the current mission of the mind-controlled unit is sufficient to fix the bug I reported.

I can't detect any more bugs related to deploy/undeploy mindcontrolled units.

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: GraionDilach
Location: various-fixes, r1119
Commit contains DLL: Yes
Revision comment:
Related to issue #825: Compiled FS-21's patch in.

Also branch fix to compile with YR++ rev391.
SVN: http://svn.renegadeprojects.com/Ares/1119

FS-21 (jagarni1983) wrote :

Tested it against r1119 and works as expected (they deploy/undeploy as mindocontrolled units & no strange loops when they try to deploy/undeploy).

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1131
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - removed FS-21's patch because it was not logical, changed CaptureManagerClass::DecideUnitFate to put deployable non-MCV units into guard mode instead of hunt, because their hunt mode doesn't work.
SVN: http://svn.renegadeprojects.com/Ares/1131

DCoder DCoder (dcoder1337) wrote :

Testers, your turn.

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1138
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - I couldn't reproduce the problem before and I can't reproduce it now, but this code is the better way to give units a new mission.
Also included one file that somehow got lost in the previous commit?
SVN: http://svn.renegadeprojects.com/Ares/1138

Drogan (drogan) wrote :

Deployable vehicles stays mind controlled when deploying into a building and vice versa.

However, enemy mind controllers seem to have an odd behavior of deploying/undeploying their controlled unit repetitively at times. Especially when no threat is near it

FS-21 (jagarni1983) wrote :

Tested r1140 & the strange loop when AI undeploy mindcontrolled units still exist.

Bug Importer (bug-importer) wrote :

Code related to this issue has just been checked in!
Author: DCoder
Location: various-fixes, r1142
Commit contains DLL: Yes
Revision comment:
Related to issue #825 - I still can't see where the problem is, now I removed the change of mission at all so the engine can deploy them as it sees fit. Added some logging for this. Can someone who can reproduce this provide detailed info on how they're testing it?

Also merged in latest trunk.
SVN: http://svn.renegadeprojects.com/Ares/1142

DCoder DCoder (dcoder1337) wrote :

Reopening this issue since it still isn't fixed - code related to it will be removed from the various-fixes branch so as not to slow down the release of 0.2 .

Drogan (drogan) wrote :

I let my MCV get mind controlled and it doesn't do anything (probably because I was playing with easy AIs).

However, when I let a slave miner get mind controlled (like I did before and removed its immunity from MCs), it gets the same behavior as before.

I also got a lot of the same message in the log reading: "Transferring YURI's MC link from YAREFN to SMIN manually, problems might occur..."

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.