Possible to reduce the insane lag of the CloakGenerator= logic?

Bug #895299 reported by Bug Importer on 2009-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Medium
Unassigned

Bug Description

I really don't know how much coding-wise I am asking for, so this feature is up to you, but I think it would be very beneficial to many modders if there was a way to reduce the insane amount of lag that CloakGenerator buildings produce on the game, especially when they cloak entire buildings.

##### ADDITIONAL INFORMATION #####
From my experience I think it would be fair to say that a possible perpetrator of the problem is the fact that buildings under a cloak become transparent. Transparent animations of all kinds lag the crap out of the game (any animation with Translucent=yes or Translucency=.). Maybe a way to make the building display as 'cloaked' to the player but not become transparent (like a little symbol above the building, maybe?)

Lag? What lag? It doesn't lag for me. Are you talking about online games?

Bug Importer (bug-importer) wrote :

no, I'm talking about singleplayer games. I could be playing a game on speed 6 on a monster machine (so like 60 FPS where normal speed on RA2 is like 30 i think; this means the game is going super zippy fast for me at least), and having 3-4 or more cloaked buildings slows my game down to like a speed 4-3 from that speed 6.

Also, I am talking about cloaking buildings; dolphins/subs for whatever reason don't have this problem, but cloaking entire buildings produces excessive amounts of lag.

I know you are talking about cloaking buildings; I've implemented stealth generators before in my personal mod and my whole base being cloaked never caused any lag.

Marshall (m-edward) wrote :

Cloak Generators causing slowdown is well known. I didn't realise there was anyone who *didn't* get the problem.

Bug Importer (bug-importer) wrote :

Lazy Dupl3xxx

I have a "overpowerd" system whene compared to the requirement of YR. And cloaking a base is instant lag! The ingame fps drops from something like 90-120fps to something like 20-40.

DCoder DCoder (dcoder1337) wrote :

Very true. This has nothing to do with your graphic cards however, it's more to do with westwood's smartass ways of drawing cloaked stuff.

Bug Importer (bug-importer) wrote :

or anything that is displayed as transparent for that matter. I turned Translucent= off on all my animations in Artmd.ini and it never lagged again when gigantic bases exploded.

Bug Importer (bug-importer) wrote :

Is is transparent buildings that make the lagg is it just the coding?

Gluk-v48 (gluk-v48) on 2013-09-16
tags: added: stealth
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.