SW.Range= is bugged for non-circular areas

Bug #1647841 reported by mevitar on 2016-12-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
Critical
AlexB

Bug Description

If the SW is set to affect a rectangular area, its actual affected area will get increased by 1 in each dimension.
This causes SWs like Chronosphere or Iron Curtain (they default to SW.Range=3,3) to affect a 4x4 area (giving them SW.Range=2,2 makes them work as they did in YR).

After testing this with different builds I can confirm it happening ever since 0.A (probably since this fix https://bugs.launchpad.net/ares/+bug/1469906). Unfortunately I didn't notice it back then since I didn't test it with default Chronosphere, but with a clone that affects a circular area.

AlexB (alexander-b) wrote :

Thanks! Bug was there since last September, when I changed the frame of reference from center coords with width and height to a rectangle defined by left, top, right, and bottom. "Right" is not just left + width, but left + width - 1, because the rightmost cell is included. I forgot the - 1, also for the height, thus the area of effect was one too large for both of them.

Changed in ares:
assignee: nobody → AlexB (alexander-b)
importance: Undecided → High
importance: High → Critical
status: New → Fix Committed
AlexB (alexander-b) wrote :

Correction: it was July 2015.

mevitar (mevitar) wrote :

Works correctly in 0.Cp1

AlexB (alexander-b) on 2017-06-10
Changed in ares:
milestone: none → 0.cp1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions