'Ready' buildings can still be placed if ConYard is EMP'd

Bug #1559581 reported by Chanterier on 2016-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
High
AlexB

Bug Description

If you have a building 'Ready' for placement but the Construction Yard is under EMP effect, there is still a way to place it, be it from Buildings or Armory tab: by using hotkeys (default Q & W). Ares - 16.76.569

Chanterier (speederyr) on 2016-03-19
description: updated
AlexB (alexander-b) on 2016-03-20
Changed in ares:
status: New → Triaged
AlexB (alexander-b) on 2016-03-22
Changed in ares:
assignee: nobody → AlexB (alexander-b)
milestone: none → 0.b
importance: Undecided → High
status: Triaged → In Progress
AlexB (alexander-b) on 2016-03-29
Changed in ares:
status: In Progress → Fix Committed
mevitar (mevitar) wrote :

This no longer happens in 0.b build. You can't use the hotkeys to place buildings in the "disabled" state - nothing happens if you try.

Note, however, that you can still place structures if the structure was EMPed after you got the "placement" cursor. This fix only prevents getting the cursor, but once you got it, you can place and the state of the Factory=BuildingType structure isn't checked anymore. Something i thought i should mention, whether it will be changed or not.

Changed in ares:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers