FlyingStrings graphical bug

Bug #1264393 reported by mevitar on 2013-12-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ares
High
Unassigned

Bug Description

When doing some testing with the bounty branch i found at one point that some flying strings got bugged on the bottom bar (they were stuck there, not sure when). Look at the bottom of the attached image. At the moment i don't know how did it happen, i was unable to reproduce it.

I noticed the game to suddenly start to lag at one point and later i noticed those strings. When i turned off and on the bar and moved the screen a bit the lag went away (not 100% sure if it was the cause, though).

mevitar (mevitar) wrote :
mevitar (mevitar) wrote :

Forgot to mention that the strings you see there were frozen, and after turning the bar off then on the bugged strings were gone, since the bar was redrawn. I didn't have any graphical issues with this bar before, so it's definitely not a bugged or incorrect sidebar gfx.

Graion Dilach (graiondilach) wrote :

This is exactly the reason why Bounty ain't in stable.

Changed in ares:
status: New → In Progress
assignee: nobody → Graion Dilach (graiondilach)
importance: Undecided → High
mevitar (mevitar) wrote :

I though FlyingStrings is a global thing, not related to bounty itself. :P

Graion Dilach (graiondilach) wrote :

It's added with Bounty. Yes it's intended to be more versatile, but it's as related to Bounty, like the crate-hooks to AttachEffect.

mevitar (mevitar) wrote :

The issue seems to be fixed in 16.60.274, because, while i still get it, it's not as serious as the first screenshot, and it appears only to happen only for the original Allied bottom bar. For a custom made UI, there are no weird artifacts on the bottom bar.

When it actually happens, it's usually several seconds after the floating string passed through the edge between the bottom bar and the battlefield view, whether i kept the screen deliberately in that way, or only passed for a moment.
However, doing ANYTHING that refreshes the bottom bar (hovering the cursor over the bottom bar, opening the menu, etc) fixes the issue.

But like i wrote earlier, this does not happen for my custom-made UI, but for the original Allied UI.

See attached animations.

mevitar (mevitar) wrote :

Correctly working UI (note that it's the same one as the one that had the original issue).

Changed in ares:
assignee: Graion Dilach (graiondilach) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers