FFe: Sync binutils-avr 2.23.1-1 (universe) from Debian unstable (main)

Bug #1235748 reported by Logan Rosen
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Arduino
Undecided
Unassigned
binutils-avr (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync binutils-avr 2.23.1-1 (universe) from Debian unstable (main)

Explanation of FeatureFreeze exception:
The new version fixes an FTBFS (verified in local pbuilder, Bug 1229534), and it also fixes Bug 662567 in Ubuntu.

Changelog entries since current saucy version 2.20.1-3:

binutils-avr (2.23.1-1) unstable; urgency=low

  * Upgraded binutils to 2.23.1 (closes: #558335)
  * Replaced the patchset with the patches from Atmel-AVR-Toolchain-
    3.4.2 provided at http://distribute.atmel.no/tools/opensource/Atmel-
    AVR-Toolchain-3.4.2/avr/
  * Fix textinfo5 incompatibility issues (closes: #712351)

 -- Hakan Ardo <email address hidden> Tue, 02 Jul 2013 09:35:36 +0200

Logan Rosen (logan)
Changed in binutils-avr (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in binutils-avr (Ubuntu):
status: New → Confirmed
Revision history for this message
thedanyes (thedanyes) wrote :

The current version of binutils-avr has an annoying bug that randomly affects Arduino development. I would love to see a new Ubuntu package.

See here:
http://sourceware.org/bugzilla/show_bug.cgi?id=13410

Revision history for this message
thedanyes (thedanyes) wrote :

Versions 2.20 (and 2.21) contain a very serious and frustrating bug for Arduino developers (compilation just fails seemingly 'randomly'). The only clue is a cryptic error message, something like:
GNU ld (GNU Binutils) 2.21 e:/winavr/4.7.0-1/bin/../lib/gcc/avr/4.7.0/../../../../avr/lib/avr6/crtm2560.o: In function `__vectors':
../../../../../../source/avr-libc-1.7.1/crt1/gcrt1.S:53: relocation truncated to fit: R_AVR_13_PCREL against symbol `__vector_1' defined in .text section in e:/winavr/4.7.0-1/bin/../lib/gcc/avr/4.7.0/../../../../avr/lib/avr6/crtm2560.o
collect2.exe: error: ld returned 1 exit status

It seems like it could be fixed easily (just by pulling the updated package from Debian). Please read the link in my previous post for further details.

Iain Lane (laney)
Changed in binutils-avr (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.