Ardour cannot open FLAC files

Bug #245047 reported by Endolith on 2008-07-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ardour
New
Undecided
Unassigned
ardour (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ardour

As far as I know, the version of Ardour included in Ubuntu does not support FLAC files, though it can be compiled to support them.

See "Ardour and flac" Ubuntu Forums thread:
http://ubuntuforums.org/showthread.php?t=626020

and

"How Do I Import FLAC Into Ardour 2.0 Rc1?"
http://ardour.org/node/861

They're supported fine in Audacity and Adobe Audition, so I converted all my .wav files to .flac long ago and saved several GB. Now that I am trying to use Ardour, of course, they are useless.

#
# june 1st 2007: look for a function that is in FLAC 1.1.2 and not in later versions
# since the version of libsndfile we have internally does not support
# the new API that libFLAC has adopted
#

Ardour supports FLAC only with 1.1.2, but Ubuntu >= 7.10 has 1.1.4 versión of FLAC (hardy, intrepid and jaunty have 1.2.1 version)

Then, this is a bug of upstream

Changed in ardour:
status: New → Invalid
Endolith (endolith) on 2009-02-08
Changed in ardour:
status: Invalid → New
Changed in ardour:
status: Unknown → New
Changed in ardour:
status: New → Invalid
status: Invalid → Confirmed
pablomme (pablomme) wrote :

Allegedly fixed in 2.8.3: http://ardour.org/node/3046 . Will we see this version in the karmic universe repos?

pablomme (pablomme) on 2012-05-01
Changed in ardour:
importance: Unknown → Undecided
Changed in ardour (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.