External download manager doesn't work

Bug #1055182 reported by Olivier Duchateau
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Midori Web Browser
midori (Arch Linux)

Bug Description

Tested with Midori 0.4.6 and 0.4.7 under FreeBSD.

When I enable External Download manager, it's always Midori which takes control (like previous versions before 0.4.6).

If I use CommandLine (with default values, wget), also tested with SteadyFlow.

$ grep download-manager ~/.config/midori/config

If I want to download, for example http://archive.xfce.org/src/apps/midori/0.4/midori-0.4.7.tar.bz2, download works, it appears in bottom. But `wget' is not installed on my box, and there's no errors. I've always "old" behaviour before Midori 0.4.6.

Versions of libraries:
- Midori 0.4.6 (+ patches for Vala), Vala 0.12.1, and GLib 2.28.8
- Midori 0.4.7 (+ patches), Vala 0.12.1 / 0.14.1, and GLib 2.28.8


Command line /usr/local/bin/midori
Midori 0.4.7 (de.twotoasts.midori_128b0d58b64bcb1093db3a57c6c5b812__0)
GTK+ 2.24.6 (2.24.6) Glib 2.28.8 (2.28.8)
WebKitGTK+ 1.6.3 (1.6.3) libsoup 2.34.3
cairo 1.10.2 (1.10.2)
gcr libunique 1.1.6
granite X11;
libnotify FreeBSD
single instance i386
Platform Mozilla/5.0 (X11; FreeBSD) AppleWebKit/535.4 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/535.4 Midori/0.4 H264 [x] Ogg Theora [x] WebM [x]
Identification X11;
Video Formats i386

Revision history for this message
Cody Garver (codygarver) wrote :

The way downloads work was just overhauled so I'm marking this Incomplete. Come back after you've tried the new system and let us know how it influenced you.

Changed in midori:
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for Midori because there has been no activity for 60 days.]

Changed in midori:
status: Incomplete → Expired
Revision history for this message
James (jamestheawesomedude) wrote :

Showing up on Midori 0.5.7, Arch Linux x86_64

Command line midori
Midori 0.5.7 ((null))
GTK+ 2.24.22 (2.24.22) Glib 2.38.2 (2.38.2)
WebKitGTK+ 1.10.2 (1.10.2) libSoup 2.44.2
cairo 1.12.16 (1.12.16) libnotify 0.7.6
gcr No granite No
Platform X11; Linux x86_64
Identification Mozilla/5.0 (X11; Linux) AppleWebKit/537.6 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/537.6 Midori/0.5
Video Formats H264 [x]   Ogg Theora [x]   WebM [x]

Changed in midori:
status: Expired → Confirmed
summary: - External download manager don't work
+ External download manager doesn't work
Revision history for this message
Michael Tunnell (michaeltunnell) wrote :

I have tried Midori on many distros with many different versions and this features not ever worked...even once. I wish it worked because I could then integrate it with my app but it never has.

I am currently testing Midori 0.5.8 on Arch and as expected, it doesn't work.

Please, address this...it has been over two years since first reported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers