[hamster plugin] not start tracking tasks

Bug #620313 reported by D.Schäfer
194
This bug affects 37 people
Affects Status Importance Assigned to Milestone
GTG
Low
Luca Invernizzi
gtg (Arch Linux)
New
Undecided
Unassigned
gtg (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.04
Hamster 2.33.1
GTG 0.3-0~ubuntu108
Hamster plugin 0.3

I cant start tracking a task from gtg

Traceback (most recent call last):
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 245, in task_cb
    self.sendTask(plugin_api.get_task())
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 97, in sendTask
    hamster_id=self.hamster.AddFact('%s%s,%s%s'%(activity, category, description, tag_str), 0, 0)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
TypeError: AddFact() takes at least 5 arguments (4 given)

Revision history for this message
Waldemar Zurowski (waldemar-zurowski) wrote :

Hi,

I've upgraded recently to Ubuntu 10.10 (development branch) and I experienced the same problem. I've got hamster-plugin 2.31.92-0ubuntu2 installed.

The gtg version is 0.2.4-4

Revision history for this message
rbertran (rbertran) wrote :

Same to me. Same lines, same error...
GTG Version: 0.2.4-4
Hamster Version: 2.31.92

Revision history for this message
Fabian Schmidt (fschmidt) wrote :

Hi,

I'm on Archlinux
Hamster Version : 2.32.0
GTG Version : trunk

i tried to figure out whats wrong, I guess they changed the api of addFact in this version, looks like this now:
add_fact(
self,
activity_name,
tags = '',
start_time = None,
end_time = None,
category_name = None,
description = None,
temporary = False
)

I hope this may help

Revision history for this message
Fabian Schmidt (fschmidt) wrote :

Hi me again its not the trunk version its 0.2.4 sorry for that

Revision history for this message
wimpunk (wimpunk) wrote :

I wrote a quick patch for hamster db which works for me on ubuntu 10.10 Feel free to test it and give me feedback.

Revision history for this message
rbertran (rbertran) wrote :

@wimpunk,
that patch did not work for me. I wrote, another one, that worked fine. The only problem is that the AddFact method exported via dbus has a parameter, named 'temporary' which I do no have the value. So, I set it to default value, which is 'False'. Hope this help too.

Working on an updated ubuntu 10.10.

Revision history for this message
Josh Huckabee (jhuckabee) wrote :

@rbertran, your patch worked for me also. Thank you!

Using GTG 0.2.4 and Hamster 2.31.92 on Ubuntu 10.10

tags: added: patch
Revision history for this message
wimpunk (wimpunk) wrote :

@rbertran,
I noticed my fix was to quick. I'll try yours.

Revision history for this message
wimpunk (wimpunk) wrote :

@rbertran,

It looks like your patch has, just like mine, a problem with tags. If you submit your tags, they get added with a # in front. I also didn't got the categories working but I may be overlooking something.

Revision history for this message
rbertran (rbertran) wrote :

@wimpunk

Yes, it seems that something is still wrong.
Categories and tags are not properly handled,
but at least the patch sets Hamster to the task.
So, we need to test a bit more to see was going
on.

Revision history for this message
Josh Huckabee (jhuckabee) wrote :

Here's a patch that addresses the tag issue. Its been working for me for a week now.

Revision history for this message
Josh Huckabee (jhuckabee) wrote :

Also, I haven't been experiencing an issue with category handling. I've only applied @rbertran's last patch (#7) and the patch I submitted (#12).

Revision history for this message
rbertran (rbertran) wrote :

I have looking into this a little bit deeper. I attach a patch that seems to fix this activity setting
problem and other related issues.

- Since the interface changed, there is not need to prepend # or @ in tags or categories.
- Moreover, the configuration GUI has two options: use GTG tag as category or Default to GTG
tag as category if the task is unsorted. I realized that the plugin did not *force* the GTG category.
So, I changed that too.

I do not know if this is the behavior that GTG-hamster plugin author want, but seems to work for
me.

Revision history for this message
Fil (zlashdot) wrote :

rbertran's patch worked for me. Thanks :)

Revision history for this message
Steve Blamey (fedorus-deactivatedaccount) wrote :

Just hitting this issue. rbertan's patch works here. Good job!

Ryan T Long (rtlong)
Changed in gtg:
status: New → Confirmed
Revision history for this message
Martin Smith (martinb3) wrote :

I rebuilt this with the latest patch from rbertan and put in my PPA at https://launchpad.net/~martinb3/+archive/ppa in case anyone else wants to use it (follow the instructions under 'Adding this PPA to your system' on that page).

Revision history for this message
Helmo (helmo) wrote :

rbertran's patch worked for me as well. Thanks :)

Any chance this can be included in the 11.04 Ubuntu release?

Changed in gtg:
status: Confirmed → Fix Committed
Revision history for this message
Rex Tsai (chihchun) wrote :

The same issue is still exist in 11.04 (natty)

$ apt-show-versions hamster-applet gtg
gtg/natty uptodate 0.2.4-5
hamster-applet/natty uptodate 2.32.1-0ubuntu1

Revision history for this message
Mani Sabri (mani-sabri) wrote :

Yes. not working in 11.04 the task appears in Hamster activity drop down menu if you open Hamster and type the first letter(s) of it but it wont start automatically when you press the Hamster Icon (I don't know if its the desired behavior or a Hamster bug!)

Daniel T Chen (crimsun)
tags: added: patch-needswork
removed: patch
Changed in gtg (Ubuntu):
status: New → Confirmed
Changed in gtg:
importance: Undecided → Low
assignee: nobody → Luca Invernizzi (invernizzi)
milestone: none → 0.2.9
Revision history for this message
ViktorNagy (viktor-nagy) wrote :

Running gtg trunk (0.3-development) with 2.32.1-ubuntu (from 11.04) gives a similar error:

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/GTG/plugins/hamster/hamster.py", line 248, in task_cb
    self.sendTask(task)
  File "/usr/local/lib/python2.7/dist-packages/GTG/plugins/hamster/hamster.py", line 98, in sendTask
    hamster_id=self.hamster.AddFact(activity, tag_str, 0, 0, category, description)
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
TypeError: AddFact() takes at most 5 arguments (7 given)

As far as I understand, the error comes from mismatching version trunk - 2.32.1. Is this correct?
If so, could someone give me a description on how to get hamster trunk or a 2.32.1 compatible gtg version?
I've tried to install gtg from the ubuntu repos, but gtg could not start. I guess the problem is that some config settings are not backward compatible. The error was something related to the localfile module.

Revision history for this message
Ganesh Hegde (ganesh-alpha) wrote :

hi i am running oneiric beta 2 and i am experiencing the same issues

regards

Revision history for this message
Izidor Matušov (izidor) wrote :

Viktor, Ganesh> Which version of GTG do you use? I have try the trunk (rev 1012) at it works good for my hamster installed from Ubuntu repositories.

Unfortunately, it is not possible to use 0.2.4 after trying trunk - see the bug #827658 (I want to write script for reversing but it would take some time)

Revision history for this message
Antono Vasiljev (antono) wrote : Re: [Bug 620313] Re: [hamster plugin] not start tracking tasks

It also broken for me on Oeiric

gtg | 0.2.4-5 | http://archive.ubuntu.com/ubuntu/ oneiric/universe
amd64 Packages
hamster-applet | 2.32.1-0ubuntu5 | http://archive.ubuntu.com/ubuntu/
oneiric/universe amd64 Packages

--
http://antono.info/

Revision history for this message
Izidor Matušov (izidor) wrote :

The stable version which is in Ubuntu is broken with hamster. Please try to test it with the trunk version:

bzr clone lp:gtg
cd gtg
scripts/debug.sh

It should work (it works for me so far). Any feed would be appreciated!

Revision history for this message
gururuby (gururails) wrote :

Thank you very much! It works!

Revision history for this message
Izidor Matušov (izidor) wrote :

I advice you to use the following PPA (an easy way how to use custom packages): https://edge.launchpad.net/~gtg/+archive/gtg-daily

It allows you to use the current (at least a little bit) stable development version. I am working in my spare time on releasing a new version of GTG but it takes some time to finish it.

Izidor Matušov (izidor)
Changed in gtg:
status: Fix Committed → Fix Released
Changed in gtg (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtg - 0.2.9-1

---------------
gtg (0.2.9-1) unstable; urgency=low

  * New upstream release (Closes: #668096).
    - Implement a search text box (Closes: #650279).
    - Window title reflects active tasks (LP: #537096).
    - Fix misbehaviours of the indicator applet (LP: #548836, #676353).
    - Fix crash when selecting notification area plugin twice (LP: #550321).
    - Fix sorting of tasks by date (LP: #556159).
    - Fix excessive delays at startup (LP: #558600).
    - Fix crash with dates having unknown values (LP: #561449).
    - Fix crash issued when pressing delete key (LP: #583103).
    - Keep notification plugin enabled after logoff (LP: #617257).
    - Fix Hamster plugin to work with recent Hamster versions (LP: #620313).
    - No longer use non-unicode strings (LP: #680632).
    - New RTM sync mechanism (LP: #753327).
    - Fix crashes while handling XML storage file (LP: #916474, #917634).
  * debian/patches/*:
    - Drop all patches, they have been merged upstream.
  * debian/patches/shebang.patch:
    - Fix shebang line.
  * debian/patches/manpages.patch:
    - Fix some groff warnings in gtg_new_task man page
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/control:
    - Bump X-Python-Version to >= 2.6.
    - Add python-liblarch and python-liblarch-gtk to Depends field.
    - Add python-cheetah, python-geoclue, python-gnomekeyring,
      python-launchpadlib and python-suds to Suggests field.
    - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Refresh copyright information.
    - Format now points to copyright-format site.
  * debian/rules:
    - Make gtcli_bash_completion script executable.
  * debian/watch:
    - Update watch file.

 -- Luca Falavigna <email address hidden> Tue, 10 Apr 2012 23:08:21 +0200

Changed in gtg (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
injected (b-comm) wrote :

hi,

i am having this issue on ubuntu 12.04 - 64bit

injected@styx:~$ apt-show-versions hamster-applet gtg
gtg/precise uptodate 0.2.9.r1184
hamster-applet/precise uptodate 2.91.3+git20110714.9aefd7-2ubuntu3

Error Details:
Traceback (most recent call last):
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 244, in browser_cb
    self.sendTask(plugin_api.get_requester().get_task(task_id))
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 98, in sendTask
    hamster_id=self.hamster.AddFact(activity, tag_str, 0, 0, category, description)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
TypeError: AddFact() takes at most 5 arguments (7 given)

Revision history for this message
Yevgeniy A. Viktorov (yevgenko) wrote :

re 29, same issue here

gtg/precise uptodate 0.2.9-1
hamster-applet/precise uptodate 2.91.3+git20110714.9aefd7-2ubuntu3

Revision history for this message
Shonin Nikolai (angelium) wrote :

re 29, same issue here
gtg/precise uptodate 0.2.9.r1233~precise1
hamster-applet/precise uptodate 2.91.3+git20110714.9aefd7-2ubuntu3

Revision history for this message
Shonin Nikolai (angelium) wrote :

Traceback (most recent call last):
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 264, in browser_cb
    self.sendTask(plugin_api.get_requester().get_task(task_id))
  File "/usr/share/gtg/GTG/plugins/hamster/hamster.py", line 109, in sendTask
    category, description)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
TypeError: AddFact() takes at most 5 arguments (7 given)

Revision history for this message
Mani Sabri (mani-sabri) wrote :

The changes applied to AddFact, categories and tag_str in old patches does not work either.
You can't apply the patches because the hamster.py is changed.
I applied them manually and traceback is gone but the activity does not appear in hamster either.

Revision history for this message
Mani Sabri (mani-sabri) wrote :

ok , you cant pass 0 as start time any more. passing time.time() solves the problem

Revision history for this message
Mani Sabri (mani-sabri) wrote :

I created a patch for 0.2.9 in Ubuntu X64 12.10. It fixes a Tag problem too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers