Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support (Bluetooth A2DP codecs).

Bug #1838151 reported by Jeff Nappi
This bug affects 214 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
Arch Linux
New
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Wishlist
Unassigned

Bug Description

Bluetooth HSP/HFP audio quality is poor on Ubuntu comparative to all other major platforms (Windows, MacOS, ChromeOS, Android, iOS).

Modern Bluetooth headsets (such as the Bose QC series headphones, many others) are capable of using HFP 1.6 with mSBC 16kHz audio encoding. As it currently stands, Ubuntu defaults to only supporting HSP headsets using 8kHz CVSD, and is incapable of supporting HFP 1.6 at this time.

The ChromiumOS team recently tackled this issue - https://bugs.chromium.org/p/chromium/issues/detail?id=843048

Their efforts may assist in bringing this to Ubuntu, however it appears that there are quite a lot of differences considering they have developed their own audio server solution etc.

The Bluetooth Telephony Working Group published the HFP 1.6 spec in May 2011 - https://www.bluetooth.org/docman/handlers/downloaddoc.ashx?doc_id=238193

Patches have been proposed in the past for this issue to the kernel and PulseAudio:

PulseAudio: https://patchwork.freedesktop.org/patch/245272/
Kernel: https://www.spinics.net/lists/linux-bluetooth/msg76982.html

It appears that the Chromium OS team applied the same kernel patch: https://chromium.googlesource.com/chromiumos/third_party/kernel/+/77dd0cb94c1713a8a12f6e392955dfa64c430e54

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: pulseaudio 1:12.2-2ubuntu3
ProcVersionSignature: Ubuntu 5.0.0-20.21-generic 5.0.8
Uname: Linux 5.0.0-20-generic x86_64
ApportVersion: 2.20.10-0ubuntu27.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jnappi 2777 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Sat Jul 27 11:08:29 2019
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-11-04 (629 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: Upgraded to disco on 2019-07-18 (9 days ago)
dmi.bios.date: 06/07/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: R07ET67W (2.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20FW000TUS
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrR07ET67W(2.07):bd06/07/2016:svnLENOVO:pn20FW000TUS:pvrThinkPadT460p:rvnLENOVO:rn20FW000TUS:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T460p
dmi.product.name: 20FW000TUS
dmi.product.sku: LENOVO_MT_20FW_BU_Think_FM_ThinkPad T460p
dmi.product.version: ThinkPad T460p
dmi.sys.vendor: LENOVO

Revision history for this message
Jeff Nappi (jeffnappi) wrote :
tags: added: patch
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1838151

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: eoan
Changed in pulseaudio (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Michael (miwait00) wrote : Re: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support.

Just noticed this with my new Bluetooth headset. With the same headset, the microphone and audio quality is a lot better when paired with an Android device than when paired with my desktop (4.15.0-55-generic Ubuntu 18.04.03 LTS).

Revision history for this message
Vedran Rafaelic (croraf) wrote :

The same. HP Omen as per this https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1852636. Eoan with 5.3.0-24-generic

Revision history for this message
Kyle Van Wagenen (kylevw) wrote :

This issue impacts the experience with Ubuntu significantly. Android, Windows, and OS X all sound much better with a Bluetooth headset when on calls, playing games, or listening to music while using the headset microphone.

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote : Re: [Bug 1838151] Re: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support.

How feasible would it be to backport (steal) the Android Bluetooth stack to
Ubuntu?

Kyle Van Wagenen <email address hidden> schrieb am Sa., 14. Dez.
2019, 20:55:

> This issue impacts the experience with Ubuntu significantly. Android,
> Windows, and OS X all sound much better with a Bluetooth headset when on
> calls, playing games, or listening to music while using the headset
> microphone.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1838151/+subscriptions
>

Changed in pulseaudio (Ubuntu):
importance: Medium → Wishlist
Revision history for this message
Alberto Bellini (abel1960) wrote : Re: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support.

This may come as a big problem in a business environment: frequently conference calls need affordable audio, in and out. We found many great devices at low cost, but with this Ubuntu problem, they become unusable.

Please, give higher rate to this issue, if possible.

tags: added: champagne
tags: removed: disco
Revision history for this message
Igor Maric (igormaric) wrote :

This is a huge issue in business environment. I can't understand that we don't have this in 2020 when all other platform has it and even now its importance is a wishlist? Come on! It's impossible to have a conversation using Bluetooth, audio is unusable.

Revision history for this message
Jeremie (charlet-jeremie) wrote :

A pity that I have to look for an extra usb microphone while I spent $200+ on a fancy bluetooth headset to have conference calls on my laptop. Reproduced with 3 bluetooth headsets. Quality is so poor on hsp/hfp that it's unusable. Didn't understand why I couldn't make it work decently until I found this bug.

Does anyone have a workaround, managed to hack his way out of this bug?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Just checked again and it seems neither upstream Linux nor upstream PulseAudio have landed this yet. Perhaps they don't know about it or have lost track of the patches.

To get the ball rolling, anyone affected please open new upstream bugs in both:

Linux: https://bugzilla.kernel.org/
PulseAudio: https://gitlab.freedesktop.org/groups/pulseaudio/-/issues

and then tell us the new bug IDs.

If the Ubuntu kernel team is listening then maybe they can help with this.

tags: added: desktop-lts-wishlist rls-ff-notfixing
removed: champagne
Revision history for this message
Jan Dageförde (de-diamonds) wrote :

There is an upstream issue in PulseAudio: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/776.

Changed in pulseaudio:
status: Unknown → New
Revision history for this message
stuart naylor (stuartiannaylor68) wrote :

Isn't this because HSP is not handled by pulse audio but ofono since PA11.0?

https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/11.0/

Ofono is HSP 1.6 and wideband audio 16khz but ubuntu conf doesn't implement?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Some recent commits in BlueZ 5.54 suggest wide band support is being prepared starting in kernel 5.6:

  https://git.kernel.org/pub/scm/bluetooth/bluez.git

Unfortunately both that kernel and bluez version seem to be too new to realistically make it into Ubuntu 20.04.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Revision history for this message
Guillaume Martres (smarter) wrote :

Someone is working on adding wideband support to pulseaudio (this currently requires ofono): https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/254

QkiZ (qkiz)
Changed in pulseaudio (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Josh Leivenzon (joshleivenzon) wrote :

This is even more important now, with many people working/learning from home...

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

One small step: bug 1877536

Revision history for this message
Jeff Nappi (jeffnappi) wrote :

Great to see traction on this, thank you for all your efforts Daniel! And to everyone else, this is a far more complex problem than you can imagine 😅 However it can and will be solved :)

Revision history for this message
Kevin Lin (kevins8) wrote :

+1

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

If you want to +1 bugs, please use the green link near the top left of the page.

Revision history for this message
agm97 (albertogomezmarin) wrote :

Are you planing to patch ubuntu packages or waiting to be in upstream?
I'm asking because in pulseaudio side I am watching no much interest at all in that changes.. and in the kernel's side the same, so I doubt if that will gonna be fixed or not, at least, in upstream.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The patch doesn't sound like something we would like to carry as a distro patch, also the depends of ofono mentioned sounds suboptimal

Revision history for this message
joao vieira (joaosensefinity) wrote :

this affects me for some years now, bosses now complain for me to move to windows as now we are all remote with tons of meetings and this is a big impact on how they see all this linux desktop adoption.

tags: added: focal groovy
removed: eoan
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Not sure how many parts there will be to this in the end...

bluez: Fixed in 5.54? That's in Ubuntu 20.10 already.
linux: Fixed in 5.6-ish? That's coming to Ubuntu 20.10 soon via kernel 5.8.
pulseaudio: In progress (pulseaudio!227).

Changed in pulseaudio (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Triaged
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in pulseaudio (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Cristiano Fraga G. Nunes (cfgnunes) wrote :

I use Ubuntu 20.04.1, and I have the same problem. I confirm this bug.

Revision history for this message
andy kitchen (kitchen-andy) wrote :

Ubuntu 20.04 user, can confirm this bug.

Revision history for this message
Victor Bloetjes (trustmega) wrote :

Linux Mint 19.3 user and I can also confirm this bug.

summary: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
- wide band speech support.
+ wide band speech support (Bluetooth A2DP codecs ).
summary: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
- wide band speech support (Bluetooth A2DP codecs ).
+ wide band speech support (Bluetooth A2DP codecs).
Revision history for this message
rahul (rahulgulve8) wrote :

Ubuntu 20.04 user, can confirm this bug.

Revision history for this message
bernd (triggetry) wrote :

Same here (Ubuntu 20.04)

Revision history for this message
maurizio de santis (izietto) wrote :

I've just logged in to share the workaround I've been using for the last two years. I have a Sony WH-1000XM3 Bluetooth headset, I bought the following USB key Bluetooth transmitter: https://www.amazon.it/gp/product/B01G3J1I5M/

No issues with it, audio quality is great either for music and for calls, both incoming audio and mic.

It saved me from installing another OS for work, I hope it might be a good alternative for someone else.

Revision history for this message
Falc (roma24ster) wrote :

I can confirm that the above solution works well. I bought a similar but slightly cheaper one:
https://www.amazon.co.uk/gp/product/B086L2WNPG/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1

Basically the dongle pairs directly to your headset and acts as a usb sound card. By far the easiest solution I've found.

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote : Re: [Bug 1838151] Re: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support (Bluetooth A2DP codecs).

Generally speaking, the "USB soundcard" is the last fallback of an
experienced Linux user if you are unhappy what is in your laptop. Be it the
Bluetooth software stack or the fighting with crappy driver support for the
physical sound card hardware.

But thanks for pointing out that solution.

Andreas

Am Mi., 14. Okt. 2020 um 11:05 Uhr schrieb Falc <<email address hidden>
>:

> I can confirm that the above solution works well. I bought a similar but
> slightly cheaper one:
>
> https://www.amazon.co.uk/gp/product/B086L2WNPG/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1
>
> Basically the dongle pairs directly to your headset and acts as a usb
> sound card. By far the easiest solution I've found.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Actually most laptops (or desktops) can't compete with USB sound cards. Because the audio chips that come on your motherboard:

 * are usually cheaper and lower quality;
 * often have limited kernel/ALSA driver support (which is why the alsa-driver bug backlog is always out of control);
 * often suffer from noise on the headset jack from the digital-to-analog stage being too close to the rest of the computer.

So I strongly recommend USB audio in general. Especially for wired headsets where you can also avoid the lossy nature of Bluetooth audio encoding.

And for Bluetooth audio, such a USB dongle sounds like a great workaround for this bug. But we all wish it wasn't necessary.

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote :

Nice explanation of the mess that Bluetooth audio is, as I'm reliving my
frustrations currently (my wife bought her first headset, for her Windows
laptop, and discovered that “plug and play” is sadly “buy and pray” in
Bluetooth land :( )

https://habr.com/en/post/456182/

* generally all OS (Android, Linux, Windows, AFAIK, but probably also the
Apple offerings) are secretive about what they negotiate with the headset.
 (I mean, capturing the traffic and analysing it to know which codec is
used. OK, on Android & Linux that sounds like part of the heritage, but I
discovered yesterday that this state-of-the-art in 2020 in the Windows
world)
* headset manufacturers tend to be secretive about the features and
protocols/profiles their devices support. Now some of that is
“understandable” manufacturers not wanting to show that their devices don't
support the cool stuff, but in many cases manufacturers don't give the
details even if they would show their products in a positive light. Guess
they don't want a 2 KB of small print of abbreviations in their spec
sheets.
* Furthermore BT Audio is complicated by the fact, that historically the
standard supports only “high quality" playback & but mono playback with a
groovy frequency bandwidth (GSM style sound) when recording audio. There
are ways around that, but not all devices implement them, and not always in
the same way.”
* patented codecs, pure joy (that makes the xkcd comic in the above link
even "funnier" for open source systems).
* Thus you have a situation that standards that out for decades are still
only implemented partially by the market, and where they are implemented,
they are not necessary implemented 100% by the book, shudder.

Ah, sorry for the rant, but “buying BT headsets” raises my blood pressure,
and I'm one of the happy owners of a flagship mobile without a 3.5 mm
connector (which is fine, I'm too clumsy to use tethered headphone on the
move anyway, shrug).

Andreas

Am Mi., 14. Okt. 2020 um 11:41 Uhr schrieb Daniel van Vugt <
<email address hidden>>:

> Actually most laptops (or desktops) can't compete with USB sound cards.
> Because the audio chips that come on your motherboard:
>
> * are usually cheaper and lower quality;
> * often have limited kernel/ALSA driver support (which is why the
> alsa-driver bug backlog is always out of control);
> * often suffer from noise on the headset jack from the digital-to-analog
> stage being too close to the rest of the computer.
>
> So I strongly recommend USB audio in general. Especially for wired
> headsets where you can also avoid the lossy nature of Bluetooth audio
> encoding.
>
> And for Bluetooth audio, such a USB dongle sounds like a great
> workaround for this bug. But we all wish it wasn't necessary.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Revision history for this message
Alex Shkop (a-v-shkop) wrote :

Have a question about USB bluetooth transmitters mentioned above. Both models include Talk/Listen switches. Do you have to use them to get decent quality for music and for calls? Or is music quality good even in Talk mode?

Revision history for this message
Falc (roma24ster) wrote :

I can only speak to the one that I linked, but yes it has talk/list switch. The talk mode is only for talking (the music quality is BAD), the lisen mode is only for listening (the music quality is good).

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote :

I've got a DG60 dongle (a slightly bigger cousin), and my experiences with
a headset that does only have SBC/MP3 codecs (Aftershokz Aeropex)

   - It switches attached to my Linux (Ubuntu 18.04) automatically to
   HFP/HSP profile (mono + microphone, but in good quality) when my laptop
   starts to use the microphone.
   - You can switch mode manually (for the very seldom case where it
   somehow does not realize that it should switch).

Andreas

Am Mi., 28. Okt. 2020 um 19:30 Uhr schrieb Falc <<email address hidden>
>:

> I can only speak to the one that I linked, but yes it has talk/list
> switch. The talk mode is only for talking (the music quality is BAD),
> the lisen mode is only for listening (the music quality is good).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Revision history for this message
Paul (bratstejskal) wrote :

How do we get the Kernel maintainers to approve the remaining patches? I thought it might be fixed in 20.10 (KUbuntu), but it is not. I would think there is at least one kernel approver within Canonical? If not, who do I get in touch to talk about this?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It appears the kernel work is done and we are waiting on PulseAudio now. To join or monitor that conversation go to: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/776

Revision history for this message
Dennis (dennis9771) wrote :

Hey there,

according to the above statements there has been a fix released for bluez bluetooth stack as well for ubuntu system?

Am I able to get this fix installed for now?

Best Regards
Dennis

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

We're not 100% sure what fixes are required but it looks like it will require fixes in the kernel AND bluez AND pulseaudio. The first two are included in Ubuntu 20.10 already, but that's not enough to fix this bug.

If you want to track the main work outstanding then please look at:

  https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/776
  https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/227
  https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/254
  https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/288

It seems the PulseAudio developers are targeting future version 15. That will take a while because even version 14 isn't released yet.

Revision history for this message
Dennis (dennis9771) wrote :

@vanvugt

Thank you for your quick response!
Does that mean I would have to wait for Pulseaudio to fix this in one of their future releases (maybe v.15) or will it be possible to use an alternative soundmanager, where the kernel fixes would be sufficient to use A2DP for bidirectional bluetooth sound?

Homeoffice without cableless headset is just not that comfortable :s

Best Regards
Dennis

Revision history for this message
Igor (igor871) wrote :

@dennis9771

Just get yourself Bluetooth audio card and save yourself a trouble, this will never be fixed. And you will not be able to use A2DP for conversation even if fixed. The goal of the fix is to add HFP 1.6 with mSBC 16kHz audio encoding so you have better quality during conversation.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I don't know of any alternative "soundmanager" for desktop Linux that has better Bluetooth support than PulseAudio. At least not on desktop Linux... I think Google wrote their own stack for Android.

Revision history for this message
gdi2k (gdi2k) wrote :

@igor871

Very interested to learn more about such Bluetooth audio cards. Years ago I had a Plantronics headset (Voyager?) that came with a USB dongle that presented itself as a USB sound card to the operating system, and it was perfect (two-way HD audio). But the dongle (Plantronics BT300 and BT600) is only compatible with Plantronics headsets from what I understand.

I've looked at the Creative Labs USB Bluetooth sound cards (BT-W2 and BT-W3), but the first one requires the FastStream codec to provide high quality two way audio, which is rare, and the second just includes an analog mic that you plug into to your laptop's mic-in port - hardly a solution (I may as well use my laptop's in-built mic). They do support two way audio with your headset's mic, but only in classic HFP mode, which is what we already have.

Are you aware of any other solutions? I would pay good money for a USB dongle that presents itself as a sound card to the OS and supports HFP 1.6 HD two way audio.

Revision history for this message
Mark (mkay581) wrote :
Revision history for this message
Falc (roma24ster) wrote :
Revision history for this message
Falc (roma24ster) wrote :

The one in #48 wouldn't, it wouldn't act as a sound card.

Revision history for this message
Mark (mkay581) wrote :

Thank you for the advice! I'm going to purchase and see if it works with my setup.👍

Revision history for this message
Stanislav German-Evtushenko (giner) wrote :

I can confirm, 1Mii b10 works pretty well.

Revision history for this message
Aurélien PRAGA (aurelienpragawithings) wrote :

I'm also interested by such Bluetooth adapter, which one do you recommend between the Avantree Leaf and 1Mii b10?

Revision history for this message
Simple User (justforabot) wrote :

@ #47
Creative Labs BT-W3 supports mSBC (https://sg.creative.com/p/speakers/creative-bt-w3).
I had checked with them before buying one.
Tried pairing it with Jabra Talk 15, as well as Avantree Clipper Pro, and I can confirm that it works. Tried plotting the spectrum of the recorded audio using Audacity to confirm. Affirmative.

Revision history for this message
Aurélien PRAGA (aurelienpragawithings) wrote :

I tried an Avantree Leaf bluetooth transmitter with my Plantronics Blackbeat Pro 2 and I don't have any improvement. In call mode, the sound is still mono with the same (bad) quality that switching the sound profile to HSP/HFP. Why there is no difference?

Revision history for this message
gyhor (gyhor) wrote :

I bought the 1Mii and tried to connect it. Unfortunately without success.
Ubuntu don't recognize it:

[ 6308.630984] usb 3-1.1.3: new full-speed USB device number 10 using xhci_hcd
[ 6308.631134] usb 3-1.1.3: Device not responding to setup address.
[ 6308.839133] usb 3-1.1.3: Device not responding to setup address.
[ 6309.051064] usb 3-1.1.3: device not accepting address 10, error -71
[ 6309.251079] usb 3-1.1.3: new full-speed USB device number 11 using xhci_hcd
[ 6309.251188] usb 3-1.1.3: Device not responding to setup address.
[ 6309.459244] usb 3-1.1.3: Device not responding to setup address.
[ 6309.667097] usb 3-1.1.3: device not accepting address 11, error -71
[ 6309.667245] usb 3-1.1-port3: unable to enumerate USB device

Revision history for this message
Falc (roma24ster) wrote :

@gyhor For the 1Mii B10 it specifically lists Linux support, see here: https://1mii.com/product-item/b10/

For me when I plug it in is shows up as a sound output device, screenshot (Ubuntu 20.04): https://imgur.com/a/gmToEL3

Revision history for this message
Falc (roma24ster) wrote :

Sorry that screenshot, failed and I cant edit my post, here is the screenshot: https://imgur.com/flypHpz

Revision history for this message
gyhor (gyhor) wrote :

Different colleagues (with stationary computer, thinkpads and me with an msi ) tried it, but everyone did get the same error message.

Revision history for this message
Igor (igor871) wrote :

@gdi2k

What we have in the Linux now is HFP with 8kHz encoding. All other platforms such as Windows, Android, Chromium, etc, supports HFP with 16kHZ encoding which is much much better quality. Sure, it's not like A2DP, but quality is very much acceptable to speak with someone.

Revision history for this message
gyhor (gyhor) wrote :

https://wiki.gentoo.org/wiki/Bluetooth_headset

"If you do not want to use PulseAudio, you can use bluez-alsa to provide integration between Bluez and ALSA. "

Did someone tried that on ubuntu?

Revision history for this message
gyhor (gyhor) wrote :

or could some one point me where to find some information how to use the patches?

Revision history for this message
Davide Pessina (pesso82) wrote :

Recently i bought both: 1Mii B10 and Avantree Leaf

Quick review of them on my Ubuntu 16.04 64bit

- plug and play -> both OK, no issues
- audio quality with mic enabled -> bad bad bad, no significantly different than using pc bluetooth

Therefore... there is no solution, apart from wired headset

Revision history for this message
Simple User (justforabot) wrote :

@ gyhor, I am pretty sure you got a faulty 1Mii B10. It doesnt get past enumeration, so it is not a compatibility issue.
You also mention that it was tried on different systems and didn't work.
Time to get it replaced.

Revision history for this message
Simple User (justforabot) wrote :

@63 - your headset likely doesn't support mSBC (16 KHz), only CVSD (8KHz) in HFP/HSP mode.
If that is the case, any fix - using a USB soundcard as you did, or a software fix (which this page is tracking) isn't gonna help.

If it does support mSBC, 1Mii B10, and Avantree Leaf, Creative BT-W3 should be able to give decent quality audio. The definition of 'decent' varies of course.
Most people in this age and time wouldn't be happy with 8 KHz (else, this page wouldn't exist), but mSBC is decent enough for most people, at least for typical voice calls.

You can check the sampling frequency used very easily using Audacity > Record a few seconds using the mic in question > Analyze > Plot Spectrum. Note that Audacity plots in log scale for freq by default.
If the highest freq component is just below 4 KHz, it is using CVSD @ 8 KHz sampling, and your headset is the likely culprit. If the highest component is 8 KHz, it is using mSBC @ 16 KHz. If you think that is not good enough, your options are limited.

You can use FastStream (FS) which is supported only by a limited number of headsets, as well as by dongles such as Leaf, 1Mii B10, Creative BT-W2. No OS afaik supports it, so you can't use the dongle. Many devices have buggy implementations of FS.

AptX LL also supposedly has bidirectional audio support, but the voiceback part is not supported by any device that I know of.

Revision history for this message
Simple User (justforabot) wrote :

@61, yes. I had tried it and it works. It also has mSBC support - https://github.com/Arkq/bluez-alsa/issues/29, but the author himself admits that mSBC support is buggy and is not being developed. I could get it to work, but the audio was very choppy.

Revision history for this message
Davide Pessina (pesso82) wrote :

@65 - thank for explanation

Could someone post a list of headsets with mSBC support?

Price below 100€ if possible

Specification are hard to find, and headset market is crowded...

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote :

That one was a good one. Bluetooth gadget makers seem to be allergic to
exactly specify what their gadgets really support.

That's on one side extremely understandable, it would be mostly not
understandable for humans, the Bluetooth standards involved are arcane, and
even relatively experienced computer scientists that are not BT experts can
be surprised from time to time, even if they tried to make themselves
clever about BT.

OTOH, it makes buying Bluetooth headsets slightly a risky business.

Then it does not help that most host implementations are kind of not
talkative about the connection that they negotiated with the head set.
(I mean figuring out which codecs your headset supports involves capturing
the traffic and analyzing that, that's state of the art in 2020 on Windows.
Now that's user friendliness taken to the extreme, wouldn't you say? Now on
Linux, bluez includes an utility that can tell you more about your headset.
For whatever reason, Ubung don't include avinfo in their packages, I mean
why burden users with details about their headsets?)

So my process is sadly as follows:

   - Look at your headsets (choose BT 4.1/4.2 devices that usually makes
   sense), read reviews
   - Order it online
   - Test if I'm happy with it (on linux, avinfo can tell you about codecs
   supported, but connecting it to an Android device, doing an Internet based
   video call, and asking the other side how if you sounded "okay" is usally
   okay. Bad BT is usually identified as "you sounded really bad, like from
   the last century").
   - If the headset is not okay, send it back.

Sadly, the reality of not complete spec sheets on devices makes it
basically impossible to know what you are buying beforehand, in general.

Andreas

Am Mi., 18. Nov. 2020 um 19:11 Uhr schrieb Davide Pessina <
<email address hidden>>:

> @65 - thank for explanation
>
> Could someone post a list of headsets with mSBC support?
>
> Price below 100€ if possible
>
> Specification are hard to find, and headset market is crowded...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Revision history for this message
Davide Pessina (pesso82) wrote :

Yes, that’s the point

I’m try to use JBL T450BT

These are the available specs on official site

Control and Connection Specifications
Bluetooth profilesHFP v1.5, HSP v1.2, A2DP v1.2, AVRCP v1.4
Bluetooth frequency2.402GHz-2.48GHz
Bluetooth transmitted modulationGFSK,π/4DQPSK, 8DPSK
Bluetooth transmitter power0-4 d

I don’t find mSBC information, so it’s supposed they don’t support mSBC

What about Sony WH-CH700? They seems to support mSBC, but who knows.. :(

Revision history for this message
Igor (igor871) wrote :

@pesso82

There is your problem. Those headphones do not support HSP 1.6 profile, only 1.5.

Revision history for this message
Igor (igor871) wrote :

I meant HFP profile.

Revision history for this message
Richard Somlói (ricsipontaz) wrote :

PulseAudio 14.0 is out [1], so hopefully there's no other blocker to merge missing features:
https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/227

1: https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/14.0/

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Unfortunately the developers could not agree and closed: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/227

That doesn't mean desktop Linux will never have it. Just not any time soon :(

Changed in pulseaudio (Ubuntu):
status: In Progress → Triaged
Revision history for this message
Richard Somlói (ricsipontaz) wrote :

Disappointing. I've just ordered a 1mii B10 USB Bluetooth 5.0 Audio Transmitter as a workaround...

Revision history for this message
Felix Griewald (tiiunder) wrote :

Time to get a Macbook or Chromebook or whatever

Revision history for this message
Filippo (filippom) wrote :

I understood that they need to deal with new codec inclusion, via GStreamer o other libs,
and that writing code and manage a community is not a simple task.

Said that,

IMHO there are three big question with bluetooth and PulseAudio:
1. in these days we (probably most of us) are always on web conferencing and we need good audio quality in both direction, mic and speaker.
Current bluetooth headsets are capable of using Bluetooth Profile HFP 1.6 with mSBC 16kHz audio encoding, this standard permit high quality voice conferencing and It was made in 2011...9 year ago.

2. Bluetooth Profile A2DP for listening only (music...) There are a lot of codec for
high quality listen audio, es. SBC-XQ, aptX-LL, aptX-HD, aptX Voice and FastStream

3. Support for new version of Bluetooth / Profile. Ex #1 BT 5.3 with LC3 (Low Complexity Communications Coded (LC3)) codec. Ex #2 BT Profile HFP 1.8 with codec selection and Enhanced Voice Recognition Activation.

My two cents

Revision history for this message
Mike Rans (rans) wrote :

Perhaps the best hope is that Pipewire develops quickly and replaces Pulseaudio:

https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/249

Revision history for this message
Nikke (nmellegard) wrote :

It seems that on Ubuntu 20.10 it is fixed by installing pulseaudio-modules-bt (which also uninstalls pulseaudio-module-bluetooth) from this ppa: https://launchpad.net/~berglh/+archive/ubuntu/pulseaudio-a2dp

Then:
> sudo systemctl restart pulseaudio
> pulseaudio -k

Did just a few tests with Google Duo with my Jabra Elite Active 65t buds, and the sound is a LOT better both on my and the other end!

Revision history for this message
Nikke (nmellegard) wrote :

Edit for #78

sudo systemctl restart pulseaudio -> sudo systemctl restart bluetooth

And perhaps a bit quick on the trigger... The sound seems better, though maybe not that much :/

Revision history for this message
soredake (soredake) wrote :
Revision history for this message
Richard Merren (richard-merren) wrote :

I installed pulseaudio-modules-bt and it does give some new options for sound output and possibly better sound, but microphone sound quality was still iffy. Recorded sound on Audacity seemed better and was slightly louder (according to the DB meter), but a test call on Microsoft Teams was still muffled and unintelligible.

I have ordered a Avantree DG80 dongle (which makes the bluetooth connection externally and appears to linux as usb audio) and will hopefully be able to continue working with that, but I would love to see this problem resolved in pulseaudio.

For the record, I am using a Sony WH-1000XM4 headset on PopOS 20.10 running on a System76 Darter Pro.

Revision history for this message
Piotr Zientarski (piotr.zientarski) wrote :

Avantree DG80 is an amazing device, it works out of box and it switches between HSP/A2DP profiles automatically - tested with AKG K371-BT and Denon GC-25w.

Revision history for this message
Richard Merren (richard-merren) wrote :

I can't seem to get the DG80 working correctly under PopOS 20.10. It works great for listening to music (though that worked directly on bluetooth without issues) but I can't seem to get the correct mode for talk. Since you say you have success with it, I will play with it some more before returning it and see if I can get it set up properly. It is probably some kind of configuration thing on my end, but I was hoping it would solve my microphone problems.

As it stands, my best option is using the headset with my phone for Teams calls--the sound works perfectly there. If I find the right magic, I'll reply again here.

Revision history for this message
Piotr Zientarski (piotr.zientarski) wrote :

Strange, maybe yours is broken?

Sound from mic should be quiet good, like on Windows or Android (mono 16 kHz, or even 48 kHz if your headset supports FastStream codec).

I have also Zoweetek B0310, this one also works for me but it doesn't have auto profile switching.

I'm using Lenovo T480, ArchLinux with kernel 5.10, pulseaudio 14 and latest Gnome.

Revision history for this message
Richard Merren (richard-merren) wrote :

I think the problem was in the headphones. I found I was having trouble on my phone as well. I contacted Sony support and they had me try a soft reset of the headset, which seems to have restored function. I am still getting bad mic sound on bluetooth, but I think it is just the low quality sound on this thread and not the completely muffled sound I was getting before. I will try reconnecting to the DG80 now and see if it is any better.

Revision history for this message
Jean- (jean-helou) wrote :

If I understand correctly all the discussions, an first step in the direction of higher quality sound for BT headsets just got merged into PA https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/440

Changed in pulseaudio (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Jean- (jean-helou) wrote :

the next step to get a full fix and improved sound quality for voip calls over BT headset is coming in https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/254

Revision history for this message
Jeff Nappi (jeffnappi) wrote :

>Jean- (jean-helou) wrote 6 hours ago: #87
>the next step to get a full fix and improved sound quality for voip calls over BT headset is >coming in https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/254

This is good news! Proper support for mSBC is critical for me to consider this bug resolved. It was the original intention of opening the bug in the first place :)

tags: added: fixed-in-15 fixed-upstream
Revision history for this message
Jeff Nappi (jeffnappi) wrote :

For those following along - it appears that the future of Linux audio servers will likely be PipeWire:

https://lwn.net/SubscriberLink/847412/d7826b1353e33734/

Revision history for this message
Oscar Pérez del Campo (oscarperezdelcampo) wrote :

I guess this bug has been solved. As stated in https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/776 by @rmeissn, from gnome-settings, when the headset is connected, you can switch from HSP/HFP to A2DP.
Once changed this setting my headsed sounds perfectly.

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote :

@Oscar That was never an issue: A2DP always sounded decent. The problem
with Linux Bluetooth headset support comes when you want decent quality
while listening and recording sound, you know e.g. during video calls.

Am Di., 30. März 2021 um 07:35 Uhr schrieb Oscar Pérez del Campo <
<email address hidden>>:

> I guess this bug has been solved. As stated in
> https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/776 by
> @rmeissn, from gnome-settings, when the headset is connected, you can
> switch from HSP/HFP to A2DP.
> Once changed this setting my headsed sounds perfectly.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Maybe it was this we were waiting for:

https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/507

Regardless, PulseAudio version 15 (not yet released) is the goal.

Revision history for this message
Luis Alberto Pabón (copong) wrote :

That would be for 21.10 at this point yes?

I wonder, how close/far is Ubuntu to swap PA for Pipewire? After next lts? I do believe this particular issue is not present on current Pipewire.

Revision history for this message
Andreas Kostyrka (andreas-kostyrka) wrote :

We'll see, Fedora 34 seems to have switched to Pipewire, and F34 is in my
near future, so I'll be experimenting.

Am Mi., 7. Apr. 2021 um 11:51 Uhr schrieb Luis Alberto Pabón <
<email address hidden>>:

> That would be for 21.10 at this point yes?
>
> I wonder, how close/far is Ubuntu to swap PA for Pipewire? After next
> lts? I do believe this particular issue is not present on current
> Pipewire.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1838151
>
> Title:
> Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing
> wide band speech support (Bluetooth A2DP codecs).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pulseaudio/+bug/1838151/+subscriptions
>

Changed in pulseaudio:
status: New → Fix Released
Revision history for this message
Luis Alberto Pabón (copong) wrote :

I haven't got any pulseaudio updates on 21.04, to which version of ubuntu was the fix released to?

Revision history for this message
Dario Menin (darioalessio-menin) wrote :

Will this be released to Ubuntu 20.04? This is very important for voice calls in these times.

Revision history for this message
Jeff Nappi (jeffnappi) wrote :

After two years of waiting on this, and seeing how disappointing the progress has been both in Ubuntu and PulseAudio, I am happy to say that I believe PipeWire is the future and I would hope that Ubuntu moves forward with switching to PipeWire (while keeping PulseAudio as an alternative).

I was able to follow these directions to switch to PipeWire and have found it to be acceptable with Bose NC700s and mSBC/HFP:

From: https://www.reddit.com/r/pop_os/comments/ofdalv/replaced_pulseaudio_with_pipewire_on_popos_2104_i/h4c5p6u/

# Add ppa for latest build
sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream && sudo apt update

# Install components
sudo apt install gstreamer1.0-pipewire pipewire-media-session libspa-0.2-bluetooth libspa-0.2-jack pipewire pipewire-audio-client-libraries

# If you get unmet dependencies, you can run:
sudo apt --fix-broken install

# Reload new services
systemctl --user daemon-reload

# Disable PulseAudio service
systemctl --user --now disable pulseaudio.service pulseaudio.socket

# If you update from previous version of PopOS
systemctl --user mask pulseaudio

# Enable Pipewire services
systemctl --user --now enable pipewire pipewire-pulse

# Enable Pipewire media session
systemctl --user --now enable pipewire-media-session.service

# I ran into an issue with a couple dependencies and needed to do the following before everything worked:
sudo apt install libspa-0.2-bluetooth libfdk-aac2
systemctl --user restart pipewire.service pipewire-pulse.service

Hope this helps.

tags: removed: groovy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.