[HDA-Intel - HDA Intel, playback] Audio stuttering

Bug #1019693 reported by Jem on 2012-07-01
110
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Arch Linux
New
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

My audio has always worked perfectly on this hardware and 12.04. On 30 June 2012 (Australian time) I received an update, including a kernel update. Since then the sound is stuttering.

Audio will play normally for 10 seconds or so, but then about 1/4 of a second of the audio stream will be replayed in a loop 5 or 6 times. Even during the audio-test executed from the ubuntu-bug application (a solid beep), there was a noticeable stop and restart of the beep. i.e. what should be beeeeeeeeeeeeeeeep became beeeeeee.bebebebebe.beeep

Others have reported a similar issue since the same patch: http://ubuntuforums.org/showthread.php?p=12064710&posted=1#post12064710

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pulseaudio 1:1.1-0ubuntu15.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: jem 2029 F.... pulseaudio
 /dev/snd/controlC0: jem 2029 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbcf8000 irq 44'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0887,1028040d,00100202 HDA:80862804,80860101,00100000'
   Controls : 52
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xfbdbc000 irq 45'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Jul 1 10:08:19 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel successful
Symptom_Card: Juniper HDMI Audio [Radeon HD 5700 Series] - HD-Audio Generic
Symptom_PulsePlaybackTest: PulseAudio playback test failed
Symptom_SpeakerTestPulseStderr: W r i t e e r r o r : - 3 2 , B r o k e n p i p e
Symptom_Type: Underruns, dropouts, or "crackling" sound
Title: [HDA-Intel - HDA Intel, playback] Underruns, dropouts or crackling sound
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/09/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0G3HR7
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd12/09/2009:svnDellInc.:pnStudioXPS8100:pvr:rvnDellInc.:rn0G3HR7:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: Studio XPS 8100
dmi.sys.vendor: Dell Inc.

Jem (jem-mawson) wrote :
Jem (jem-mawson) wrote :

The work-around in https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1008177 fixes this issue for me. Could it be the same issue? I have marked this as a duplicate.

Jem (jem-mawson) wrote :

Actually, the work-around I mentioned previously changed the interval of the pulsing, but did not fix the problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed

Since the work-around didn't help, maybe you should unmark it as a duplicate of that other bug. Your report it really exactly what I am experiencing (stuttering sound after a late June update) and I don't think the issues are the same (the other bug mentions problems since 10.04).

Jem (jem-mawson) wrote :

Yes, I would love to unmark as duplicate, but the option doesn't seem to be available. I'm hoping one of the pulseaudio team members is able to (and will) do it.

Jem (jem-mawson) wrote :

Got it, figured out how to remove the duplicate status...

I had the same problem, for me the solution was disabling automute.
alsamixer => disable auto mute

Like in this video: http://www.youtube.com/watch?v=Wrhl8iaDzFI

Hope it helps someone.

Brilliant. This work around has been successful for me (after 2 minutes of testing). Thank you.

summary: - [HDA-Intel - HDA Intel, playback] Audio stuttering
+ [HDA-Intel - HDA Intel, playback] Audio stuttering - (automute?)
Jem (jem-mawson) wrote :

After reboot, automute is still disabled, but the problem returns.

summary: - [HDA-Intel - HDA Intel, playback] Audio stuttering - (automute?)
+ [HDA-Intel - HDA Intel, playback] Audio stuttering

Hi, sorry to hear that, for me it hasn't returned, I suggest that you turn on and off the setting to see if it helps, this is what I have:

Jem (jem-mawson) wrote :

"Turn it on and off again". No, this didn't help. Thanks.

Jem (jem-mawson) wrote :

At this stage, normal video via VLC is fine. Flash and HTML5 youtube/vimeo videos via Chrome are affected, which seems to be this issue: https://code.google.com/p/chromium/issues/detail?id=123706

There is also a problem playing these in Chromium and Firefox. Although in these cases the video is slowed and the sound is choppy (as opposed to sped and video and sound).

Strangely the HTML5 video at http://html5video.org/ plays fine in all browsers.

Running killall pulseaudio restores correct video playback for all scenarios.

Same problem here on a System76 laptop, have been talking to them but they haven't been able to recreate it yet. Likewise, disabling auto-mute fixes the problem until reboot under Ubuntu, luckily I also have an Arch Linux dual boot which I just haven't rebooted since toggling auto-mute. The below information is from Arch:

tapio@tartufo> lspci| grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)

hexdump /proc/bus/pci/00/1b.0
# attached

uname -a
Linux tartufo 3.4.8-1-ARCH #1 SMP PREEMPT Thu Aug 9 21:21:22 CEST 2012 x86_64 GNU/Linux

If there is any other information I can provide, please let me know. I'd appreciate it if someone could compare their stuttering pci config with mine, similar to in this thread https://bbs.archlinux.org/viewtopic.php?id=129990

Damien Miller (djm) wrote :

It affects me too, on a Lenovo D20 workstation. The "automute" workaround doesn't work for me because alsamixer doesn't list an automute option. Details:

[djm@demiurge bt]$ lspci| grep Audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV770 HDMI Audio [Radeon HD 4850/4870]
[djm@demiurge bt]$ hexdump /proc/bus/pci/00/1b.0
0000000 8086 3a3e 0406 0010 0000 0403 0010 0000
0000010 0004 d070 0000 0000 0000 0000 0000 0000
0000020 0000 0000 0000 0000 0000 0000 17aa 1023
0000030 0000 0000 0050 0000 0000 0000 0105 0000
0000040
[djm@demiurge bt]$ uname -a
Linux demiurge 3.2.0-27-generic #43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

(I'm using the snd_hda_intel card and not the HDMI output)

Hmm, that's a different model, not sure which changes are relevant. Darn.

Damien Miller (djm) wrote :

I seem to have found a workaround - disabling message signalled interrupts for snd_hda_intel. I guess they are b0rked for this driver - were they switched on recently? I recall that the driver started stuttering only after a kernel "upgrade" that was released after Precise stable was released.

Edit /etc/modprobe.d/alsa-base.conf and append "enable_msi=0" to the "options snd-hda-intel" line (should be near the end).

Chrome flash video was completely unusable prior to this for stuttering and skipping, but seems quite solid now.

Richard Huddleston (rhuddusa) wrote :

i'm having sound issues in chrome too, especially with pandora.

setting "enable_msi=0" did not solve my problem, appeared to make it worse. i think the value of that setting may be determined by your exact hardware.

tags: added: pulseaudio
edward (deltorodata) wrote :

i begin to hate ubuntu... i got this problem since ubuntu 9.10... n up now, it is not possible to fix it... when i need something with audio... i got to open opera n use the webcam through flash in opera... so works everything... but if i dont do that... i stutter everything... n the programs are not stable... could be great if someone fix that...

@edward
Disabling auto-mute in alsamixer console tool makes sound problems
happening less frequently for me.
Try it out.

On 8 December 2012 15:05, edward <email address hidden> wrote:

> i begin to hate ubuntu... i got this problem since ubuntu 9.10... n up
> now, it is not possible to fix it... when i need something with audio...
> i got to open opera n use the webcam through flash in opera... so works
> everything... but if i dont do that... i stutter everything... n the
> programs are not stable... could be great if someone fix that...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1019693
>
> Title:
> [HDA-Intel - HDA Intel, playback] Audio stuttering
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1019693/+subscriptions
>

--
cheers,
Tomasz Kubacki

Jem (jem-mawson) wrote :

I was habitually doing a `killall pulseaudio` after login to get rid of this problem. About 4-6 weeks ago, again after a kernel update, the problem went away altogether. As the OP, I'm happy to say it's not a bug anymore. I'm not sure about all the others who are signed up to this bug.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.