failed to install packages from backup dvd

Bug #159721 reported by ivan on 2007-11-03
22
Affects Status Importance Assigned to Milestone
APTonCD
Undecided
Unassigned
aptoncd (Ubuntu)
High
Unassigned

Bug Description

i have aptoncd_0.1.97-0ubuntu1_all.deb on both my notebook and desktop. i first created a backup of the installed packages that i have installed on my notebook, then burnt the image with k3b successfully on a dvd. i then put in the dvd into my desktop, it asked me if i wanted to start a package manager. i tried yes and got an error (i get the same error when i just try to do the following command from the command line: apt-cdrom add)

E: Cannot find filename or size tag

What needs to be changed to get it working?

winkman (php-mitch) wrote :

The EXACT same thing has happened for me- much to my dissappointment!
When you try to add the APTonCD disc as a CD repository, an error pops up, saying that Synaptic "(Drive Letter) Cannot Find Filename Or Size Tag"
Ouch!
I"m left with a cd full of files, and no way to install them! :(
HELP PLEASE!
Mitch

Changed in aptoncd:
status: New → Confirmed
ivan (levchenko-i) wrote :

I was able to install the packages that I had on my cd partially in synaptic. In synaptic, click File->Add downloaded packages and point it to the directory on your cd that contains all of the debs (don't remember exactly which one, poke around and you will find it). A bit disappointed that nobody from the authors of this app. replied to this bug. Looks like it is not maintained anymore.

Laudeci Oliveira (laudeci) wrote :

Sorry for the delay in answer.
As you can see the problem doesnt look like an aptoncd bug, but apt-cdrom.
I've tried myself to reproduce such situation without success.

APTonCD still being in development and will show soon a lot of improvments.

Thank you for using it.

ivan (levchenko-i) wrote :

Hi

Thanks for the update!

how can we help to replicate this issue?

Laudeci Oliveira (laudeci) wrote :

Maybe you could send an iso file of your broken cd...

ivan (levchenko-i) wrote :

hm.. the one i used was over 4 gigs and i don't have it now.. i'll try to create a small one and attach it today.

ivan (levchenko-i) wrote :

sorry, will be able only tomorrow (don't have a cd-rw at the moment)

Hi,

Actually we need only the Packages.gz in the CD. If you could attach the
broken one would be nice.
Thank you.

winkman (php-mitch) wrote :

I haven't tried addding the CD as mentioned above (File>Add Downloaded Packages), (https://bugs.launchpad.net/aptoncd/+bug/159721/comments/2)
but I can send your the package.gz file.
(see attached)
Hope this helps,
Mitch

ivan (levchenko-i) wrote :

just some additional info:
2.6.22-14-generic, gutsy; aptoncd version: 0.1.97-0ubuntu1
attached are my Packages.gz and bz2 files

ivan (levchenko-i) wrote :
ivan (levchenko-i) wrote :

Hope that helps! If you need anything else from us, just ask! Wonderful app and I would be very happy to help to get it working!

Rafael Proença (cypherbios) wrote :

One more thing please,
Could you give me the output of
$ ls -alh /media/cdrom0

Or wherever your aptoncd disc is monted.

Thank you!

winkman (php-mitch) wrote :

Here are my results:

mitch@gigabyte-ubuntu:~$ ls -alh /media/cdrom0
total 628K
dr-xr-xr-x 4 root root 2.0K 2007-12-17 15:16 .
drwxr-xr-x 4 root root 4.0K 2007-12-20 11:12 ..
-r--r--r-- 1 root root 107 2007-12-17 15:16 aptoncd.info
dr-xr-xr-x 2 root root 2.0K 2007-12-17 15:16 .disk
dr-xr-xr-x 2 root root 58K 2007-12-17 15:16 packages
-r--r--r-- 1 root root 376K 2007-12-17 15:16 Packages
-r--r--r-- 1 root root 76K 2007-12-17 15:16 Packages.bz2
-r--r--r-- 1 root root 109K 2007-12-17 15:16 Packages.gz
-r--r--r-- 1 root root 248 2007-12-17 15:16 README.diskdefines
-r--r--r-- 1 root root 36 2007-12-17 15:16 Release

I'mpleased to help out with anything else. :)
Mitch

xilos (riki-kmp) wrote :

this worked for me
restore in aptoncd - go to synaptic - file- downloaded packages - in dialogue go to /var/cache/apt/archives - hit open and wait installs everything so you may have remove packages that you have tried and removed
xilos

ivan (levchenko-i) wrote :

How are we doing with this? Merry Christmas BTW!

Rafael Proença (cypherbios) wrote :

Unfortunately we were not able to reproduce the error.
It does not mean that there is no error, though. We will keep trying, but
until we can see the problem happening we will not be able to do anything
because we do not know what is causing it.

Happy Holidays!

Changed in aptoncd:
status: Confirmed → Incomplete
eglyph (a-dm) wrote :

I may confirm this issue.
A Packages.gz is attached.
Was able to install the whole bunch using dpkg --install *.deb in the packages folder (but never do it at home!).

Artem Popov (artfwo) wrote :

I'm pretty sure, that this error is happening, because there're no md5sums and sizes for Packages.* in the Release file.

MrDarkSide (omarrubenisaias) wrote :

I have the same issue. I've just created a CD, now Im trying to add it to the synaptic as a source and I get the same message, E:Cannot find filename or size Tag....wait...E:? Linux uses drives letters too? wheres is the option? I think it only uses cdrom0 adn cdrom1.... mmm.
Anyway...I just want to add those little boxes to the list the next time I mess with the system..
Thanks

Artem Popov (artfwo) wrote :

Manually creating the Release file by running "apt-ftparchive release ." and putting it to the CD actually solves this problem.

Rafael Proença (cypherbios) wrote :

I'll have a look at that. Thank you!

boga (boga-inbox) wrote :

Just encountered the problem once again. Re-creating Release with "apt-ftparchive release ." didn't help at all. What I've found out was that the last entry in Packages was incomplete:
---
Package: alien
Priority: optional
Section: admin
Installed-Size: 276
Maintainer: Ubuntu Core Developers <email address hidden>
--- and that's all, EOF here
When I removed that incomplete entry it worked fine (of course without alien package).
What I'd like to suggest to the developers is adding some Packages checking/fixing code as a workaround before the problem is fixed.

I also confirmed what boga said. I will try to burn a CD later in the week (ran out of blanks).
I used the AptOnCD in the Hardy repos. But for the CD, I have only tested it (and verified that the problem exists) in Gutsy. I will be able to try it out in Hardy later.

leleu_devil (leleu-devil) wrote :

the bug is caused by presence of broken packages in cache of apt-get, you must remove the packages containing "%" in the name when you aptoncd.

example of a package broken: automake_1% 3a1.10.1-2_all.deb - note the "%" in the name, these are the packages that must be removed before making his aptoncd.

Farhan Perdana (blaxnux) wrote :

There are so many packages which is actually not broken on the /var/cache, maybe this'll help.
rename the % to something else, then burn it with aptoncd and do not check the "Create meta packages" box. Anyway, better not include the packages on /var/cache.

yup, I know it is crazy to rename all of it one by one, so, either use bulk renamer program such as gprename to remove the %, or use the real_man style.

Copy the *.debs on archives to home, then on the terminal (got this bulk_renamer enlighment from P.Y.A.P :" ) :

$ for i in *; do mv $i ${i/'%'/'_'}; done

Ex (I use a file named rei%ayanami on rei folder. Dump all the debs is not so nice looking :P )

blaxnux@melchior ~/rei $ echo $SHELL
/bin/bash
blaxnux@melchior ~/rei $ ls
rei%ayanami
blaxnux@melchior ~/rei $ for i in *; do mv $i ${i/'%'/'_'}; done
rei_ayanami

anyway, {i/'%'/'_'} means Change "%" with "_"

Hope it works. :)

Kjell Braden (afflux) wrote :

Can confirm this on 0.1.98-0ubuntu2. This is definetly caused by the Packages file being incomplete, not because of "%" characters (which are used to escape for example "+").

Changed in aptoncd:
status: Incomplete → Confirmed
importance: Undecided → High
status: New → Triaged
Kjell Braden (afflux) wrote :
Kjell Braden (afflux) wrote :

Rationale for my changes: Only using .readline as long as the subprocess is running would result in dropping the part of the stdout that is written between last poll() and program termination. I changed the program to directly pass the complete stdout to inFile.

Rafael Proença (cypherbios) wrote :

Hello Kjell,

Thank you very much. That was surprisingly amazing!
Fix commited to upstream bzr.

Changed in aptoncd:
status: Triaged → Fix Committed
Changed in aptoncd:
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
Kjell Braden (afflux) wrote :

patch is waiting for sponsoring, so this is not in progress. Thanks.

Changed in aptoncd:
status: In Progress → Triaged
Chris Halse Rogers (raof) wrote :

Thank you for your contribution to Ubuntu. While the debdiff is correct, the package itself has a number of problems:
 * The .desktop file doesn't validate with desktop-file-validate
 * It doesn't build twice in a row (the clean target misses a large number of binary translation files)
 * It has a number of Lintian warnings.
 * It's missing a watch file

While these aren't your fault, would you like to fix them? If not, I'll look at fixing these problems before uploading your fix.

Changed in aptoncd:
assignee: nobody → raof
status: Triaged → Incomplete
Kjell Braden (afflux) on 2008-06-30
Changed in aptoncd:
assignee: raof → afflux
status: Incomplete → In Progress
Kjell Braden (afflux) wrote :

I tried to address most of the issues. Since I'm not familiar with debian-policy 3.8.0 I think it would be best if you or someone else check it.

The following two warnings come from python-distutils-extras' build_help part, I'm not sure how to handle them.
W: aptoncd: package-contains-empty-directory usr/share/omf/aptoncd/
W: aptoncd: package-contains-empty-directory usr/share/gnome/help/aptoncd/C/figures/

Note that the watch file actually does not seem to work with upstreams versioning, since the packages on their download site seem to have a different versioning.

I did everything I could think of, if you have any objections or better ideas, feel free to do it.

Kjell Braden (afflux) on 2008-06-30
Changed in aptoncd:
assignee: afflux → nobody
status: In Progress → Triaged
Bimal J Rekhadiya (bimaljr) wrote :

May be here is the sollution :
https://bugs.launchpad.net/aptoncd/+bug/268673

Changed in aptoncd:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptoncd - 0.1.98-0ubuntu3

---------------
aptoncd (0.1.98-0ubuntu3) intrepid; urgency=low

  [ Kjell Braden ]
  * APTonCD/core/scanpkgs.py: fix creation of package index by reading
    everything apt-ftparchive tells us (LP: #159721)

  [ Scott Kitterman ]
  * Version build-dep on dephelper to (>= 5.0.51~) due to dh_icons

 -- Scott Kitterman <email address hidden> Wed, 17 Sep 2008 09:09:05 -0400

Changed in aptoncd:
status: Fix Committed → Fix Released
libertyernie (libertyernie) wrote :

What worked for me (still using the old hardy version) was to run aptoncd as root. Obviously this is not ideal, so thanks for fixing it in intrepid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers