Error while installing kernel 2.6.37 Maverick

Bug #700654 reported by Mhd. Tarek
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Aptdaemon
Fix Released
Undecided
Unassigned
Linux
New
Undecided
Unassigned

Bug Description

I was installing the new kernel and I was following instructions from this page:
http://www.ramoonus.nl/2011/01/linux-kernel-2-6-37-installation-guide-for-ubuntu-linux/
I installed the first two packages without any problem but when I was installing the last package, the Software Center give me that error:

"An unhandlable error occured

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry."

then I tried sudo update-grub and thats the output:

/etc/default/grub: 33: Syntax error: EOF in backquote substitution

Mhd. Tarek (mhd-tarek)
summary: - Error while installing kernel 2.6.37
+ Error while installing kernel 2.6.37 Maverick
description: updated
Revision history for this message
Mhd. Tarek (mhd-tarek) wrote :

0 down vote accept

I found the fix for this bug by this codes:

sudo rm /var/lib/dpkg/info/linux-image-2.6.37-020637-generic.postrm
sudo rm /var/lib/dpkg/info/linux-image-2.6.37-020637-generic.list

my problem was with "linux-image-2.6.37-020637-generic" you can replace it with your package. then:

sudo apt-get clean all
sudo apt-get update
sudo apt-get upgrade

I ran sudo apt-get update twice.

Then I run synaptic and manually remove the package and my system is clean again. Many thanks to this blog:
http://allforlinux.com/2010/07/solving-e-sub-process-usrbindpkg-returned-an-error-code1/

Mhd. Tarek (mhd-tarek)
Changed in aptdaemon:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers