aptdaemon needs translations export from Launchpad

Bug #655642 reported by Andrej Znidarsic on 2010-10-06
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
aptdaemon (Ubuntu)
High
Michael Vogt
Maverick
Undecided
Unassigned

Bug Description

Hello !

When in software center or update manager one tries to authenticate, he is presented with the following dialog window:

http://img291.imageshack.us/img291/4937/overi004.png

As you can see the bold text in not translated. After discussion on #ubuntu-translations it seems that the .policy files have not been exported. The image above is for the slovenian language.

Gabor Kelemen (kelemeng) on 2010-10-11
Changed in ubuntu-translations:
status: New → Triaged
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in aptdaemon:
status: New → Invalid
Changed in ubuntu-translations:
importance: Undecided → High
klutzrick (klutzrick) wrote :

I just encountered this bug. Is there a work around or a fix yet?

Thanks.

Rick

David Planella (dpm) wrote :

I'm attaching the exported translations from Launchpad, so that it is easier to fix this bug an make an SRU.

If anyone would like to have a go at creating a package including these translations for an SRU, here's the general procedure:

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

David Planella (dpm) wrote :

Also note that addressing bug 663150 might save us from these situations in the future.

David Planella (dpm) on 2010-10-19
summary: - Translations of .policy files were not exported
+ aptdaemon needs translations export from Launchpad
Michael Vogt (mvo) on 2010-10-20
Changed in aptdaemon (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Michael Vogt (mvo)
milestone: none → maverick-updates
Michael Vogt (mvo) wrote :

For some reason I can not "nominate for release", launchpad OOPSes if I click on that.

Accepted aptdaemon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Cheng-Chia Tseng (zerng07) wrote :

Is that version 0.31+bzr50?
I installed it a few minutes ago, but the string "To install or remove software, you need to authenticate." is still in English within Traditional Chinese after reboot.

We have translated it on 2010-08-26. Maybe the translation has not updated.

Hello !
I have tested 0.31+bzr506-0ubuntu4 and the string in question is now correctly translated into Slovenian.
Thanks !

tags: added: verification-done
removed: verification-needed
Cheng-Chia Tseng (zerng07) wrote :

I attach a screenshot which shows 0.31+bzr506-0ubuntu4 installed but the string is still English.

Gabor Kelemen (kelemeng) wrote :

The new version works for me too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.31+bzr506-0ubuntu4

---------------
aptdaemon (0.31+bzr506-0ubuntu4) maverick-proposed; urgency=low

  * debian/patches/06_rosetta_po_update.patch:
    - updated translations from rosetta, this includes the
      policy.in files that can not be updated via language-packs
      (LP: #655642)

aptdaemon (0.31+bzr506-0ubuntu3) maverick-proposed; urgency=low

  * debian/patches/08_fix_deb_install.patch:
    - fix installing deb packages with odd/broken installed-size
      fields (LP: #656633)
 -- Michael Vogt <email address hidden> Wed, 20 Oct 2010 10:12:52 +0200

Changed in aptdaemon (Ubuntu Maverick):
status: Fix Committed → Fix Released

El dc 27 de 10 de 2010 a les 07:55 +0000, en/na Cheng-Chia Tseng va
escriure:
> I attach a screenshot which shows 0.31+bzr506-0ubuntu4 installed but the
> string is still English.

Hi Cheng-Chia Tseng,

Is this still a problem?

Looking at the PO file included in the package, it seems that the string
is indeed translated, so it should show up translated in the interface
as well:

#: ../data/org.debian.apt.policy.in.h:24
msgid "To install or remove software, you need to authenticate."
msgstr "若要安裝或移除軟體,您需要通過認證。"

If that is the case, would you mind changing the status to "Fix
Released"?

Thanks!

Cheng-Chia Tseng (zerng07) wrote :

I also used msgunfmt to convert the aptdaemon.mo in /usr/share/locale-langpack/zh_TW/LC_MESSAGES to do a recheck, the string has TRANSLATED indeed while it still shows the English string. Quite odd, though.

Gabor Kelemen (kelemeng) wrote :

I just installed Chinese locale, and tried to install something from software-center, and I see the problem too - while it works in Hungarian!

Attached is a screenshot of the problem, with the result of:
$ grep -A30 "To install or remove software" /usr/share/polkit-1/actions/org.debian.apt.policy
(at least the end of it) - seems that the string is translated for all three Chinese locale.

David Planella (dpm) wrote :

El dg 14 de 11 de 2010 a les 20:39 +0000, en/na Gabor Kelemen va
escriure:
> I just installed Chinese locale, and tried to install something from
> software-center, and I see the problem too - while it works in
> Hungarian!
>
> Attached is a screenshot of the problem, with the result of:
> $ grep -A30 "To install or remove software" /usr/share/polkit-1/actions/org.debian.apt.policy
> (at least the end of it) - seems that the string is translated for all three Chinese locale.
>
> ** Attachment added: "Screenshot.png"
> https://bugs.launchpad.net/aptdaemon/+bug/655642/+attachment/1733506/+files/Screenshot.png
>

Thanks Gabor and Cheng-Chia Tseng for the testing.

So it seems that translations were correctly exported, but are not
loaded for Traditional Chinese.

In any case, that confirms at least that we can close this bug, which
was concerned with exporting the translations from Launchpad, which
seems to have happened - although translations for Traditional Chinese
are not loaded.

Cheng-Chia Tseng, would you mind opening a separate bug for that and
adding a comment with a link to it, so we can follow it up?

Thanks!
--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Changed in ubuntu-translations:
status: Triaged → Fix Released
Cheng-Chia Tseng (zerng07) wrote :

@ Gabor Kelemen: Would you kindly do me a favor to file another bug for Chinese locale? I am being busy lately (a examination hosted next week on my school), though I will file another bug some days later after that.

Changed in aptdaemon:
status: Invalid → Confirmed
status: Confirmed → Invalid
David Planella (dpm) wrote :

The remaining issue was reported in bug 690270

Michael Vogt (mvo) on 2011-04-01
Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers