cannot install First Class client

Reported by Anulaikar on 2010-09-13
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned

Bug Description

..

Anulaikar (anulaikar) wrote :

Computor says:
There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry.

Sebastian Heinlein (glatzor) wrote :

The dialog also has got some details. Do you remeber them? Or have you made a copy of the details?

Changed in aptdaemon:
status: New → Incomplete
Sebastian Heinlein (glatzor) wrote :

Guessing: Are you using Maverick? Do you want to install a local package file from a folder which has got special chars in its name?

kristian304 (kblichfeldt) wrote :

The bug is also affecting me. I am using Maverick, and it is from a local package. The folder does not have special characters in its name.

Yes. But now I have solved the problem by installing 10.04.1 instead,
waiting for a more stable 10.10...

Daniel
--
**********************************************************************
Daniel Hedin
Norderön 361
832 93 Frösön
063-421 15

tis 2010-09-14 klockan 05:30 +0000 skrev Sebastian Heinlein:
> Guessing: Are you using Maverick? Do you want to install a local package
> file from a folder which has got special chars in its name?
>

Ctbeiser (ctbeiser) wrote :

I tried in GDebi too, and the terminal left the following message:

dpkg: error processing /home/chrisbeiser/fcc-10.009-Linux.i686 (1).deb (--install):
 unable to open file '/var/lib/dpkg/tmp.ci//.svn': Is a directory
Errors were encountered while processing:
 /home/chrisbeiser/fcc-10.009-Linux.i686 (1).deb

I'm on Maverick Netbook, and everything is up to date.

Ctbeiser (ctbeiser) wrote :

I apologize for the double post, but the tar.bz2 that they have for the same piece of software refuses to extract, and I'm tempted to blame Opentext for incomptence. Both files can be downloaded here: http://www.centrinity.com/Divisions/Resources/?Plugin=FC&OpenItemURL=S047C50E4

Alexander Luksep (a-luksep) wrote :

They might of course have updated the archive, but extracting the tar.bz2 worked for me.
.deb threw the same error as others have had.

Ole Wolf (ole.wolf) wrote :

I've downloaded version 10.0.0.9 of the Firstclass Client from Opentext's web site. Installing with "dpkg --install" works without problems on Lucid 10.4.1. However, on Maverick 10.10, it fails with the error reported by #6.

This indicates that Opentext may not be the only source of the problem; rather, something appears to have broken in dkpg since Lucid.

E Sorenson (sorens) wrote :

Agree with the previous post.

I also get this error in Maverick 10.10 trying to install a completely different program: FlowJo (http://offsite.treestar.com/downloads/publicbetas/flowjo.deb). Looks like the problem is in aptdaemon and happened with the move to 10.10.

Jorgen (jorgenqv) wrote :

I also can confirm problem installing fcc deb package in 10.10

dpkg: error processing /home/test/fcc-10.009-Linux.i686.deb (--install):
 unable to open file '/var/lib/dpkg/tmp.ci//.svn': Is a directory

Works fine in 10.04.1

aleandro (aleandrodasilva) wrote :

hi, I got this error after a trial of installation by source. I tried the deb package after deleting everything related to the previous installation. It seems that the package is working in any case properly cause in ubuntu center is said it is installed.
Doing some analysis.

Ubuntu Maverick

Eran Sadeh-Or (eranpolo) wrote :

Got the same error with a different .deb package. My solution - remove the (unnecessary) .svn folder from the .deb file.
I attached a small script that does just that - opens the deb file, removes the .svn folder from /DEBIAN/.svn and repackages the deb file.

Jeremy Blair (thebigguy7) wrote :

Hey this might be just me but idk so mine said somehting about mscore fonts and tt or something like that so i ran the sudo apt-get upgrade command and bang it worked try that.

Jeremy Blair (thebigguy7) wrote :

O srry for the double post but i have ubuntu 10.10

I got this (Swedish) error with Linux Mint Debian 32-bit 201012:

sudo dpkg -i fcc-10.009-Linux.i686.deb

dpkg: fel vid hantering av fcc-10.009-Linux.i686.deb (--install):
 kunde inte öppna filen "/var/lib/dpkg/tmp.ci//.svn": Är en katalog
Fel uppstod vid hantering:
 fcc-10.009-Linux.i686.deb

IKT (ikt) on 2011-03-17
Changed in aptdaemon:
status: Incomplete → Confirmed
IKT (ikt) wrote :

Currently can't install after downloading the client from here:

http://www.firstclass.com/Divisions/FAV13-0024FC95/?Plugin=FC&OpenItemURL=S047C50E4

V. 10.009 (Debian Intel)

As far as I'm aware the fix is listed here:

https://bugs.launchpad.net/aptdaemon/+bug/637489/comments/13

Testing it worked for me.

so now all we need to do is let someone who works at "first class" know the issue and the fix... can someone handle this?

AJenbo (ajenbo) wrote :

I put a fixed version of the deb here:
http://anders.jenbo.dk/fcc-10.009-Linux.i686.deb

IKT (ikt) wrote :

That's ok, but you need to send a request to them with the fixed package, so they can fix it for everyone not just people who run across this page.

I got this (Swedish) error with Ubuntu 11.04 (Natty Narwhal) i386:

sudo dpkg -i fcc-10.009-Linux.i686.deb

dpkg: fel vid hantering av fcc-10.009-Linux.i686.deb (--install):
 kunde inte öppna filen "/var/lib/dpkg/tmp.ci//.svn": Är en katalog
Fel uppstod vid hantering:
 fcc-10.009-Linux.i686.deb

uname -r -p
2.6.38-8-generic i686

Timothy Friesen (tjfriese) wrote :

I get the same error trying to install Kubuntu on Ubuntu 11.4. I have gone into Synaptic and scanned for broken packages and it found none.

Magnus Olsen (mucilago-8) wrote :

Can someone please tell me how to use the " fix_deb_svn.sh ", which is provided above. I really need Firstclass to work! I've tried several soulutions but none work.

Ole Wolf (ole.wolf) wrote :

Magnus: as far as I can tell, you simply open a terminal and make the fix_deb_svn.sh script executable then call it with the FirstClass Client package as an argument:

chmod 755 fix_deb_svn.sh
./fix_deb_svn.sh fcc-10.014-Linux.i686.deb

According to the script content, this will convert the fcc-10.014-Linux.i686.deb to an installable package, which you can now install like any other package.

Note that you'll have to satisfy a number of other dependencies, such as installing konqueror and (maybe) having to start the FirstClass Client with "padsp fcc" to avoid freezes owing to OSS sound problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions