Should acquire a lock on the lists

Reported by crtm on 2010-09-01
236
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Medium
Unassigned
aptdaemon (Ubuntu)
Medium
Sebastian Heinlein

Bug Description

Binary package hint: aptdaemon

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 155, in _process_transaction
    self.update_cache()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 514, in update_cache
    self._cache.update(progress)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 341, in update
    raise LockFailedException("Failed to lock %s" % lockfile)
LockFailedException: Failed to lock /var/lib/apt/lists/lock

Which Ubuntu version do you use? Maverick or Lucid?

If you are using Maverick could you pleas eupgrade to the lastest version. The locking was cleaned up recently.

summary: - Traceback (most recent call last): File "/usr/lib/python2.6/dist-
- packages/aptdaemon/worker.py", line 155, in _process_transaction
- self.update_cache() File "/usr/lib/python2.6/dist-
- packages/aptdaemon/worker.py", line 514, in update_cache
- self._cache.update(progress) File "/usr/lib/python2.6/dist-
- packages/apt/deprecation.py", line 98, in deprecated_function return
- func(*args, **kwds) File "/usr/lib/python2.6/dist-
- packages/apt/cache.py", line 341, in update raise
- LockFailedException("Failed to lock %s" % lockfile) LockFailedException:
- Failed to lock /var/lib/apt/lists/lock
+ Races in the system lock
Changed in aptdaemon (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete

I have Maverik 10.10.

Ok, I'm upgrade

Thanks!

2010/9/13 Sebastian Heinlein <email address hidden>

> Which Ubuntu version do you use? Maverick or Lucid?
>
> If you are using Maverick could you pleas eupgrade to the lastest
> version. The locking was cleaned up recently.
>
> ** Summary changed:
>
> - Traceback (most recent call last): File
> "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 155, in
> _process_transaction self.update_cache() File
> "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 514, in
> update_cache self._cache.update(progress) File
> "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in
> deprecated_function return func(*args, **kwds) File
> "/usr/lib/python2.6/dist-packages/apt/cache.py", line 341, in update
> raise LockFailedException("Failed to lock %s" % lockfile)
> LockFailedException: Failed to lock /var/lib/apt/lists/lock
> + Races in the system lock
>
> ** Changed in: aptdaemon (Ubuntu)
> Status: New => Confirmed
>
> ** Changed in: aptdaemon (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Races in the system lock
> https://bugs.launchpad.net/bugs/628061
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “aptdaemon” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: aptdaemon
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 155, in
> _process_transaction
> self.update_cache()
> File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 514, in
> update_cache
> self._cache.update(progress)
> File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in
> deprecated_function
> return func(*args, **kwds)
> File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 341, in update
> raise LockFailedException("Failed to lock %s" % lockfile)
> LockFailedException: Failed to lock /var/lib/apt/lists/lock
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/628061/+subscribe
>

------------------------------
[image: XT_BVM]
*Pbro. Dr. Carlos Ruben Terceiro Muiños*
Director Cultura Religiosa
UCCuyo Sede San Luis

summary: - Races in the system lock
+ Should acquire a lock on the lists
Changed in aptdaemon (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
assignee: nobody → Sebastian Heinlein (glatzor)
Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Changed in aptdaemon:
status: New → Fix Committed
importance: Undecided → Medium
tags: added: iso-testing
screamoticon (screamoforheart) wrote :

I cant install a repository from getdeb

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers