Concurrent work on the same POD template leads to errors.

Bug #740290 reported by Gaëtan Delannay on 2011-03-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Appy
Undecided
Unassigned

Bug Description

Today we had the following error:

  File "/var/snapshots/appy-0.6.3/appy/pod/renderer.py", line 146, in __init__
    self.prepareFolders()
  File "/var/snapshots/appy-0.6.3/appy/pod/renderer.py", line 305, in prepareFolders
    raise PodError(TEMP_FOLDER_EXISTS % self.tempFolder)
PodError: I need to use a temp folder "/usr/local/django/dsbe_eupen/media/cache/appypdf/contacts.Person-22315.pdf.temp"
but this folder already exists.

I had to manually delete the specified directory. So there must be at least one possible situation where appy.pod does not delete the temp folder. I suspect that it happens when a user double-clicks on the print button (i.e. a second call for the same file while the first call is still running). The problem is not that the second print request fails. The problem is that the first request won't tidy up in this case. Note that the temporary directory was not empty.

That problem is also present in other operating system platforms (e.g Win ).... :(

In my situation the .temp directory is not removable from the system because in use by the OO service...
Maybe there is a way to send a termination command to the UNO server to "release" the file in use instead killing the entire soffice istance?

Hi guys,
I think I've solved this problem by generating a unique name for the temp folder.
Tests are welcome !

I've committed this change in revision 150 (see http://bazaar.launchpad.net/~appy-dev/appy/trunk/revision/150).
To be released soon in Appy 0.6.7...
Cheers
Gaetan

Changed in appy:
status: New → Fix Committed

I installed the new version on my development machine. No problems so
far. But I didn't really test since my problem isn't systematically
reproducible.

Luc
On 2.06.2011 13:24, Gaëtan Delannay wrote:
> Hi guys,
> I think I've solved this problem by generating a unique name for the temp folder.
> Tests are welcome !
>
> I've committed this change in revision 150 (see http://bazaar.launchpad.net/~appy-dev/appy/trunk/revision/150).
> To be released soon in Appy 0.6.7...
> Cheers
> Gaetan
>
> ** Changed in: appy
> Status: New => Fix Committed
>

Changed in appy:
milestone: none → 0.6.7
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions