do section do cell fails

Bug #720270 reported by David Burke on 2011-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Appy
Undecided
Gaëtan Delannay

Bug Description

do cell does not work when used inside a "do section". See the attached document. The do cell behavior does not function as is documented. Instead it deletes all cells to the right of the "do cell"

A look at content.xml shows the problem. There is a stray </table:table-row><table:table-row> after the first cell. This causes LibreOffice to not render the rest of the first row and rightfully so. In addition we see many blank cells

</table:table-cell><table:table-cell office:value-type="string" table:style-name="Table1.A1">

This appears to be appy correcting for having to add a new row that it thinks needs to be created. Deleting these by hand the odt file can be corrected.

David Burke (bufke) wrote :
David Burke (bufke) wrote :

A little debugging in actions.py

if isinstance(self.elem, Cell):
            isCell = True
            nbOfColumns = self.elem.tableInfo.nbOfColumns
            initialColIndex = self.elem.tableInfo.curColIndex
            currentColIndex = initialColIndex
            rowAttributes = self.elem.tableInfo.curRowAttrs
            print self.elem.tableInfo.curColIndex <<<<<<<<< wrong index!

I guess it's getting that info from something in buffers.py but it's a bit over my head from there.

Thank you David,
I've committed a bug fix. Indeed, the current column index was wrong.
Cheers !
Gaetan

Changed in appy:
status: New → Fix Committed
Changed in appy:
milestone: none → 0.6.4
status: Fix Committed → Fix Released
Changed in appy:
assignee: nobody → Gaëtan Delannay (gaetan-delannay)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments