Substandard .desktop file (patch against bzr attached)

Bug #146957 reported by Stéphane Loeuillet
12
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned

Bug Description

It fixes the following problems reported by desktop-file-validate :
/usr/share/applications/apport-gtk-mime.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
/usr/share/applications/apport-gtk-mime.desktop: error: value "text/x-apport" for string list key "MimeType" in group "Desktop Entry" does not have a semicolon (';') as trailing character
/usr/share/applications/apport-gtk-mime.desktop: warning: value "GNOME;Application;Core;" for key "Categories" in group "Desktop Entry" contains a deprecated value "Application"
/usr/share/applications/apport-gtk-mime.desktop: error: value "True" for boolean key "NoDisplay" in group "Desktop Entry" contains invalid characters, boolean values must be "false" or "true"

Revision history for this message
Stéphane Loeuillet (leroutier) wrote :
Daniel Hahler (blueyed)
Changed in apport:
status: New → Fix Committed
Daniel Hahler (blueyed)
Changed in apport:
status: Fix Committed → Confirmed
Revision history for this message
Marco Rodrigues (gothicx) wrote :

$ desktop-file-validate apport-gtk.desktop.in
apport-gtk.desktop.in: warning: key "Encoding" in group "Desktop Entry" is deprecated

apport-gtk.desktop.in: error: file contains key "_Name" in group "Desktop Entry", but key names must contain only the characters A-Za-z0-9- (they may have a "[LOCALE]" postfix)

apport-gtk.desktop.in: error: file contains key "_Comment" in group "Desktop Entry", but key names must contain only the characters A-Za-z0-9- (they may have a "[LOCALE]" postfix)

apport-gtk.desktop.in: warning: value "GNOME;Application;Core;" for key "Categories" in group "Desktop Entry" contains a deprecated value "Application"

apport-gtk.desktop.in: error: required key "Name" in group "Desktop Entry" is not present

Revision history for this message
Martin Pitt (pitti) wrote :

Merged Daniel's branch (which has the fix) to trunk. Thanks, Daniel!

Changed in apport:
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

apport (0.102) hardy; urgency=low

  [ Martin Pitt ]
  * problem_report.py: Support reading reports with legacy zlib
    compression in 'retain compressed values' mode (as used nowadays by
    apport when reporting a crash). Add a test case, too. (LP: #129616)
  * debian/control, debian/rules: Switch from python-support to
    python-central, and use 'nomove' option so that apport works during
    upgrades, too. (LP: #121341)
  * debian/rules: Use dh_icons instead of dh_iconcache.
  * debian/apport.init: Do not stop apport in any runlevel (LSB header).
  * apport/ui.py, run_crash(): Catch zlib.error on invalidly compressed core
    dumps. (LP: #176977)
  * apport/ui.py: Give a meaningful error message instead of crashing if the
    package for a crash report is not installed any more. (LP: #149739)
  * apport/ui.py: Do not include ProcCmdline in bug reports, since these are
    not ack'ed by the user and might contain sensitive data. (LP: #132800)
  * apport/ui.py: Add various test cases for crash reports whose packages have
    been uninstalled between the crash and the report. This reproduces
    LP #186684.
  * apport/ui.py, load_report(): Produce proper error message if
    executable/interpreter path do not exist any more. (LP: #186684)
  * cli/apport-cli: Intercept SIGPIPE when calling sensible-pager, to avoid
    crash when quitting it prematurely. (LP: #153872)
  * bin/apport-checkreports: Print out a list of program names/packages which
    have a pending crash report. (LP: #145117)
  * apport/ui.py, run_argv(): Add return code which indicates whether any
    report has been processed.
  * cli/apport-cli: If no pending crash reports are present, say so and refer
    to --help. (LP: #182985)
  * apport/ui.py: Waive check for obsolete packages if environment defines
    $APPORT_IGNORE_OBSOLETE_PACKAGES. Document this in the apport-cli manpage.
    (LP: #148064)

  [ Daniel Hahler ]
  * .crash file integration for KDE3 (LP: #177055)
    - debian/apport-qt.install: install added files qt4/apport-qt-mime.desktop
      and qt4/apport-qt-mimelnk.desktop
  * Fixed minor warnings/errors from desktop-file-validate in
    gtk/apport-gtk-mime.desktop.in and qt4/apport-qt.desktop.in (LP: #146957)

 -- Martin Pitt <email address hidden> Wed, 06 Feb 2008 12:55:53 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers