Appmenu-gtk should not blacklist eclipse

Bug #865389 reported by Mingming Ren on 2011-10-03
This bug affects 104 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
appmenu-gtk (Ubuntu)

Bug Description

The current version of eclipse and swt library in oneiric work perfectly with appmenu.
Thus eclipse should be removed from appmenu's blacklist.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-gtk (Ubuntu):
status: New → Confirmed
Lorenzo Villani (lvillani) wrote :

The patch is there, and a merge request was approved 6 months ago. It's not merged upstream though.

Lior (lior) wrote :

I'm not sure that it's wise yet to merge - not all menu shortcuts appear when displayed under Unity (e.g. F11 - Run/Debug, the shortcut works but the shortcut key doesn't display under Unity).

To me, having HUD working on Eclipse is way better than seeing the shortcut displayed on the menu items...

In Eclipse the shortcut ctrl+3 might be equivalent to HUD.

Bilal Akhtar (bilalakhtar) wrote :

Charles, any reason why we haven't merged this branch yet?

Changed in appmenu-gtk:
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Bilal, when I asked around about this patch, I heard some concerns similar to Lior's in comment #3... this is secondhand knowledge, I haven't tested Eclipse against 12.04.

Bilal, do you want build a copy of appmenu-gtk with the patch and give Eclipse a spin with it? ;)

I've been using the trick in to edit the binary file, changing 'Eclipse' to something else for several weeks.
I can confirm that the menu works, but there is the issue that most shorcut sequences are not displayed on the corresponding menu items, but the shortcuts do work.
I prefer having the consistent menu bar without shortcuts (working with HUD) than have 100% correct menu representation but inconsistent with other applications.
Unrelated: I always install lo-menubar to have the global menu in libreoffice too, even if some shortcuts don't work, in favor of greater consistency.

Herczeg Zsolt (zsolt94) wrote :

I would like to say that me (and I think most of) the users has the same opinion that the showing of some shortcuts, (which are works!) is not more important than having the standard way of showing.

Please think about that also in a new version (or maybe in update)! Thanks.

Alex Jones (alex-jones) wrote :

The patch seems to work for me (12.04 and Juno). I'll report back in a week or two when I've really given it a good run.

Charles Kerr (charlesk) wrote :

Alex, anything to report?

My preference would be to remove Eclipse from the blacklist :)

Gilberto Olimpio (golimpio) wrote :

I don't understand why is it so hard to move the appmenu's blacklist to an external configuration file? It would make everybody's life a lot easy.

Eclipse work just fine with the appmenu.

Philipp (sacridex) wrote :

The branch is approved, but still not merged?

Lars Karlitski (larsu) wrote :

I've just tested it, eclipse hangs on its splash screen when I remove it from the blacklist. So the patch is not getting merged for now.

I've also reported bug #1062141 to make it easier for people to override the blacklist if they want to.

Mickael Istria (mistria) wrote :

Note that blacklisting Eclipse does not make a lot of sense. RCP applications based on Eclipse are not blacklisted, so it's not consistent.
Either you should blacklist all SWT-based applicaitons, either you should blacklist none of them.

I've tested hack described in with:
* Eclipse Juno using org.eclipse.swt.gtk.linux.x86_64 version 3.100.v4233d
* Ubuntu 12.04 LTS, up-to-date on 2012-10-17

I could see shortcuts on menu after the hack, and did not notice any difference in booting time. I tried 3 times with Eclipse using global menu, and 3 times without (current). All startups took 17s.
@Larsu Maybe you got an unlucky Eclipse boot when you tested. Can you retry on several boots instead of just a single one?

So I really support the idea of merging the branch and release a version that does not blacklist Eclipse.

Lars Karlitski (larsu) wrote :

Mickael, it happened every time I started eclipse, I tried it multiple times. I tested with 3.8.0~rc4-1ubuntu1.

I agree that blacklisting eclipse while not blacklisting other SWT applications is inconsistent, but I prefer that over having an unusable version of eclipse in Ubuntu.

Nicolay Doytchev (lightrush) wrote :

No hangs with hack on 12.04 either. Are you sure there wasn't any other variable that caused the issue?

Higgs Bison (bizzone) wrote :

Don`t you think that hardcoding name of another application in binaries is very bad programming style? I think options like blacklist should be placed in configuration files. Users shold be able to make a choise to use globalmenu or not. Besides, Eclipse is IDE for programmers, they actually know what they do.

But now after every upgrade to new version of Ubuntu I keep doing the same strange acion: open and find "Eclipse" sting. It`s funny.

Higgs Bison (bizzone) wrote :

Sorry, I`ve found recent ticket about hardcoding blacklist: #1062141 . I`m glad to see that this problem will be fixed.

Lars Vogel (lars-vogel) wrote :

Google now offer their customized version of the Eclipse IDE which is also not blacklisted.

I think out of consistency and to find the remaining bugs, it would be great if you could remove the blacklisting of Eclipse. I'm a Eclipse committer so if their are still issues on the Eclipse side with Eclispe 4.2 or higher please let me know.

I absolutely agree with Higgs Bison. Blacklists should never be in binaries. Besides that, patching the binary, Eclipse works absolutely fine with menuproxy for me. I guess it should also be removed, even if it might not work for some exceptions, as it's not really obvious, why menuproxy is working for everything else except eclipse.

Mystic-Mirage (mystic-mirage) wrote :

I created package eclipse-globalmenu for patching
Package contains dpkg triggers so patch will be automatically applied to on every appmenu-gtk update.

Supported appmenu-gtk from precise-updates and above. Tested on Raring i386 and x86_64.

Stephan Henningsen (zta77) wrote :

Still present in 13.04. According to comment #2 a patch was made over a year ago. What's taking so long? This is ridiculous!

Alan (alanjas) wrote :

I'm in 13.10 (Saucy) with the latest version packaged: 3.8 with this problem. The package: eclipse-globalmenu fix my problem.
Why there are only 3.8 packaged and in the page you get the 4.3 ???

Michael Prentice (splaktar) wrote :

The eclipse-globalmenu does not appear to work anymore with the latest 13.10. It appears to use appmenu-qt instead of appmenu-gtk. But eclipse menus are still broken for me with Eclipse 4.3. Setting UBUNTU_MENUPROXY=eclipse does not work for me either.

If I can't find a resolution for this, I"ll have to use another DE than Unity.

I had to give up patching because since Eclipse 4.2 (4.3 also) crashes constantly when using appmenu.
It works well while it is up and running, but suddenly it crashes silently.
With the patch (that is, without Eclipse being blacklisted) Eclipse crashes, say, 10 times in a work day. Without the patch it runs fine for hours.
So, there is something new on the 4.X platform that doesn't plays nicely with appmenu....

Sera (seraphim6x7) wrote :

I wouldn't be too quick to assign blame for those crashes to appmenu. I've been having frequent crashes with Eclipse 4.2 and 4.3 but these crashes started happening after I had been using the above patch for a while.
Based on @luisfpg's comment I reverted the patch and the frequent crashes haven't stopped.

Daniel Hahler (blueyed) wrote :

FWIW, @splaktar: you have to unset (or assign 0 to) UBUNTU_MENUPROXY.
This should work (from a shell): UBUNTU_MENUPROXY=0 eclipse
See also

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers