some apps are missing menu items

Bug #709839 reported by Omer Akram on 2011-01-29
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Invalid
Undecided
Michael Terry
DBus Menu
Fix Released
Undecided
Michael Terry
libdbusmenu (Ubuntu)
Undecided
Michael Terry

Bug Description

with the recent updates to appmenu-gtk(0.1.91-0ubuntu1) and dbusmenu(0.3.16-0ubuntu1) totem is missing some menu items in its 'Edit' menu and also its 'Movie' menu is missing the recently played movies list. also the 'Help' menu in empathy is missing the launchpad integration items(like 'report a problem', 'translate this application' etc.) also the nautilus desktop menu is missing many items.

Also i wonder if the bug should be moved to libdbusmenu instead ;)

Related branches

Omer Akram (om26er) on 2011-01-29
summary: - few apps are missing menu items
+ some apps are missing menu items
Michael Terry (mterry) on 2011-02-03
Changed in appmenu-gtk:
assignee: nobody → Michael Terry (mterry)
Changed in appmenu-gtk (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Changed in appmenu-gtk:
status: New → Confirmed
Changed in appmenu-gtk (Ubuntu):
status: New → Confirmed
Alex Launi (alexlauni) on 2011-02-03
Changed in dbusmenu:
status: New → Incomplete
tags: added: parser
Michael Terry (mterry) wrote :

This seems to be because dbusmenu's parser just doesn't watch the underlying GtkMenu for child additions. I'm looking at adding the code now.

Michael Terry (mterry) on 2011-02-04
Changed in appmenu-gtk:
status: Confirmed → Invalid
Changed in dbusmenu:
assignee: nobody → Michael Terry (mterry)
status: Incomplete → In Progress
Changed in appmenu-gtk (Ubuntu):
status: Confirmed → Invalid
affects: appmenu-gtk (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
status: Invalid → Confirmed
Michael Terry (mterry) on 2011-02-04
Changed in dbusmenu:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.3.96-0ubuntu3

---------------
libdbusmenu (0.3.96-0ubuntu3) natty; urgency=low

  * libdbusmenu-gtk/parser.c
    - Handle ChildAdded on GtkShell items and clean up the code so that it
      has single functions for doing common operations. (LP: #709839)
 -- Ken VanDine <email address hidden> Mon, 07 Feb 2011 09:29:09 -0500

Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted) on 2011-02-10
Changed in dbusmenu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers