Application menu module for GTK+

All menu item text is invisible in Adobe Reader

Reported by u-foka on 2010-10-21
194
This bug affects 36 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Medium
Unassigned
Unity Foundations
Medium
Unassigned
Unity GTK+ module
Medium
Charles Kerr
acroread (Ubuntu)
Undecided
Unassigned
appmenu-gtk (Ubuntu)
Medium
Unassigned
unity-gtk-module (Ubuntu)
Undecided
Unassigned

Bug Description

indicator-appmenu 0.0.13-0ubuntu1, Ubuntu 10.10 beta
appmenu-gtk 0.2.0-0ubuntu1, Ubuntu 11.04

1. Launch Adobe Reader.
2. Open any menu.

What you see: All items present, and all separators visible, but the item text is invisible.
https://launchpadlibrarian.net/59735690/acroread.png

What you should see: The menu items are visible.

Related branches

lp:~charlesk/unity-gtk-module/lp-664647
Merged into lp:unity-gtk-module at revision 306
PS Jenkins bot: Approve (continuous-integration) on 2013-10-31
William Hua: Approve on 2013-10-31
u-foka (ufooka) wrote :
Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
status: New → Confirmed
Tor Klingberg (tor-klingberg) wrote :
David Barth (dbarth) wrote :

If acroread is linking with a version of gtk that is incompatible with appmenu-gtk, it should be blacklisted as well.

Changed in indicator-appmenu:
importance: Undecided → Medium
assignee: nobody → Ted Gould (ted)
Changed in indicator-appmenu (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ted Gould (ted)
milestone: none → natty-alpha-3
David Barth (dbarth) wrote :

The workaround is to prevent appmenu from loading, with env UBUNTU_MENUPROXY= acroread, see https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu#Troubleshooting

With a workaround i think we can lower the priority to medium.

Changed in indicator-appmenu (Ubuntu):
importance: High → Medium
Ted Gould (ted) on 2011-01-21
affects: indicator-appmenu → appmenu-gtk
Changed in appmenu-gtk:
status: New → Triaged
affects: indicator-appmenu (Ubuntu) → appmenu-gtk (Ubuntu)
Kalle Valo (kvalo) on 2011-02-21
Changed in appmenu-gtk (Ubuntu):
status: Confirmed → Triaged
David Barth (dbarth) on 2011-03-09
Changed in appmenu-gtk (Ubuntu):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Medium
milestone: none → ubuntu-11.04-beta-1
status: New → Triaged
Fabien Tassin (fta) wrote :

duped my bug 744361 (which just had a video showing the same problem)

David Barth (dbarth) on 2011-04-04
Changed in unity-foundations:
milestone: unity-3.8.2 → unity-3.8.4
Changed in appmenu-gtk (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
cgarre (cgarre) wrote :

Even i am having this issue .. basically the menu is blank ... in whatever color its blank. 11.04 dev i386 - acro read 9.

David Barth (dbarth) on 2011-04-12
Changed in unity-foundations:
milestone: unity-3.8.4 → unity-3.8.6
Changed in appmenu-gtk (Ubuntu):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
teimcrr (marco-carrarini) wrote :

This bug affects me as well.
Ubuntu 11.04 beta 2 fresh install, nvidia proprietary drivers
Menus are empty

areteichi (areteichi) wrote :

I installed the version inside the partner repository (for Natty) and it looks like we now have the traditional menu back. I take it that this is a temporary workaround (or regression) until we get this fully working?

Changed in appmenu-gtk (Ubuntu Natty):
milestone: none → natty-updates
status: New → Triaged
importance: Undecided → Medium
Changed in appmenu-gtk (Ubuntu Oneiric):
milestone: ubuntu-11.04 → oneiric-alpha-1
magelan (magelan) wrote :

If you mean quit Adobe Reader, type "env UBUNTU_MENUPROXY= acroread" in the terminal and then start Adobe Reader again: no, that does not work. The menu ist still blank.
Any further suggestions?

David Barth (dbarth) on 2011-08-29
Changed in unity-foundations:
milestone: unity-3.8.6 → 4.12.0
Changed in appmenu-gtk (Ubuntu Natty):
milestone: natty-updates → none
Ted Gould (ted) wrote :

Still waiting for comment from Adobe.

Changed in unity-foundations:
milestone: oneiric-beta-2 → none
Changed in appmenu-gtk (Ubuntu Oneiric):
assignee: Ted Gould (ted) → nobody
Changed in unity-foundations:
assignee: Ted Gould (ted) → nobody
Changed in appmenu-gtk:
assignee: Ted Gould (ted) → nobody
Changed in appmenu-gtk (Ubuntu Oneiric):
milestone: oneiric-alpha-1 → none
dardhal (ubuntu-24x7linux) wrote :

Just wanted to say that in an up to date Ubuntu 11.10(i386) with Acrobat Reader 9.4.2, the workaround of launching the propietary software as "env UBUNTU_MENUPROXY= acroread" works, and the software also works for non primary users in the system (that is, users created afterwards), who don't have the environmental variable set.

Thanks for the workaround.

description: updated
summary: - acroread menu captions not transfered
+ All menu item text is invisible in Adobe Reader
description: updated
brotherquintus (gkoefner) wrote :

I can confirm this bug in Oneiric with Acrobat Reader 9.4.6

The workaround
env UBUNTU_MENUPROXY= acroread
works though

Lars Uebernickel (larsu) wrote :

This has already been fixed in acroread's packaging: the startup script contains `UBUNTU_MENUPROXY=0`, which disables the global menu for this application. In precise, the menu is inside the window and all items are visible.

Changed in appmenu-gtk:
status: Triaged → Invalid
Changed in appmenu-gtk (Ubuntu):
status: Triaged → Invalid
Lars Uebernickel (larsu) on 2012-04-11
Changed in appmenu-gtk:
status: Invalid → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acroread (Ubuntu Natty):
status: New → Confirmed
Changed in acroread (Ubuntu Oneiric):
status: New → Confirmed
Changed in acroread (Ubuntu):
status: New → Confirmed

I have the problem with Acrobat Reader 9.5.1 & Ubuntu 12.04 LTS 32 bit. Notebook with 1024x600 pixels, Atom processor, 1 GByte RAM.
I don't have the problem with Acrobat Reader 9.5.1 & 12.04 LTS 64 bit. Desktop with 1920x1280 pixels, i7 processor, 8 GByte RAM.

usuari@ubuntu:~$ env | grep MENU
UBUNTU_MENUPROXY=libappmenu.so

at the two systems.

Workaround...

With menu-editor installed, edit Adobe Reader item and put as command:

env UBUNTU_MENUPROXY= acroread

Like this, Acrobat Reader has menus when is called directlly, outside Firefox.

I'm sorry. I wanted to say "alacarte" package instead.

Adrian Schmid (ascsoftware) wrote :

Exactly the same problem here: Running Ubuntu 12.04 LTS (unity)

The problem can be resolved by adding the proposed directive to the desktop launcher file.

Open the menu shortcut file:

 nano /usr/share/applications/AdobeReader.desktop

and Replace the line/s:

#Exec=/opt/Adobe/Reader9/bin/acroread
Exec=env UBUNTU_MENUPROXY=0 /opt/Adobe/Reader9/bin/acroread

This does not correct the problem but sends you back to the traditional menu.
Would be nice if this could be resolved in the Adobe Reader Installer.

This problem is present for me in 12.10 KUBUNTU for Adobe Reader and GNU Cash.
GNU Cash has repeated menu items. In the import menu, there are about 10 submenus all showing "convert".

Jeff Powell (jrpinjapan) wrote :

Here's another way to get around the problem that works via context menus (right-click->open with, double click PDF, etc).

root@marys-ubuntu:/opt/Adobe/Reader9/bin# mv acroread acroread-real
root@marys-ubuntu:/opt/Adobe/Reader9/bin# nano acroread
root@marys-ubuntu:/opt/Adobe/Reader9/bin# chmod 755 acroread

Where acroread is
env UBUNTU_MENUPROXY=0 /opt/Adobe/Reader9/bin/acroread-real $@

no longer affects: acroread (Ubuntu Natty)
no longer affects: appmenu-gtk (Ubuntu Natty)

Hi, a new acroread release (0.9.4) is available for update, could you give it a try and tell us if the problem persists?
If you still have this bug please set back the status to "new"
thanks

Changed in acroread (Ubuntu):
status: Confirmed → Incomplete
Changed in acroread (Ubuntu Oneiric):
status: Confirmed → Incomplete
Changed in appmenu-gtk (Ubuntu Oneiric):
status: Triaged → Incomplete
Changed in unity-foundations:
status: Triaged → Incomplete
Changed in appmenu-gtk:
status: Triaged → Incomplete
Damien Cassou (cassou) wrote :

Which package are you referring to exactly? As far as I can tell, there is no acroread package in 12.10 and the adobereader-enu package I see is at version 9.5.1 (bug still present).

Changed in appmenu-gtk:
status: Incomplete → Confirmed
Changed in unity-foundations:
status: Incomplete → Confirmed
Changed in acroread (Ubuntu):
status: Incomplete → Confirmed
Changed in acroread (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in appmenu-gtk (Ubuntu Oneiric):
status: Incomplete → Confirmed
krishna (krishna-k2r) wrote :

#20
I am using Ubuntu 12.04 LTS (unity)

The problem has been resolved by adding the proposed directive to the desktop launcher file.

Open the menu shortcut file:

 nano /usr/share/applications/AdobeReader.desktop

and Replace the line/s:

#Exec=/opt/Adobe/Reader9/bin/acroread
Exec=env UBUNTU_MENUPROXY=0 /opt/Adobe/Reader9/bin/acroread

Thanks to #20 author

no longer affects: acroread (Ubuntu Oneiric)
no longer affects: appmenu-gtk (Ubuntu Oneiric)
Dmitriy Kaliberda (dkaliberda) wrote :

A small addition to the script. You need to put quotes "$ @". Otherwise, the file path with spaces not open. And then the decision will be the following:

root@marys-ubuntu:/opt/Adobe/Reader9/bin# mv acroread acroread-real
root@marys-ubuntu:/opt/Adobe/Reader9/bin# nano acroread
root@marys-ubuntu:/opt/Adobe/Reader9/bin# chmod 755 acroread

Where acroread is
env UBUNTU_MENUPROXY=0 /opt/Adobe/Reader9/bin/acroread-real "$@"

Thanks to #20 author!!!

Charles Kerr (charlesk) wrote :

This is still broken in ubuntu 13.10 + acroread 9.5.5

Lars Uebernickel (larsu) wrote :

We should blacklist it.

Charles Kerr (charlesk) on 2013-10-31
Changed in unity-gtk-module:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Charles Kerr (charlesk)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-gtk-module at revision None, scheduled for release in unity-gtk-module, milestone Unknown

Changed in unity-gtk-module:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-gtk-module - 0.0.0+14.04.20131125-0ubuntu1

---------------
unity-gtk-module (0.0.0+14.04.20131125-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Add acroread to the blacklist. (LP: #664647)

  [ William Hua ]
  * Freeciv uses multiple menu bars in its UI. When unity-gtk-module
    tries to export its menus, it becomes really cramped in the global
    menu to the point of being unusable. It's better to allow Freeciv to
    keep its menus where they are in this case. (LP: #1242937)
  * Add a GSettings schema that allows the user to set a blacklist and
    whitelist for unity-gtk-module (LP: #1243413). (LP: #1243413)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 308
 -- Ubuntu daily release <email address hidden> Mon, 25 Nov 2013 03:55:07 +0000

Changed in unity-gtk-module (Ubuntu):
status: New → Fix Released
Charles Kerr (charlesk) on 2014-03-13
Changed in unity-gtk-module:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers