Cannot run AppImages with sudo

Bug #1865238 reported by Peter J. Mello
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

From @colemanlee on GitHub:

I also meet this problem when I run ./pling-store-5.0.1-1-x86_64.AppImage in ROOT graphical interface.

My system information:
Linux debian 5.3.0-1-686-pae #1 SMP Debian 5.3.7-1 (2019-10-19) i686 GNU/Linux
deb package information:
# apt-cache show appimagelauncher
Package: appimagelauncher
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 56454
Maintainer: TheAssassin
Architecture: i386
Version: 2.0.2-travis883~f5ac870+buster
Description: AppImageLauncher built using CMake

Yes, I modified the system and log in the system graphical interface with root for some test purpose.
Then I tried to login normal user mode in the graphical interface, and run the command:

sudo ./HastyHeroes-1.0.0-x86_64.AppImage

If I run the command:

The error appears when I click the "Run once" button:

execv() failed: executable file format error

I have no idea how to run AppImage on Debian 10 now.
I open a new issue in order to allow for debugging.

Revision history for this message
Peter J. Mello (roguescholar) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.