After waking from sleep, the system prompts me for administrator password 3 times to update system sources [$75]

Bug #1617687 reported by Forrest Robertson on 2016-08-28
530
This bug affects 111 people
Affects Status Importance Assigned to Milestone
AppCenter
Fix Released
High
Jeremy Wootten

Bug Description

This happens every time the I close the lid of my laptop and then reopen it later.

ProblemType: Bug
DistroRelease: elementary 0.4
Package: elementary-desktop 1.414+469+r1~daily~ubuntu0.4.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
Uname: Linux 4.4.0-34-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Sat Aug 27 22:01:53 2016
InstallationDate: Installed on 2016-08-28 (0 days ago)
InstallationMedia: elementary OS 0.4 "Loki" - Daily amd64 (20160716)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Forrest Robertson (forrest-f) wrote :
Daniel Fore (danrabbit) wrote :

I can confirm this. It seems to get progressively worse throwing more and more dialogs.

affects: elementaryos → appcenter
Changed in appcenter:
status: New → Confirmed
importance: Undecided → High
Daniel Fore (danrabbit) wrote :
tags: added: bounty
summary: After waking from sleep, the system prompts me for administrator
- password 3 times to update system sources
+ password 3 times to update system sources [$20]

After installing updates last night this seems to have gone away. I will continue testing this to see if this is a permanent fix or if it just a temporary thing. If it is still gone 3 days from now I will see if there is a way to close this bug.

Zisu Andrei (matzipan) wrote :

OP, is this issue gone?

Forrest Robertson (forrest-f) wrote :

Nope, just checked and it prompted me to enter my password 4 times after logging in after resuming from sleep. So it may have been fixed but recent updates may have broken it again?

Davide Aguiari (gorghino) wrote :

I've this bug too.

Linux dago 4.4.0-36-generic
Loki Beta 2

Davide Aguiari (gorghino) wrote :

12 times this time :/

Changed in appcenter:
status: Confirmed → In Progress
assignee: nobody → Jeremy Wootten (jeremywootten)
Max (max-bordelon) wrote :

I've experienced this Authentication Required behavior on a fresh install of Loki stable. I am not using a laptop. The system is just utilizing it's default settings of "Turn off display when inactive for: 15 minutes" and also "Sleep when inactive for: Never" I have not changed any default power or screen saver settings.

So unless the Dell bios is putting the system to sleep, given the above default settings, the system should just be returning from a display off mode, and not sleep, standby, or some hibernate mode.

Also, I didn't see it mentioned, but the root user password does not clear the box. It continues to display "Authentication failed. Please try again."

Pavel Dolinin (pavel-dolinin) wrote :

Have the same issue on my Dell XPS 13 laptop with Loki stable.

Obro Ahmed (obro) wrote :

same here... :(

Changed in appcenter:
status: In Progress → Confirmed
Daniel Fore (danrabbit) on 2016-09-30
Changed in appcenter:
status: Confirmed → In Progress
milestone: none → juno-beta1
Sam Kelly (sa3) wrote :

This bug also affects me. I have a Lenovo T440s. Only happens on resume from sleep. I get 1-5 login boxes. Seems to be random how many.

smatt (simonmatt1999) wrote :

Same here

Reproduce in my context:

1. Click on power icon
2. Click on suspend
3. Wake up notebook
4. Log in
5. There are 4 dialog instances open at the same time (appearing at once)

System: elementary OS 0.4 loki (Kernel: x86_64 Linux 4.4.0-38-generic).
Notebook: Acer Aspire V3-571G

Note:
After suspend and wake up there are exactly 4 new entries "/usr/lib/policykit-1/polkit-agent-helper-1 simon" in running "ps aux". Maybe this helps?

smatt (simonmatt1999) wrote :

Confirming what Max (Comment #9) said. I encountered the same yesterday.

> Also, I didn't see it mentioned, but the root user password does not clear the box. It continues to display "Authentication failed. Please try again."

Nemo (liapman) wrote :

This bug affects me as well. I've got Elementary OS Loki 0.4 installed on my Dell XPS 13. I've been having one or more instances of this dialog appearing when the laptop is resumed from sleep for a while now.

ttosttos (ttosttos) wrote :

Facing a catastrophic bug that seems to match this description. Every time the desktop is locked, the systems keeps asking for authentication to update sources in the background. In the best case scenario, unlocking the desktop gives you a flurry of authentication dialogs (see attachment). In the worse case scenario, unlocking the desktop presents a black screen where the pointer is the only responsive element. Maybe a very high number of dialog windows accumulates and gala gets sick? In a few cases, the desktop is rendered after a minute or so of the black screen. In most cases, the black screen stays there. I'm not sure how to properly restart gala from tty1, so I ultimately have to reboot my system. I have to do so multiple times a day :-(

ttosttos (ttosttos) wrote :

Fix should really be made available in Loki. Milestone shows juno-beta1.

Jeremy Wootten (jeremywootten) wrote :

ttosttos: The fix should ready soon I hope.

Although I do experience this bug I have only ever had two or three dialogs overlaid and then only after suspending overnight.

It is unclear why some people experience it so much worse, but if that is the case I tend to agree its should be released as soon as proven stable. It is possible that in these bad cases, something else is going on that the current fix does not address of course - let us hope not.

colej4586 (colej4586) wrote :

Also affected

Details:
elementary OS 0.4 Loki (64-bit)
ThinkPad X1 1st gen

Lassaad Ben Saad (lassaad-bs) wrote :

same thing here
http://hpics.li/edf3453

Also affected

Details:
elementary OS 0.4 Loki (64-bit)
System76
Model: Lemur
Version: lemu6

Simon Butcher (sbutcher) wrote :

Jeremy
is there some documentation on how I can test the code on your bramch? happy to be a testing guinea pig

Jeremy Wootten (jeremywootten) wrote :

Simon: Thanks for the offer to test. There are (very) brief instructions for building and installing the code in the "INSTALL" file in the source code. You will need to have, or acquire, some familiarity with bzr (see https://elementary.io/developer for some information) and have all the necessary tools and build dependencies installed. You will have to use the "sudo make install" command and after installing, restart your system to make sure that it is the new version of appcenter that is running in the background. Let me know if you need more details.

Then it just a question of doing what you normally do to produce the problem and see if this branch fixes it for you. The main known deficiency in the branch as it stands is that you must log in reasonably promptly (within one minute) after the log-in screen shows otherwise you will still get a single authentication request. The branch should at least prevent multiple authentication requests.

generalnie (general-nie) wrote :

As I see some people may not know what is the workaround for now: to avoid these prompts you need to disable AppCenter in startup applications (gnome-session-properties). As long as it is not running everything will be fine.

Zach Burnham (thejambi) wrote :

Experiencing this. Basically is rendering the machine unusable after an extended period of screen lock. Quite a bad first impression of a stable release.

Daniel Fore (danrabbit) on 2016-10-17
Changed in appcenter:
status: In Progress → Fix Committed
Jaden (mativista) wrote :

The problem still persists even after disabling AppCenter in startup applications. This fix does NOT work anymore. I am using a fully updated Loki x64 on a ThinkPad T410.

Same here, fully updated Loki on Thinkpad x230i, still having the issue to this day.

Klaus Rennecke (kre) wrote :

For me, on elementaryOS Loki the packagekit was drawing a lot of power because I have very frequent network changes (docker containers) so I disabled it

sudo systemctl mask packagekit

and that also silenced the AppCenter apparently.

Warning: You will need to fetch and install updates by hand if you use that!

TC (smalltimer) wrote :

Yup, have the same bug. It's even more severe if you suspend the laptop, then dock it, and then try to wake. Just freezes up the whole system.

Victor (victorcalvo12) wrote :

I might be a tad late, but I think there might be a correlation between the number of prompts that appear and the number of tasks running on the computer upon suspension. I've suspended the system after a restart and only received a handful of prompts. If I suspend the system after an extended period of work without closing any programs I will have upwards of 15 prompts on system wake. Haven't gotten a chance to verify this theory since I need to determine which tasks using the top command might be associated with needing authentication.

Akhil (akhilrrocks) wrote :

This happens every time the screen is locked for some period. The number of popups seems to be proportional to the duration of the screen lock period. After a prolonged period of screen lock, after logging in, the screen goes completely blank.

In such case, I log in to the virtual console to see there are about 70-80 instances of these two processes and I have to kill all of them.

1. /๐˜‚๐˜€๐—ฟ/๐—น๐—ถ๐—ฏ/๐—ฝ๐—ผ๐—น๐—ถ๐—ฐ๐˜†๐—ธ๐—ถ๐˜-๐Ÿญ/๐—ฝ๐—ผ๐—น๐—ธ๐—ถ๐˜-๐—ฎ๐—ด๐—ฒ๐—ป๐˜-๐—ต๐—ฒ๐—น๐—ฝ๐—ฒ๐—ฟ-๐Ÿญ

2. ๐˜‡๐—ฒ๐—ป๐—ถ๐˜๐˜† --๐—พ๐˜‚๐—ฒ๐˜€๐˜๐—ถ๐—ผ๐—ป --๐—ฑ๐—ถ๐˜€๐—ฝ๐—น๐—ฎ๐˜† :๐Ÿฌ.๐Ÿฌ --๐—ฐ๐—น๐—ฎ๐˜€๐˜€ ๐—บ๐˜‚๐˜๐˜๐—ฒ๐—ฟ-๐—ฑ๐—ถ๐—ฎ๐—น๐—ผ๐—ด --๐˜๐—ถ๐˜๐—น๐—ฒ --๐˜๐—ฒ๐˜…๐˜ <๐—ฏ๐—ถ๐—ด><๐—ฏ>"๐—”๐˜‚๐˜๐—ต๐—ฒ๐—ป๐˜๐—ถ๐—ฐ๐—ฎ๐˜๐—ถ๐—ผ๐—ป ๐——๐—ถ๐—ฎ๐—น๐—ผ๐—ด" ๐—ถ๐˜€ ๐—ป๐—ผ๐˜ ๐—ฟ๐—ฒ๐˜€๐—ฝ๐—ผ๐—ป๐—ฑ๐—ถ๐—ป๐—ด.</๐—ฏ></๐—ฏ๐—ถ๐—ด> ๐—ฌ๐—ผ๐˜‚ ๐—บ๐—ฎ๐˜† ๐—ฐ๐—ต๐—ผ๐—ผ๐˜€๐—ฒ ๐˜๐—ผ ๐˜„๐—ฎ๐—ถ๐˜ ๐—ฎ ๐˜€๐—ต๐—ผ๐—ฟ๐˜ ๐˜„๐—ต๐—ถ๐—น๐—ฒ ๐—ณ๐—ผ๐—ฟ ๐—ถ๐˜ ๐˜๐—ผ ๐—ฐ๐—ผ๐—ป๐˜๐—ถ๐—ป๐˜‚๐—ฒ ๐—ผ๐—ฟ ๐—ณ๐—ผ๐—ฟ๐—ฐ๐—ฒ ๐˜๐—ต๐—ฒ ๐—ฎ๐—ฝ๐—ฝ๐—น๐—ถ๐—ฐ๐—ฎ๐˜๐—ถ๐—ผ๐—ป ๐˜๐—ผ ๐—พ๐˜‚๐—ถ๐˜ ๐—ฒ๐—ป๐˜๐—ถ๐—ฟ๐—ฒ๐—น๐˜†. --๐—ผ๐—ธ-๐—น๐—ฎ๐—ฏ๐—ฒ๐—น _๐—ช๐—ฎ๐—ถ๐˜ --๐—ฐ๐—ฎ๐—ป๐—ฐ๐—ฒ๐—น-๐—น๐—ฎ๐—ฏ๐—ฒ๐—น _๐—™๐—ผ๐—ฟ๐—ฐ๐—ฒ ๐—ค๐˜‚๐—ถ๐˜ --๐—ถ๐—ฐ๐—ผ๐—ป-๐—ป๐—ฎ๐—บ๐—ฒ ๐—ณ๐—ฎ๐—ฐ๐—ฒ-๐˜€๐—ฎ๐—ฑ-๐˜€๐˜†๐—บ๐—ฏ๐—ผ๐—น๐—ถ๐—ฐ --๐—บ๐—ผ๐—ฑ๐—ฎ๐—น

Romi (iammhr) on 2016-10-25
Changed in appcenter:
status: Fix Committed → Fix Released
Romi (iammhr) wrote :

I am sorry, i was trying to figure out what's the difference between Fix Committed and Fix released and I mistakenly pressed the fix released option (i thought i would get some explanation about that option and/or release dates may be if i click on it). BUT It changed!!! I don't know why! I am not affiliated with this project and i should not be able to change that. I don't know how launchpad works. Anyway I am really really sorry. Now i cannot change it back where it was. I don't think the Fix is released. Apologies.

Changed in appcenter:
status: Fix Released → Fix Committed
osocron (osocron) wrote :

Have the same bug here!

Cody Garver (codygarver) on 2016-10-29
Changed in appcenter:
milestone: juno-beta1 → 0.1.2
status: Fix Committed → Fix Released
Kenedy Silva (kenedyrms) wrote :

After Fix Released bug still happen here in my system.

PS: System is updated

Sorry my English!

Jeremy Wootten (jeremywootten) wrote :

Kenedy (and any one else reporting this bug) : Please specify exactly the circumstances producing it and (approx) how many prompts you get. In particular, how long was the computer suspended? Did you manually suspend it from the wingpanel? Or was it after an inactivity timeout? Or by closing the lid? Or did you just lock the screen and leave the login screen showing?

It is known that the current "fix" is limited in scope - it only works fully if the computer is suspended (as per the original bug report) and if you log in within one minute of the computer waking up. It should at least reduce the number of prompts otherwise. The problem is not entirely with AppCenter. Hopefully a full solution will be found soon.

Jeremy Wootten (jeremywootten) wrote :

Please also note that the fix will not take effect until the background appcenter process is restarted by logging out or restarting the computer.

Akhil (akhilrrocks) wrote :

This fix seems to be working. I'm no longer facing this issue after the update. Thanks.

Kenedy Silva (kenedyrms) wrote :

Sorry guys today I test it better and it works.
It Works when I close my laptop
It Works when I manually suspend my machine
It Works when I wait for automatic suspend on Battery

Sorry again that fix really works and sorry my bad English

Works for me after a close-lid suspend. if i login straight away i get no
dialog box.

If i wait 1 minute and then login, i receive a single message that needs
cancelling, as expected.

unsure why there is no way to test that the network is up, rather than
waiting 1 minute before refreshing sources, but this is excellent progress,
thank you.

On 31 October 2016 at 12:00, Kenedy Silva <email address hidden> wrote:

> Sorry guys today I test it better and it works.
> It Works when I close my laptop
> It Works when I manually suspend my machine
> It Works when I wait for automatic suspend on Battery
>
> Sorry again that fix really works and sorry my bad English
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1617687
>
> Title:
> After waking from sleep, the system prompts me for administrator
> password 3 times to update system sources [$20]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/appcenter/+bug/1617687/+subscriptions
>

Maxim Taranov (png2378) wrote :

The bounty is not paid until now.

summary: After waking from sleep, the system prompts me for administrator
- password 3 times to update system sources [$20]
+ password 3 times to update system sources [$75]
MBWD (xmbwd) wrote :

This bug is still alive for me running App Center 0.1.3 on a fully upgraded version of Loki. As stated in the original description, it happens after waking from sleep. However, for me at least, it is intermittent. But it has been present since before 0.1.3 and after upgrading as well (it just happened about 5 minutes ago).

Post 35.5 and the bug status both suggest that this was resolved with the 0.1.2 version of App Center. But that does not appear to be the case.

Changed in appcenter:
milestone: juno-beta1 โ†’ 0.1.2
status: Fix Committed โ†’ Fix Released

MBWD (xmbwd) wrote :

Oops. Just saw post #37. Here are the details:

Happens both on (A) wake from lid close suspend and (B) automatic screen lock after set timeout, but without any suspend.

On wake from lid close suspend, I have only received 1 notice.

On login from screen lock, I received 2 notices stacked on top of each other.

Jeremy Wootten (jeremywootten) wrote :

MBWD: Sorry to hear you are still experiencing a problem - could you just confirm you have restarted the computer to make sure the new version of appcenter running (just updating will not do this)? Some people have reported that the problem is fixed. If you are still experiencing the problem please specify how long you are leaving the computer suspended.

Jeremy Wootten (jeremywootten) wrote :

MBWD: Another thing - do you close the appcenter window or just minimise it after use?

MBWD (xmbwd) wrote :

Jeremy:

Yes, I can confirm that I have restarted the computer and the behavior persists.

As noted above, it is not just suspend, but also screen lock that causes the problem for me. On suspend, it can be minutes or hours.

When done using the AppCenter, I quit it using the x button.

Any prospects on a fix for this?

Thanks.

Luke Arms (lkrms) wrote :

Still happening today (although the dialog is a little different to the one that appeared when Loki launched--screencap attached). It also doesn't seem to spawn like it used to -- I haven't had to click Cancel more than twice per incident.

Geniusoff (igor-kot) wrote :

Confirm that this issue is still present on fresh installed and fully upgraded Loki.

'Authentication Required' - 'Authentication is required to refresh the system resources'

And it doesn't accept my password - 'Authentication failed. Please try again'.

I have only one option - 'Cancel' this dialog

Maliktunga (maliktunga) wrote :

I confirm that this issue is still present on Loki.

Jeremy Wootten (jeremywootten) wrote :

I cannot reproduce this bug anymore on my system. I usually suspend the system using the drop-down menu on the wingpanel and wait until the system suspends before closing the lid. I close the AppCenter window (if open) first. On coming out of suspend I often get a wingpanel notification that new updates are available but no request for password. My user account has admin rights.

MBWD (xmbwd) wrote :

At least for me, this is an intermittent bug. I would estimate that it occurs something between 5% and 10% of the time.

antonio (blancog) wrote :

Same as Geniusoff (igor-kot)

q (elixir75) wrote :

Doesn't seem fixed. I'm experiencing this on a fresh install of 0.4.1 on a desktop.

supertrack (supertrackster) wrote :

Yes, doesn't fixed. The same bug, in 0.4.1 just installed, on a Asus UX330.

Tarun Singh (tarun7singh) wrote :

The bug is occurring on fresh install of Loki 0.4.1, it doesn't even accepts the password of superuser, tried for more then three times. Occurs after waking laptop from suspend. Screenshot attached.

information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Public
Ronald Wright (linuxviking) wrote :

I have Loki running on an Intel i7 8-core with hyperthreading, 32 GB RAM, 1 TB HD. I have gotten as many as 36 AppCenter requests for admin password upon waking up.

raymond shpeley (rshpeley) wrote :

Suse linux has a similar problem, (https://forums.opensuse.org/showthread.php/502754-quot-Authentication-is-required-to-refresh-the-system-resources-quot).

In that thread wolfi323 said, "If you are logged in via remote desktop, you do not have the permissions to refresh the software repositories, install updates, or even mount removable media.
Only a user logged in locally may do that." It seems to me that when elementary os is locked, or suspended, or sleeping, or in any other condition than where a user is logged in then as wolf323 also says, "This is no bug then. These are the default security settings."

The workaround given in that thread (disable the apper monitor on suse) is the same as given in https://elementaryos.stackexchange.com/questions/7447/multiple-password-prompts-on-resume-from-sleep-authentication-is-required-to-r -- disable appcenter dock reminder on eos.

So it's pretty clear that the authentication dialogues are occurring because appcenter is attempting to refresh software repositories in the same way that suse apper monitor is (and with the same error dialogue).

I think it's safe to say that permissions are not the problem and disabling the appcenter dock reminder is not a solution. What could work as a solution is to disable appcenter from attempting to refresh software repositories while a user is not logged in. A check on login status would do.

I assume this would have the effect of changing the appcenter policy from "always check for software repository changes" to "check for software repository changes only during a valid user login session." This may mean a slowdown in informing a logged-in user of a change in repository status (since the status is not waiting for them as soon as they login), but I would think this delay to be a good trade-off.

raymond shpeley (rshpeley) wrote :

For the record, I experienced this same issue after locking my account manually, with the appcenter open, and being away from the computer for a few hours. On logging in I got what appeared to be one error dialogue, but were likely many in the same screen location. I must have hit the cancel button 30 times or more.

My account has admin rights and it doesn't login automatically (goes without saying I suppose). All of the software is the most recent.

Ronald Wright (linuxviking) wrote :

I saw that the appcenter -s was listed in task manager, and couldn't find any details about it online. I killed that process. When my I woke this Elementary OS Loki platform, I didn't see any requests for admin password from the appcenter, nor the authentication failure notice. The system woke right up and my desktop appeared without any issues. I just don't see the system update option when I launch appcenter from the desktop, select updates. Does the appcenter -s mean a system process?

Ronald Wright (linuxviking) wrote :

From what I see, the appcenter -s is where this problem occurs.

Ronald Wright (linuxviking) wrote :

Since I terminated the appcenter -s, every wake up has been without the request for admin password. The desktop appears as quickly as it did before this bug. I hope that I am reporting this information to the correct blog.

Ronald Wright (linuxviking) wrote :

I don't however, see the system update section of the appcenter UPDATES section. Is it safe to assume that the appcenter -s is for updating the kernel and Loki?

Ronald Wright (linuxviking) wrote :

After a reboot, appcenter is using 2.32 GB of RAM, second only to my browser. Appcenter is not in the top five processes currently running. The amount of RAM held/used by appcenter has gone up in the last 3 days since the last reboot.

Davide Aguiari (gorghino) wrote :

Still happens to me after resuming. The prompt doesn't accept my root password.
Linux 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Elementary 0.4.1 Loki

Zisu Andrei (matzipan) wrote :

Please reopen this bug on the github AppCenter repository, instead.

Grant (gsupp) wrote :

> Please reopen this bug on the github AppCenter repository, instead.

https://github.com/elementary/appcenter/issues/499

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.