Memory leaking when null-xxx profiles are removed or replaced

Bug #539437 reported by John Johansen on 2010-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppArmor
Undecided
John Johansen

Bug Description

Bug found in code review.

When profile replacement, or removal is done on any null-xxxx profile, its memory is not freed (continuing to consume kernel memory resources). This occurs because null- profiles have the PFLAG_NO_LIST_REF flag set, but currently which means when they are removed from the profile list that there is no reference to put. However this is not the case and the null- profile never reaches a 0 refcount because of it.

Changed in apparmor:
status: New → Confirmed
assignee: nobody → John Johansen (jjohansen)
Andy Whitcroft (apw) on 2010-03-30
Changed in apparmor:
status: Confirmed → Fix Committed
Steve Beattie (sbeattie) wrote :

The fix for this has been released.

Changed in apparmor:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers