Regression tests can not detect binfmt_elf mmpa semantic change

Bug #1630069 reported by John Johansen on 2016-10-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppArmor
Undecided
John Johansen
apparmor (Ubuntu)
Undecided
Unassigned
Xenial
Low
Tyler Hicks
Yakkety
Undecided
Unassigned
linux (Ubuntu)
Undecided
John Johansen
Xenial
Undecided
Unassigned
Yakkety
Undecided
John Johansen

Bug Description

== apparmor SRU ==

[Impact]

 * The exec_stack.sh regression test fails due to a behavior change in 4.8
   kernels from this patch:

   commit 9f834ec18defc369d73ccf9e87a2790bfa05bf46
   Author: Linus Torvalds <email address hidden>
   Date: Mon Aug 22 16:41:46 2016 -0700

       binfmt_elf: switch to new creds when switching to new mm

 * The regression tests were fixed for this kernel change but they were fixed
   in a way that always assumed that kernel change is present. They should have
   been adjusted so that they act differently according to whether or not the
   kernel change is present (it is a change that could end up being backported
   through the stable trees).

[Test Case]

 $ apt-get source apparmor # make sure this fetches the new apparmor source
 $ sudo apt-get install libapparmor-dev
 $ cd tests/regression/apparmor
 $ make USE_SYSTEM=1
 $ sudo bash exec_stack.sh

 The previous command should result in no output and return value of 0.

[Regression Potential]

 * This is an extremely low risk change since it only touches regression
   testing code that is not user-facing.

[Other]

 * Fixed in upstream lp:apparmor tree:

   https://bazaar.launchpad.net/~apparmor-dev/apparmor/master/revision/3558

== Original description ==

The regression tests are currently hard coded to the semantics of mmap in binfmt_elf

With the recent upstream commit 9f834ec18defc369d73ccf9e87a2790bfa05bf46 the cred used for the mmap changed resulting in test failures. The tests have been patched for this change but it results in the test breaking for everyone using upstream releases against pre 4.8 kernels.

Changed in linux (Ubuntu):
milestone: none → ubuntu-16.10
Changed in linux (Ubuntu Yakkety):
assignee: nobody → John Johansen (jjohansen)
Changed in apparmor:
assignee: nobody → John Johansen (jjohansen)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1630069

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in apparmor:
status: New → Fix Committed
Changed in linux (Ubuntu Yakkety):
status: Incomplete → In Progress
Tyler Hicks (tyhicks) wrote :

The Yakkety apparmor package does not need this change since the Yakkety kernel will always have kernel commit 9f834ec18defc369d73ccf9e87a2790bfa05bf46 present.

description: updated
Changed in apparmor (Ubuntu Yakkety):
status: New → Won't Fix
Changed in apparmor (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Low
Changed in apparmor (Ubuntu Yakkety):
assignee: nobody → Tyler Hicks (tyhicks)
Changed in apparmor (Ubuntu Xenial):
assignee: nobody → Tyler Hicks (tyhicks)
Changed in apparmor (Ubuntu Yakkety):
assignee: Tyler Hicks (tyhicks) → nobody
Tyler Hicks (tyhicks) on 2016-10-07
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.8.0-21.23

---------------
linux (4.8.0-21.23) yakkety; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1630279

  * powerpc 4.8.0-17 fails to boot on PowerMac G5 (LP: #1628968)
    - Revert "Revert "powerpc: Simplify module TOC handling""

  * Regression tests can not detect binfmt_elf mmpa semantic change
    (LP: #1630069)
    - SAUCE: apparmor: add flag to detect semantic change, to binfmt_elf mmap

  * Autofs parameter substitution broken in kernel 4.4.0-38 and 4.4.0-40
    (LP: #1629204)
    - SAUCE: (namespace) autofs4: Use real_cred for requestor's ids

 -- Tim Gardner <email address hidden> Tue, 04 Oct 2016 08:01:21 -0600

Changed in linux (Ubuntu Yakkety):
status: In Progress → Fix Released

Hello John, or anyone else affected,

Accepted apparmor into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apparmor/2.10.95-0ubuntu2.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apparmor (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Tyler Hicks (tyhicks) wrote :

I've completed the AppArmor test plan:

  https://wiki.ubuntu.com/Process/Merges/TestPlans/AppArmor

I've also manually verified the AppArmor portion of this SRU with the kernel currently in xenial-updates (4.4.0-45.66) and the kernel in xenial-proposed (4.4.0-46.67), which contains a number of AppArmor changes.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.10.95-0ubuntu2.5

---------------
apparmor (2.10.95-0ubuntu2.5) xenial; urgency=medium

  * debian/lib/apparmor/functions, debian/apparmor.init,
    debian/apparmor.service, debian/apparmor.upstart,
    debian/lib/apparmor/profile-load: Adjust the checks that previously kept
    AppArmor policy from being loaded while booting a container. Now we
    attempt to load policy if we're in a LXD or LXC managed container that is
    using profile stacking inside of a policy namespace. (LP: #1628285)
  * Fix regression tests for stacking so that the kernel SRU process is not
    interrupted by failing tests whenever the AppArmor stacking features are
    backported from the 16.10 kernel or when the 16.04 LTS Enablement Stack
    receives a 4.8 or newer kernel
    - debian/patches/r3509-tests-fix-exec_stack-errors-1.patch: Fix the
      exec_stack.sh test when running on 4.8 or newer kernels (LP: #1628745)
    - debian/patches/r3558-tests-fix-exec_stack-errors-2.patch: Adjust the
      exec_stack.sh fix mentioned above to more accurately test kernels older
      than 4.8 (LP: #1630069)
    - debian/patches/allow-stacking-tests-to-use-system.patch: Apply this
      patch earlier in the series, as to match when it was committed upstream,
      so that the above two patches can be cherry-picked from lp:apparmor

 -- Tyler Hicks <email address hidden> Fri, 07 Oct 2016 05:21:44 +0000

Changed in apparmor (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apparmor has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in apparmor (Ubuntu):
status: New → Fix Released
Changed in apparmor:
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Xenial):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers