ptrace regression test fails to compile on arm64 platforms

Bug #1470985 reported by Steve Beattie on 2015-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppArmor
Undecided
Unassigned
2.9
Undecided
Unassigned

Bug Description

While attempting to run the apparmor regression tests on on arm64 machine, the ptrace regression test fails to compile:

1166. cc -g -O0 -Wall -Wstrict-prototypes ptrace.c -lapparmor -o ptrace
1167. ptrace.c: In function ‘do_parent’:
1168. ptrace.c:40:14: error: storage size of ‘regs’ isn’t known
1169. struct user regs;
1170. ^
1171. ptrace.c:92:14: error: ‘PTRACE_GETREGS’ undeclared (first use in this function)
1172. if (ptrace(PTRACE_GETREGS, pid, NULL, ®s) == -1) {
1173. ^
1174. ptrace.c:92:14: note: each undeclared identifier is reported only once for each function it appears in
1175. ptrace.c:40:14: warning: unused variable ‘regs’ [-Wunused-variable]
1176. struct user regs;
1177. ^
1178. : recipe for target 'ptrace' failed
1179. make: *** [ptrace] Error 1

This is due to the arm64 platform only supporting the PTRACE_GETREGSET interface. As this interface is the preferred mechanism for getting access to arch-specific register information [0], the ptrace should be converted to using this by default.

[0] https://sourceware.org/ml/archer/2010-q3/msg00193.html

Revision history for this message
Steve Beattie (sbeattie) wrote :
Changed in apparmor:
status: New → Triaged
milestone: none → 2.10
Steve Beattie (sbeattie) on 2015-07-14
Changed in apparmor:
status: Triaged → Fix Committed
Revision history for this message
Steve Beattie (sbeattie) wrote :

AppArmor 2.10 has been released: https://launchpad.net/apparmor/2.10/2.10

Changed in apparmor:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers