[hg] Uncatched error in hgrc update

Bug #1208745 reported by Georges Racinet on 2013-08-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenERP buildout recipe
Low
Unassigned

Bug Description

Here's the relevant part of the tracebak I just got in a buildbot build:

  File "/srv/buildslave/privbot.anybox.fr/buildout-caches/eggs/anybox.recipe.openerp-1.7.0-py2.7.egg/anybox/recipe/openerp/vcs/hg.py", line 155, in get_update
    self.update_hgrc_paths()
  File "/srv/buildslave/privbot.anybox.fr/buildout-caches/eggs/anybox.recipe.openerp-1.7.0-py2.7.egg/anybox/recipe/openerp/vcs/hg.py", line 25, in update_hgrc_paths
    default = parser.get('paths', 'default')
  File "/usr/lib/python2.7/ConfigParser.py", line 607, in get
    raise NoSectionError(section)
NoSectionError: No section: 'paths'

Funny thing is that 'paths' does seem to exist afterwards. It's probably a rare condition

Anyway, this one should be catched and logged, even if that means that the paths don't get properly updated.

Related branches

Georges Racinet (gracinet) wrote :

Got it again, it's the error one gets if a repo is changed to not be a so-called standalone any more

This error occurs with me because I tried to add a new repository in the .Cfg

Which had already been previously cloned in the same directory manually.

Georges Racinet (gracinet) wrote :

okay, I'll deal with it, it's been around long enough, thanks for the heads up !

Indeed there are plenty of reasons not to have a [paths] section in .hg/hgrc
For instance, creating the repo with hg init

Changed in anybox.recipe.openerp:
milestone: none → 1.8.5
status: New → Confirmed
Changed in anybox.recipe.openerp:
status: Confirmed → Fix Committed
Changed in anybox.recipe.openerp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers